Sada je: 15 pro 2019, 17:22.
Diskusije usko vezane uz Ubuntu i srodne distribucije (Kubuntu, Xubuntu, Lubuntu, LinuxMint...)

Moderator/ica: Moderatori/ce

Instalirao sam Ubuntu 13.10, 64 bit kako dual boot na desktop kompjuter na kojem je vec bio instaliran Windows 8.1. Ubuntu je instaliran da se pokreće preko Grub-a ne preko wubi-ja.
No međutim svaki puta prilikom pokretanja kompjutera umjesto Grub-a pokrene se odma Windows 8.1.

Več sam tražio po forumima pa sam našao da moram isključiti opciju brzoga pokretanja, tj da isključim ono hibernacijsko pokretanje (Fast startup) win 8.1.
Ali i dalje se događa ista stvar. Bio san nanovo intalirao Ubuntu da vidiim jesam li mozda pogriješio ali događa se opet ista stvar. Također sam po savjetu na jednome drugom forumu promjenio prioritete boot-anja s jednog na drugi hard disc ali isto se ništa nije promjenilo.

Ima li tko možda kakvo riješenje?
Hvala na odgovorima

Moja kofiguracija je ako nekome slučajno treba da detekciju problema:

AMD Phenom II X4 965 processor
AMD Radeon HD 6670 grafic card
Maxtor 6y080M0 ATA hard disc 1
WDC WD5000 AAKX - 083CA0 ATA hard disc 2
ASRock 970 Extreme3 motherboard
RAM: DD3 8 GB
............................................
BIOS: AMI (OEM) P1.60
Avatar
Postovi: 5
Postovi: 5
Pridružen/a: 25 vel 2014, 11:14
Lokacija: Kotor Varoš BiH / Knin HR
Podijelio/la zahvalu: 2 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Ubuntu 13.10, Gnome
Na koji hard disk si instalirao Ubuntu? Naveo si da je pored Windows 8...,
Kada si instalirao, i dodjeljivao particije, gdje si postavio grub da se instalira?
Mislim da opcija brzog pokretanja ne utiče na izbor OS-a prilikom boot-a ili griješim
Avatar
Postovi: 1801
Postovi: 1801
Pridružen/a: 15 sij 2014, 09:37
Lokacija: Zaljev svetaca
Podijelio/la zahvalu: 69 puta
Primio/la zahvalu: 177 puta
Spol:
OS: Leap 15.1 / Hera 5.1
Imam dva hard diska. na jednom mi je instaliran windows 8.1 a na drugi sam instaliro Ubuntu 13.10.
Windowsi mi se nalaze na sda -> sda1, a ubuntu je instaliran na sdb-> sdb1. Vec sam u bios-u mjenjo prioritete boot-anja na oba hard diska ali je isto stanje, uvjek se samo pokrece windows 8.1.

Ntko mi je na jednom drugom forumu poslao da probam s nekim supergrub2 instalacijom ali ne znam kako bih taj supergrub 2 mogao instalirati preko uSB-a budući da ni jedan od programa za kreiranje boot-aabilnih USB-ova ne podržava taj format. Konkretno ne mogu ga instalirati preko Rufus-a ni preko Pen drive-a...
Avatar
Postovi: 5
Postovi: 5
Pridružen/a: 25 vel 2014, 11:14
Lokacija: Kotor Varoš BiH / Knin HR
Podijelio/la zahvalu: 2 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Ubuntu 13.10, Gnome
Stavi da ti je defaultni boot disk sdb. Na njemu ti je očito GRUB, a na sda standardni windowsov boot loader koji ne priznaje ništa osim sebe.
Arch Linux Install Script
Hash Checker
Vl@do je napisao/la:Arch imaš upravo zato da uštediš na vremenu. Nemaš nikakvih problema s instalacijama, kompajliranjem i ostalim. Imaš jednostavno funkcionalan i stabilan, uvijek najsvježiji OS, a osim toga je sexy i cool do neba.

I've seen some idiots back in my days but you man... you're special!
Avatar
Moderator
Postovi: 6249
Moderator
Postovi: 6249
Pridružen/a: 13 stu 2010, 21:12
Lokacija: /hrvatska/split/.../9/7
Podijelio/la zahvalu: 266 puta
Primio/la zahvalu: 324 puta
Spol: M
OS: Arch MATE/Xfce
Stavio sam bio pa je opet ista stvar. Bio sam probo popravit stvar preko ovoga grub2 disk pa uopce ne prepoznaje Ubuntu tamo, tj uopce ga nema. Je li preporučuješ nanovo instalaciju Ubuntua ili?
Avatar
Postovi: 5
Postovi: 5
Pridružen/a: 25 vel 2014, 11:14
Lokacija: Kotor Varoš BiH / Knin HR
Podijelio/la zahvalu: 2 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Ubuntu 13.10, Gnome
Isključi u potpunosti (makni kablove) disk na kojem su ti win pa probaj onda bootat Linux. Ako to ne pomogne probaj napraviti reinstalaciju Gruba ili kompletnog Linuxa. Kad uspiješ s Linuxom vrati opet ovaj disk na kojem su Windowsi.

Edit:
Zaboraio sam da onda nećeš imati opciju podizanja Win u Grub izborniku. Znači, nakon što proradi Linux, dodaj disk s Windowsima pa napravi:
Kod: Označi sve
sudo grub-mkconfig -o /boot/grub/grub.cfg
Postovi: 101
Postovi: 101
Pridružen/a: 05 vel 2012, 13:12
Podijelio/la zahvalu: 4 puta
Primio/la zahvalu: 10 puta
Maknuo sam kablove (SATA vezu) od hard diska na kojem je bio windows pa se svejedno nije htio bootati linux.
Sada san napravio novu instalaciju linuxa pa ću probati dodati hard disk s windowsima. Samo da te pitam je li treban uključiti hard disk na kojem su windowsi kada se podigne sistem od linuxa tj kada kompjuter radi ili prije nego šta upalim kompjuter? Mislim može li to prouzročiti neku štetu na hardweru?
Zadnja izmjena: miso.vucko; 26 vel 2014, 15:39; ukupno mijenjano 1 put/a.
Avatar
Postovi: 5
Postovi: 5
Pridružen/a: 25 vel 2014, 11:14
Lokacija: Kotor Varoš BiH / Knin HR
Podijelio/la zahvalu: 2 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Ubuntu 13.10, Gnome
To bi moglo biti neki problem s UEFI-jem. Tu bi ti trebao odgovoriti neko tko to ima na svom kompu.
Možda treba isključiti Safe Boot ili nešto takvo da bi se podigao OS koji nisu Windoze?
Avatar
Site Admin
Postovi: 16087
Site Admin
Postovi: 16087
Pridružen/a: 03 tra 2008, 18:09
Lokacija: Svugdi me ima. Slavonija uglavnom.
Podijelio/la zahvalu: 503 puta
Primio/la zahvalu: 531 puta
Spol: M
OS: Mint 17 Cinnamon
To ti se hoće desiti kad prilikom instaliranja linuxa grub instaliraš na particiju umjesto na MBR diska. Prilikom instalacije gruba uvijek biraj sda, sdb i slično a ne sda1, sdb1, sdb2 - znači biraj ono bez broja - to je MBR diska. Oznaka sa brojem označava particiju - to u normalnom slučaju ne želiš. Kad instaliraš na MBR onda grub prebriše windowsov bootloader i stavi svoj a windows se onda pokreće iz grub menija. I isključi secure boot ako to imaš u BIOS-u. Također, ako koristiš GPT (GUID Partition Table ) umjesto običnog MBR, to donosi novi set mogućih problema pa takve stvari moraš navesti pri upitu, tako da ljudi znaju s čime imaju posla.
Avatar
Postovi: 1899
Postovi: 1899
Pridružen/a: 16 tra 2011, 08:34
Lokacija: i grupa Film
Podijelio/la zahvalu: 45 puta
Primio/la zahvalu: 339 puta
Spol: M
OS: Mint 10 LXDE itd...
Pozdrav. Hvala vam na odgovorima.
Instalirao sam Linux Ubuntu nanovo i poslje spojio SATA kabel od hard diska na kojem je windows.
Onda sam preko terminala isntalirao grub preko naredbe :

Kod: Označi sve
sudo grub-mkconfig -o /boot/grub/grub.cfg


Sada normalno radi grub, tj bez problema se podiže i LInux i Windowsi.
Ali našao sam na dodatni problem.
Ne mogu preko Linuxa ući na particiju od hard diska na kojem se nalaze Windowsi.
Tj prijavljuje neku grešku i piše da bi trebalo isključiti hibernaciju.
Ja sam to isključio u windowsima ali ona kada uključim Ubuntu opet ne ne mogu ući na particiju na kojoj je Windows instaliran.
Za GPT (GUID Partition Table ) nisam uopće čuo da sada, znam da mi je nešto poznato. Kako mogu provjeriti je li to imam? Mislio sam pitati je li to mogu provjeriti preko Ubuntua ili moram ići na Windowse?

Evo stavio sam i sliku da vidite kako to izgleda.
Privitak/ci
greska.jpg
greska.jpg (60.68 KiB) Pogledano 1939 put/a.
Zadnja izmjena: miso.vucko; 26 vel 2014, 16:58; ukupno mijenjano 3 put/a.
Avatar
Postovi: 5
Postovi: 5
Pridružen/a: 25 vel 2014, 11:14
Lokacija: Kotor Varoš BiH / Knin HR
Podijelio/la zahvalu: 2 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Ubuntu 13.10, Gnome

Na mreži
Trenutno korisnika/ca: / i 1 gost.