Stranica: 1/2.

openSUSE promjena local settings

PostPostano: 22 lip 2014, 17:27
Postao/la snake2903
Pozdrav, koristim openSUSE 13.1 sa KDE. Ono što me zanima i što nisam uspio nikako je prilagoditi locales.

Kada u terminalu upisem locale, vrati mi se kao en_US.

Jezik instalacije je bio engleski, a keyboard je hrvatski.

Ono što bih ja htio da mi i dalje jezik bude engleski, a da sve ostalo (npr. prikaz datuma, valuta, decimalni zarez i dr.) bude hrvatski.

Recimo datum sam na KDE složio da mi prikazuje kak ja hoću u taskbaru, ali recimo Thunderbird mi čita locale settings i prikazuje mi u engleskom formatu datum.

Hvala unaprijed.

Re: openSUSE promjena local settings

PostPostano: 22 lip 2014, 17:54
Postao/la shicy
Desktop Configuration --> Locale settings moš birat šta ćeš i kako ;)

Re: openSUSE promjena local settings

PostPostano: 22 lip 2014, 20:37
Postao/la stefan
salkof je napisao/la:Desktop Configuration --> Locale settings moš birat šta ćeš i kako ;)

Da, to bi trebalo biti to.

Ali moraš paziti da li neke aplikacije (čak i KDE aplikacije) imaju zaseban setting vezan uz regionalne postavke.
Primjer: Desni klik na sat u trayu -> Digital Clock Settings -> Calendar pa pod Holydays tu biraš čije blagdane da ti prikazuje... I neće ti prikazivati Hrvatske bez obzira što si prebacio regionalne postavke na Hrvatski. Ima još takvih slučajeva, ali mi ne padaju sad na pamet.

Re: openSUSE promjena local settings

PostPostano: 22 lip 2014, 23:03
Postao/la sumski
snake2903 je napisao/la:Recimo datum sam na KDE složio da mi prikazuje kak ja hoću u taskbaru, ali recimo Thunderbird mi čita locale settings i prikazuje mi u engleskom formatu datum.


Editiraj
/etc/sysconfig/language
ili, YaST -> Language
tim uređuješ sistemske postavke. ovo u 'Desktop Configuration' je po korisniku, i utječe samo na KDE.

Re: openSUSE promjena local settings

PostPostano: 23 lip 2014, 06:19
Postao/la snake2903
Evo ga uspio sam.
Već sam mjenjao postavke u /etc/sysconfig/language ali mi je uvijek i dalje vraćalo sve en_US kad sam upisao locale u terminal.
Na kraju sam otkrio da nisam u Yast -> Language instalirao Hrvatski kao drugi jezik.
Nakon toga sam u /etc/sysconfig/language podesio šta hoću da mi bude hr, a šta en i evo sada mi je sustav na engleskom, a datum, mjere i ostalo na hr.

Hvala još jednom :-)

Re: openSUSE promjena local settings

PostPostano: 23 lip 2014, 13:15
Postao/la stefan
sumski, ovo bi moglo u tweakanje?
Vjerujem da si dosta ljudi želi promijeniti regionalne postavke...

Re: openSUSE promjena local settings

PostPostano: 26 lip 2014, 09:33
Postao/la holden
Kad smo već kod ovog. Ja sam umetao redom sl_SI.UTF-8 u /etc/sysconfig/language.

I onda mi se desi ovo:

slika

Ovo levo. Ć neće da mi prepozna...i sad, tražio sam i u yastu, deluje mi da je sve podešeno na slovenački, a svejedno neće da mi povrati na ć. Zna li neko koju vrednost bi morao da ispravim?

Hvala.

edit: to je u launcheru programa/menuju.

Re: openSUSE promjena local settings

PostPostano: 26 lip 2014, 17:39
Postao/la Abzeenth
To bi ti moglo biti do fonta. Pogledaj si postavke za fontove, možda koristiš neki koji ne podržava naše dijakritike. Probaj promijeniti na neki "defaultni" da vidiš što će se dogoditi, ako već nisi.

EDIT: totalni offtopic ali tek sad sam ti skužila avatar! :D Nevjerojatna slučajnost - baš sam danas pogledala taj film (i super mi je :D)) :sokiran

Re: openSUSE promjena local settings

PostPostano: 26 lip 2014, 18:07
Postao/la holden
Oftopic: Ja nisam mogoa da verujem šta gledam. Bio sam ushićen :)

Ali stvarno, nisam se osećao tako otkad sam kao tinejdžer gledao Eternal Sunshine of the Spotless Mind. I koju godinu kasnije Donnie Darko. E, ovo je broj 3.

Re: openSUSE promjena local settings

PostPostano: 29 ruj 2015, 23:20
Postao/la iv@n
Ovaj problem imam otkad sam instalirao Tumbleweed (cista instalacija s DVD ISO preslike, odabran engleski jezik i hrvatski layout tipkovnice). Nikako ne mogu dobiti dijakriticke znakove vec [];'\,./ umjesto nasih slova.

Sve sam dva put provjerio i cini mi se da bi trebalo stimati, ali iz nekog razloga ne radi.

Izlistat cu par stvari i okacit koji screenshot, mozda je netko imao isti problem ili mozda cak ima tema na forumu, nisam pretrazivao.

slika

slika

slika

Kad grepam /etc/sysconfig/language dobijem:

Kod: Označi sve
INPUT_METHOD=""
RC_LANG="hr_HR.UTF-8"

RC_LC_ALL=""

RC_LC_MESSAGES=""

RC_LC_CTYPE=""

RC_LC_COLLATE=""

RC_LC_TIME=""

RC_LC_NUMERIC=""

RC_LC_MONETARY=""

RC_LC_PAPER=""

ROOT_USES_LANG="ctype"

AUTO_DETECT_UTF8="no"

INSTALLED_LANGUAGES="hr_HR"


a /etc/sysconfig/keyboard izbaci:

Kod: Označi sve
KEYTABLE=""

KBD_DELAY=""

KBD_RATE=""

KBD_NUMLOCK="bios"

KBD_SCRLOCK="no"

KBD_CAPSLOCK="no"

KBD_DISABLE_CAPS_LOCK="no"

KBD_TTY=""

COMPOSETABLE="clear latin1.add"

YAST_KEYBOARD="croatian,pc104"


i konacno tumleweedov /etc/vconsole.conf:

Kod: Označi sve
KEYMAP=hr_HR-nodeadkeys


HALP! :(

NADOPUNJENO:

https://forums.opensuse.org/showthread. ... s-American
https://bugzilla.opensuse.org/show_bug.cgi?id=943735

Thanks to korisnik @Suse