Sada je: 20 kol 2019, 01:40.
Diskusije usko vezane uz SUSE i openSUSE distribucije.

Moderator/ica: Moderatori/ce

5.7.1
Naravno da je stabilno, do sada nisam imao nikakve greške sa DE, kod mene sve radi. E sada, da budem iskren od kad sam instalirao Leap, navikao sam da kada radim nadogradnju, ugasim X.
Avatar
Postovi: 1795
Postovi: 1795
Pridružen/a: 15 sij 2014, 09:37
Lokacija: Zaljev svetaca
Podijelio/la zahvalu: 68 puta
Primio/la zahvalu: 177 puta
Spol:
OS: Leap 15 / Linux Mint 19
@vision

Mislis na X-11?
Kako se gasi, daj objasni malo, i zasto je to dobro?

Hvala unapred,
openSUSE
Linux For Open Minds
Avatar
Postovi: 65
Postovi: 65
Pridružen/a: 23 stu 2015, 21:58
Podijelio/la zahvalu: 38 puta
Primio/la zahvalu: 1 puta
Spol: M
OS: openSUSE-Leap 42.3
i mene zanima isto kako se gasi X i kako da povučem 5.7.1.....hvala
Avatar
Postovi: 679
Postovi: 679
Pridružen/a: 15 stu 2011, 20:41
Lokacija: Bjelovar i okolica
Podijelio/la zahvalu: 43 puta
Primio/la zahvalu: 6 puta
Spol: M
OS: Debian 10
Odes na stranicu: https://en.opensuse.org/KDE_repositories

Iskopiras repo KDE Frameworks 5 & Plasma 5 za Leap (ima ih dva) i preko YaST dodas u Repositories

Zatim preko terminala kao root kucas: zypper up, pa posle toga zypper dup.
openSUSE
Linux For Open Minds
Avatar
Postovi: 65
Postovi: 65
Pridružen/a: 23 stu 2015, 21:58
Podijelio/la zahvalu: 38 puta
Primio/la zahvalu: 1 puta
Spol: M
OS: openSUSE-Leap 42.3
Dok sam koristio Slackware, kod instalacije nove verzije (KDE, Plasma) je pisalo:
Make sure you are not running KDE or even X ! If you are running an X session,
log out first, and if you are in runlevel 4 (graphical login) you first have to
go back to runlevel 3 (console) by typing "init 3".

To mi je par puta pomoglo kod Tumbleweed-a, a tako sam nastavio i na Leap. Vjerujem da više nema takvih problema kao prošle godine, ali ne želim rizikovati, par komandi mi ne predstavlja problem.

U terminal ukucaš:
Kod: Označi sve
sudo kill sddm

ponovo se prijaviš (u tty1)
Kod: Označi sve
sudo zypper up

kad se završi:
Kod: Označi sve
sudo poweroff
Avatar
Postovi: 1795
Postovi: 1795
Pridružen/a: 15 sij 2014, 09:37
Lokacija: Zaljev svetaca
Podijelio/la zahvalu: 68 puta
Primio/la zahvalu: 177 puta
Spol:
OS: Leap 15 / Linux Mint 19
Ok, to je to.
Ja, to isto radim samo malo drugacije:
Ctrl+Alt+F1
zatim, odradim zypper up i zypper dup
i na kraju reboot.
Mislim da je to isto?
openSUSE
Linux For Open Minds
Avatar
Postovi: 65
Postovi: 65
Pridružen/a: 23 stu 2015, 21:58
Podijelio/la zahvalu: 38 puta
Primio/la zahvalu: 1 puta
Spol: M
OS: openSUSE-Leap 42.3
Zašto kill? Sddm je servis.

Kako suse ima systemd servisi se uključuju i isključuju sa:
Kod: Označi sve
systemctl stop NAZIV_SERVISA
systemctl start NAZIV_SERVISA

Može još i:
Kod: Označi sve
systemctl restart N_S
systemctl enable N_S postavi servis (postavi pokretanje servisa pri bootanju)
systemctl disable N_S ukloni servis (zaustavi ga i više ne pokreći pri bootanju)

systemctl reload N_S -ako servis to podržava, ponovo učitaj konfig servisa bez restartanja istog

Normalno, uz sudo ako nije root prompt.
Avatar
Postovi: 1891
Postovi: 1891
Pridružen/a: 16 tra 2011, 08:34
Lokacija: i grupa Film
Podijelio/la zahvalu: 45 puta
Primio/la zahvalu: 337 puta
Spol: M
OS: Mint 10 LXDE itd...
Kod: Označi sve
sudo systemctl list-unit-files


Kod: Označi sve
sddm.service                               disabled

l4k1 je napisao/la:Ok, to je to.
Ja, to isto radim samo malo drugacije:
Ctrl+Alt+F1
zatim, odradim zypper up i zypper dup
i na kraju reboot.
Mislim da je to isto?

Nije, jer si se sa CTRL+ALT+F1 prebacio u tty1, a da pritisneš CTRL+ALT+F7 vratio bi se u KDE (desktop), što znači da X i dalje radi.
Sa zypper dup možeš da imaš probleme, govorilo se i ovdje o tome.
Avatar
Postovi: 1795
Postovi: 1795
Pridružen/a: 15 sij 2014, 09:37
Lokacija: Zaljev svetaca
Podijelio/la zahvalu: 68 puta
Primio/la zahvalu: 177 puta
Spol:
OS: Leap 15 / Linux Mint 19
vision je napisao/la:
Kod: Označi sve
sddm.service                               disabled

Zanimljivo. Pogledao sam malo i izgleda da suse ima malo drugačiji setup i servis se zove display-manager a DM se namješta u /etc/sysconfig/displaymanager, ako je točno što ovaj čovjek kaže:
https://forums.opensuse.org/showthread. ... DM-Setting

Kod: Označi sve
wolfi323 is offline Global Moderator

Default Re: Strange SDDM Setting

    It is normal that sddm.service is disabled and inactive.
    openSUSE uses a general display-manager.service (which should be enabled), this reads /etc/sysconfig/displaymanager and starts the display manager set there ("DISPLAYMANAGER=xxx").

    You should *not* try to enable sddm.service or any other one. There were even problems with that in the past (should be fixed by now AFAIK though).
    If you want to use a different one, edit /etc/sysconfig/displaymanager, either with a text editor or YaST->System->/etc/sysconfig editor.

    Oh, and it's by no way mandatory to use sddm with a KDE installation. You don't win or loose anything, and can just use anything else if you prefer.
    With Plasma5 at least that is, KDE4 does only provide the Restart menu (where you can choose what boot menu entry to boot) with kdm.
Avatar
Postovi: 1891
Postovi: 1891
Pridružen/a: 16 tra 2011, 08:34
Lokacija: i grupa Film
Podijelio/la zahvalu: 45 puta
Primio/la zahvalu: 337 puta
Spol: M
OS: Mint 10 LXDE itd...
@vision,

Pratim forum od objave leap-a i dude stvarno bi neko trebao da te promote ovdje u SuSe forumu. Zaslužio si,fakat;)
U svakom slučaju, od mene veliko hvala,keep up the good work

zypper source-install -D peace out
People disagree with me. I just ignore them.
Avatar
Postovi: 364
Postovi: 364
Pridružen/a: 30 kol 2014, 18:34
Podijelio/la zahvalu: 17 puta
Primio/la zahvalu: 38 puta
Spol: M
OS: suse, Arch

Na mreži
Trenutno korisnika/ca: / i 1 gost.