Sada je: 14 stu 2019, 05:44.
Diskusije usko vezane uz SUSE i openSUSE distribucije.

Moderator/ica: Moderatori/ce

Ne znam jeste li primijetili na openSUSE 12.2 (a pretpostavljam i ostalim verzijama) HR raspored tipki nije dobar za tipku tzv. <TLDE>. Tipka se nalazi lijevo od tipke za "1".

Pritiskom na tipku (ne toliko meni značajnu tipku, ali eto...) trebao bi se dobiti znak "¸", dok neispravno ona prikazuje "`", dok pritiskom sa SHIFT-om trebao bi biti ispisan "¨", a neispravno daje "~".

Prepravio sam datoteku "hr" za "layout" koja se nalazi u:

/usr/share/X11/xkb/symbols/

i koju treba tamo zamijeniti s priloženom:

hr.zip
(odzipati naravno prije)
(885 bajt(ov)a) Preuzeto 98 put/a.

Naravno, samouk sam "linuxaš", pa više šaljem da uvid da netko provjeri jesam li to dobro napravio.

Na mojem računalu navedena prepravka zasad radi.

Također ću biti sretan ako sam nekome i pomogao.

Pozdrav i sretno "linuxiranje" :)
Avatar
Postovi: 25
Postovi: 25
Pridružen/a: 11 sij 2013, 22:28
Podijelio/la zahvalu: 5 puta
Primio/la zahvalu: 2 puta
Spol: M
OS: openSUSE 12.3, KDE 4.10
Pa i meni je tak ko tebi na archu. Kaj ja cijeli zivot zivim u ne znanju?
stefan je napisao/la:tu mač gemišta

To understand recursion, you must first understand recursion.
Avatar
Postovi: 1536
Postovi: 1536
Pridružen/a: 22 tra 2012, 08:55
Lokacija: ForHill Croatia
Podijelio/la zahvalu: 20 puta
Primio/la zahvalu: 26 puta
Spol: M
OS: eOS Luna
Kako mislis? :) Napisao sam da *ja* nisam siguran da li sam dobro napravio... to je sve... :)
Ugl. meni je tipka krive znakove ispisivala od onog što je na njoj "nacrtano/utisnuto" :)
Avatar
Postovi: 25
Postovi: 25
Pridružen/a: 11 sij 2013, 22:28
Podijelio/la zahvalu: 5 puta
Primio/la zahvalu: 2 puta
Spol: M
OS: openSUSE 12.3, KDE 4.10
upravo sam isprobao i radi kako treba....recimo ö, ä itd.....znači radi mi kako treba bez prepravke
ipak pohvala što imaš volje za učenjem .....
Avatar
Postovi: 679
Postovi: 679
Pridružen/a: 15 stu 2011, 20:41
Lokacija: Bjelovar i okolica
Podijelio/la zahvalu: 43 puta
Primio/la zahvalu: 6 puta
Spol: M
OS: Debian 10
Hvala na probi :)

Da mi je rijesiti i jos nepotrebniju tipku Scroll-Lock :lol: na sistemskom nivou.

Probao sam dodavanjem:

"add mod3 = Scroll_Lock"

u

"/etc/X11/Xmodmap"

te kako u istoj pise kreiranjem i dodavanjem u:

"/usr/X11R6/lib/X11/Xmodmap"

ali nista ne pomaze.

Moguce je staviti za nove korisnike u:

"/etc/skel/.Xmodmap"

ili u vlastiti:

"~/.Xmodmap"

medjutim volio bih to rijesiti na prvi nacin, a ne znam gdje grijesim. :?

Ako ima tko kakav savjet, naravno da je dobro dosao :D

Pozdrav
Avatar
Postovi: 25
Postovi: 25
Pridružen/a: 11 sij 2013, 22:28
Podijelio/la zahvalu: 5 puta
Primio/la zahvalu: 2 puta
Spol: M
OS: openSUSE 12.3, KDE 4.10
Scroll Lock koristim za promjenu US <-> HR layouta. U KDE-u layout i shortcut za njihovu promjenu izabereš i dodaješ u: System Settings - Input Devices - Keyboard - Layouts.
Ako si na to mislio...
1986-1990: Commodore64 / 1990-1994: Amiga 500 / 1995-1996: Amiga 1200 / 1997-2001: N/A@home /
2002-2004: Windows98, XP /
2004-2005: Knoppix, Mandrake / 2005: Mandriva, Ubuntu / 2005-2009: LFS / 2009-2010: Mint /
2010-... Arch
Avatar
Moderator
Postovi: 3293
Moderator
Postovi: 3293
Pridružen/a: 01 pro 2010, 23:50
Lokacija: Nova Gradiška
Podijelio/la zahvalu: 122 puta
Primio/la zahvalu: 156 puta
OS: Arch/KDE, Debian/Armbian
O hvala! Za to nisam niti znao 8-)

Iskreno, nisam baš na to mislio, zanimalo me kako da dok stisnem Scroll-lock u KDE-u da mi se upali lampica na tipkovnici, pa pretpostavljam da Scroll-Lock tada radi (mada ne znam da li mu funcionalnost ostala takva kakva mu je bila u "stara vremena") :)

Npr. ako ručno uključim ovime:

xmodmap -e "add mod3 = Scroll_Lock"

onda "lampica" radi :)

Međutim, ne znam kako to napraviti automatski na nivou sistema za sve korisnike.
Avatar
Postovi: 25
Postovi: 25
Pridružen/a: 11 sij 2013, 22:28
Podijelio/la zahvalu: 5 puta
Primio/la zahvalu: 2 puta
Spol: M
OS: openSUSE 12.3, KDE 4.10
Nisam još naišao da lampica ne radi ako se stisne Scroll Lock, pa pretpostavljam da je to tvoje djelo :)
Trebao bi provjeriti s defaultnim postavkama. Nažalost, ne mogu ti pomoći s tweakanjima tastature po tekstualnim fajlovima jer sam to radio davno na Mandrakeu kad mi defaultno nisu radile < i > tipke na hr layoutu i ne sjećam se gotovo ničega.
1986-1990: Commodore64 / 1990-1994: Amiga 500 / 1995-1996: Amiga 1200 / 1997-2001: N/A@home /
2002-2004: Windows98, XP /
2004-2005: Knoppix, Mandrake / 2005: Mandriva, Ubuntu / 2005-2009: LFS / 2009-2010: Mint /
2010-... Arch
Avatar
Moderator
Postovi: 3293
Moderator
Postovi: 3293
Pridružen/a: 01 pro 2010, 23:50
Lokacija: Nova Gradiška
Podijelio/la zahvalu: 122 puta
Primio/la zahvalu: 156 puta
OS: Arch/KDE, Debian/Armbian
Od friške instalacije te tipke nisu radile. Očito nove distribucije polako izbacuju "stare" stvari, npr. podršku za floppy, te neke "stare i specifične" tipke koje čak se i prestaju stavljati u neke tipkovnice i sl.
Avatar
Postovi: 25
Postovi: 25
Pridružen/a: 11 sij 2013, 22:28
Podijelio/la zahvalu: 5 puta
Primio/la zahvalu: 2 puta
Spol: M
OS: openSUSE 12.3, KDE 4.10
solo je napisao/la:Od friške instalacije te tipke nisu radile. Očito nove distribucije polako izbacuju "stare" stvari, npr. podršku za floppy, te neke "stare i specifične" tipke koje čak se i prestaju stavljati u neke tipkovnice i sl.

Hm, to nije sigurno jer koristim Cherry tastaturu Made in West Germany s DIN konektorom i PS/2 adapterom, a koristim Arch (znači uvijek najnoviji kernel, driveri, Xorg i sw) i radi sve kako treba. Sve tri ledice svijetle sasvim dobro :)
1986-1990: Commodore64 / 1990-1994: Amiga 500 / 1995-1996: Amiga 1200 / 1997-2001: N/A@home /
2002-2004: Windows98, XP /
2004-2005: Knoppix, Mandrake / 2005: Mandriva, Ubuntu / 2005-2009: LFS / 2009-2010: Mint /
2010-... Arch
Avatar
Moderator
Postovi: 3293
Moderator
Postovi: 3293
Pridružen/a: 01 pro 2010, 23:50
Lokacija: Nova Gradiška
Podijelio/la zahvalu: 122 puta
Primio/la zahvalu: 156 puta
OS: Arch/KDE, Debian/Armbian

Na mreži
Trenutno korisnika/ca: / i 2 gostiju.