Switch to full style
Diskusije usko vezane uz Fedora i srodne distribucije (RHEL, CentOS...)
Odgovori

[Riješeno] Kompajliranje help...

02 lip 2011, 20:57

Imam problem sa kompajliranjem ovoga programa na Fusion-u 14.1 (što je u biti Fedora 14):
http://linux.softpedia.com/get/Text-Edi ... 5220.shtml

Pustim ./configure

Dobijem ovo
Kod:
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to disable maintainer-specific portions of Makefiles... yes
checking for a Python interpreter with version >= 2.5... python
checking for python... /usr/bin/python
checking for python version... 2.7
checking for python platform... linux2
checking for python script directory... ${prefix}/lib/python2.7/site-packages
checking for python extension module directory... ${exec_prefix}/lib/python2.7/site-packages
checking python module: gtk... yes
checking python module: pygtk... yes
checking python module: gtkspell... yes
checking python module: goocanvas... yes
checking python module: enchant... no
configure: error: failed to find required module enchant


dalje ovo
Kod:
$ yum search enchant
=============================== Matched: enchant ===============================
python-enchant.i686 : Python bindings for Enchant spellchecking library
enchant-aspell.i686 : Integration with aspell for libenchant
enchant-devel.i686 : Support files necessary to compile applications with
                   : libenchant.
enchant-voikko.i686 : Integration with voikko for libenchant
mingw32-enchant.noarch : MinGW Windows Enchanting Spell Checking Library
mingw32-enchant-static.noarch : Static version of the MinGW Windows enchant
                              : library
enchant.i686 : An Enchanting Spell Checking Library
geany-plugins-spellcheck.i686 : Spellcheck Text in Geany using the Enchant
                              : Library
php-enchant.i686 : Human Language and Character Encoding Support
xfce4-dict.i386 : A Dictionary Client for the Xfce desktop environment
xfce4-dict-plugin.i386 : Xfce panel plugin to query a Dict server


U biti instaliran je taj paket i dev od tog paketa, zašto configure ne prepoznaje ga?
Zadnja izmjena: /Zoran\; 05 lip 2011, 15:02; ukupno mijenjano 1 put/a.

Re: Kompajliranje help...

02 lip 2011, 23:04

Kod:
checking python module: enchant... no

Pa jel imaš ovo instalirano?

Re: Kompajliranje help...

02 lip 2011, 23:15

da, mislio sam da se to može vidjet iz ove druge komande, evo screen od pacakge managera

slika

drugog nema u repoima...

Re: Kompajliranje help...

03 lip 2011, 05:50

python-enchant

Re: Kompajliranje help...

03 lip 2011, 06:34

drade je napisao/la:python-enchant


e to , veli da traži python module ...

Re: Kompajliranje help...

03 lip 2011, 09:44

:nee :thumbs :bravo

instalirano, radi....
Odgovori