Sada je: 26 lis 2020, 06:02.
Diskusije usko vezane uz Fedora i srodne distribucije (RHEL, CentOS...)

Moderator/ica: Moderatori/ce

Kod: Označi sve
Resolving Dependencies
--> Running transaction check
---> Package fedora-release-rawhide.noarch 0:15-1 will be updated
--> Processing Dependency: fedora-release-rawhide = 15-1 for package: fedora-release-15-1.noarch
---> Package fedora-release-rawhide.noarch 0:15-3 will be an update
---> Package glibc-common.i686 0:2.13.90-9 will be updated
--> Processing Dependency: glibc-common = 2.13.90-9 for package: glibc-2.13.90-9.i686
---> Package glibc-common.i686 0:2.14-4 will be an update
--> Finished Dependency Resolution
Error: Package: fedora-release-15-1.noarch (@koji-override-1/$releasever)
           Requires: fedora-release-rawhide = 15-1
           Removing: fedora-release-rawhide-15-1.noarch (@koji-override-1/$releasever)
               fedora-release-rawhide = 15-1
           Updated By: fedora-release-rawhide-15-3.noarch (updates)
               fedora-release-rawhide = 15-3
Error: Package: glibc-2.13.90-9.i686 (@koji-override-0/$releasever)
           Requires: glibc-common = 2.13.90-9
           Removing: glibc-common-2.13.90-9.i686 (@koji-override-0/$releasever)
               glibc-common = 2.13.90-9
           Updated By: glibc-common-2.14-4.i686 (updates)
               glibc-common = 2.14-4
 You could try using --skip-broken to work around the problem
** Found 30 pre-existing rpmdb problem(s), 'yum check' output follows:
adwaita-cursor-theme-3.0.2-1.fc15.noarch is a duplicate with adwaita-cursor-theme-3.0.1-1.fc15.noarch
adwaita-gtk2-theme-3.0.2-1.fc15.i686 is a duplicate with adwaita-gtk2-theme-3.0.1-1.fc15.i686
bash-4.2.10-4.fc15.i686 is a duplicate with bash-4.2.10-2.fc15.i686
32:bind-license-9.8.0-7.P4.fc15.noarch is a duplicate with 32:bind-license-9.8.0-3.P1.fc15.noarch
1:control-center-filesystem-3.0.1.1-6.fc15.i686 is a duplicate with 1:control-center-filesystem-3.0.1.1-5.fc15.i686
fedora-release-15-3.noarch is a duplicate with fedora-release-15-1.noarch
filesystem-2.4.41-1.fc15.i686 is a duplicate with filesystem-2.4.40-1.fc15.i686
glibc-2.14-4.i686 is a duplicate with glibc-2.13.90-9.i686
glibc-2.14-4.i686 has missing requires of glibc-common = ('0', '2.14', '4')
gnome-python2-desktop-2.32.0-4.fc15.i686 is a duplicate with gnome-python2-desktop-2.32.0-1.fc14.i686
gnome-user-docs-3.0.4-1.fc15.noarch is a duplicate with gnome-user-docs-3.0.3-1.fc15.noarch
hplip-common-3.11.5-3.fc15.i686 is a duplicate with hplip-common-3.11.3a-1.fc15.i686
iso-codes-3.25.1-1.fc15.noarch is a duplicate with iso-codes-3.25-1.fc15.noarch
iwl5000-firmware-8.83.5.1_1-1.fc15.noarch is a duplicate with iwl5000-firmware-8.83.5.1-2.fc15.noarch
liberation-fonts-common-1.07.0-1.fc15.noarch is a duplicate with liberation-fonts-common-1.06.0.20100721-5.fc15.noarch
libgcc-4.6.0-9.fc15.i686 is a duplicate with libgcc-4.6.0-6.fc15.i686
linux-firmware-20110601-1.fc15.noarch is a duplicate with linux-firmware-20110304-1.fc15.noarch
m17n-contrib-1.1.12-5.fc15.1.noarch is a duplicate with m17n-contrib-1.1.12-5.fc15.noarch
mesa-dri-filesystem-7.11-0.16.20110709.0.fc15.i686 is a duplicate with mesa-dri-filesystem-7.11-0.9.20110509.0.fc15.i686
nss-softokn-freebl-3.12.10-2.fc15.i686 is a duplicate with nss-softokn-freebl-3.12.9-7.fc15.i686
python-IPy-0.75-1.fc15.noarch is a duplicate with python-IPy-0.70-3.fc15.noarch
python-cloudfiles-1.7.9.1-1.fc15.noarch is a duplicate with python-cloudfiles-1.7.8-1.fc15.noarch
python-slip-0.2.17-1.fc15.noarch is a duplicate with python-slip-0.2.14-2.fc15.noarch
python-telepathy-0.15.19-3.fc15.noarch is a duplicate with python-telepathy-0.15.19-1.fc15.noarch
python-xlib-0.15-0.5.rc1.fc15.noarch is a duplicate with python-xlib-0.15-0.4.rc1.fc15.noarch
tigervnc-license-1.0.90-4.fc15.noarch is a duplicate with tigervnc-license-1.0.90-3.fc15.noarch
tzdata-2011h-1.fc15.noarch is a duplicate with tzdata-2011d-3.fc15.noarch
xkeyboard-config-2.3-2.fc15.noarch is a duplicate with xkeyboard-config-2.2.1-2.20110415git19a0026b5.fc15.noarch
xorg-x11-server-common-1.10.3-1.fc15.i686 is a duplicate with xorg-x11-server-common-1.10.1-14.fc15.i686
yelp-xsl-3.0.2-1.fc15.noarch is a duplicate with yelp-xsl-3.0.1-1.fc15.noarch
Nije teško biti toliko nesrećan da bi čovek počeo da pije. Ljude treba odvikavati od nesreće, a ne od alkohola. Nesreća je veći porok.
Avatar
Postovi: 9934
Postovi: 9934
Pridružen/a: 12 tra 2008, 22:45
Lokacija: Rijeka
Podijelio/la zahvalu: 7 puta
Primio/la zahvalu: 71 puta
Spol: M
OS: PopOS
Onemogući rawhide repozitorij.. Mislim da ti on radi problem.. :)

Pa ponovno pokušaj update..
One definition of the word mean is "small." Mean people live small, think small, and feel small—the smaller, the meaner.
Avatar
Postovi: 2478
Postovi: 2478
Pridružen/a: 28 vel 2010, 18:13
Lokacija: Đubrovnik
Podijelio/la zahvalu: 11 puta
Primio/la zahvalu: 7 puta
Spol: M
OS: Linux
nije nikada niti bio ukljucen taj repo. probo ukljuciti pa iskljuciti ali isto uglavnom prikazuje mi dva paketa koja nemoze updateati...
Privitak/ci
Untitled.jpg
Untitled.jpg (37.14 KiB) Pogledano 1159 put/a.
Nije teško biti toliko nesrećan da bi čovek počeo da pije. Ljude treba odvikavati od nesreće, a ne od alkohola. Nesreća je veći porok.
Avatar
Postovi: 9934
Postovi: 9934
Pridružen/a: 12 tra 2008, 22:45
Lokacija: Rijeka
Podijelio/la zahvalu: 7 puta
Primio/la zahvalu: 71 puta
Spol: M
OS: PopOS
zole052 je napisao/la:nije nikada niti bio ukljucen taj repo. probo ukljuciti pa iskljuciti ali isto uglavnom prikazuje mi dva paketa koja nemoze updateati...


Ne znam sad na pamet jer nemam više Fedoru, ali sam imao sličan problem, i to zbog toga jer sam omogućio neki novi repozitorij u kojemu su bili isti paketi kao i u službenom repozitoriju, pa yum nije znao kojemu dati prednost,..valjda.. :)

Jesi pokušao ovo što ti je izbacio:

You could try using --skip-broken to work around the problem


Kod: Označi sve
yum update --skip-broken
One definition of the word mean is "small." Mean people live small, think small, and feel small—the smaller, the meaner.
Avatar
Postovi: 2478
Postovi: 2478
Pridružen/a: 28 vel 2010, 18:13
Lokacija: Đubrovnik
Podijelio/la zahvalu: 11 puta
Primio/la zahvalu: 7 puta
Spol: M
OS: Linux
Kod: Označi sve
yum update --skip-broken
[/quote]

Je na taj nacin sam i updateo sustav... jos mi ostaju ova dva za nekako updateati.

Inace super mi je ovaj gnome 3, za jednu dvije verzije biti ze zvjerka!

Na kojoj jos distri mogu isprobati gnome 3? (nemojte mi samo neke archeve spominjati ;) )
Nije teško biti toliko nesrećan da bi čovek počeo da pije. Ljude treba odvikavati od nesreće, a ne od alkohola. Nesreća je veći porok.
Avatar
Postovi: 9934
Postovi: 9934
Pridružen/a: 12 tra 2008, 22:45
Lokacija: Rijeka
Podijelio/la zahvalu: 7 puta
Primio/la zahvalu: 71 puta
Spol: M
OS: PopOS
i neka moderador ubati u pravu ladicu, sada sam skuzio da sam pod pclos i mandriva ovo poceo pisati...
Nije teško biti toliko nesrećan da bi čovek počeo da pije. Ljude treba odvikavati od nesreće, a ne od alkohola. Nesreća je veći porok.
Avatar
Postovi: 9934
Postovi: 9934
Pridružen/a: 12 tra 2008, 22:45
Lokacija: Rijeka
Podijelio/la zahvalu: 7 puta
Primio/la zahvalu: 71 puta
Spol: M
OS: PopOS
ovaj problem s update-om se događa i na fedori 14.
Postovi: 48
Postovi: 48
Pridružen/a: 24 srp 2011, 11:22
Lokacija: Okolica Zagreba
Podijelio/la zahvalu: 0 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Fedora, Debian, FreeBsd
a
Kod: Označi sve
#yum install fedora-release-rawhide-15-3 glibc-common-2.14-4

?
ili
Kod: Označi sve
#yum install yum-utils

Kod: Označi sve
#package-cleanup --cleandupes



Note:
Kod: Označi sve
Found 30 pre-existing rpmdb problem(s), 'yum check' output follows:
.
.
.
fedora-release-15-3.noarch is a duplicate with fedora-release-15-1.noarch
glibc-2.14-4.i686 is a duplicate with glibc-2.13.90-9.i686
glibc-2.14-4.i686 has missing requires of glibc-common = ('0', '2.14', '4')


EDIT:
pogledaj vamo:
http://forums.fedoraforum.org/showthread.php?t=262677
Listen, I gotta fight the lion. That's what that guy Scott's all about. I know. I've studied him already.
Avatar
Moderator
Postovi: 1779
Moderator
Postovi: 1779
Pridružen/a: 10 ruj 2010, 11:20
Podijelio/la zahvalu: 9 puta
Primio/la zahvalu: 92 puta
Spol: M
OS: openSUSE Factory KDE
ono prvo nije napravilo nista, izbaci istu gresku a drugo je izbacilo novu...

Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
glibc-common = 2.14-4 is needed by (installed) glibc-2.14-4.i686
Complete!
(1, [u'Please report this error in http://yum.baseurl.org/report'])

ali to je i tako testiranje pa nemora raditi kako treba :)
Nije teško biti toliko nesrećan da bi čovek počeo da pije. Ljude treba odvikavati od nesreće, a ne od alkohola. Nesreća je veći porok.
Avatar
Postovi: 9934
Postovi: 9934
Pridružen/a: 12 tra 2008, 22:45
Lokacija: Rijeka
Podijelio/la zahvalu: 7 puta
Primio/la zahvalu: 71 puta
Spol: M
OS: PopOS
mogu probati deinstalirati taj glibc pa probati ponovo instalirati ili ce mi krepati sustav od toga?
Nije teško biti toliko nesrećan da bi čovek počeo da pije. Ljude treba odvikavati od nesreće, a ne od alkohola. Nesreća je veći porok.
Avatar
Postovi: 9934
Postovi: 9934
Pridružen/a: 12 tra 2008, 22:45
Lokacija: Rijeka
Podijelio/la zahvalu: 7 puta
Primio/la zahvalu: 71 puta
Spol: M
OS: PopOS

Na mreži
Trenutno korisnika/ca: / i 1 gost.