Sada je: 17 stu 2019, 06:11.
Audio, video, codeci...

Moderator/ica: Moderatori/ce

Pozdrav,

Imam spojen PC sa televizorom u drugoj sobi, znaci zvuk mi može ići na built-in Analog Stereo ili na HDMI izlaz pa na TV.
Za svaki program koji pokrenem ja imam određene preference gdje bi ja htio da mi zvuk ide po defaultu (npr. pustim film u VLC u - želim da ide na TV, a muziku u Clementine da ide na PC zvucnike) i ok, to se da svaki put namjestiti sa PAVU Controll ili preko Kmix-a.
Problem je u tome sto mi na Debianu svi programi po defaultu puštaju zvuk na PC zvučnike i onda ja moram otvori PAVU Controll ili Kmix pa eventualno prebaciti na HDMI izlaz.
Postoji li neki setting da sustav zapamti poslije reboota za pojedini program gdje sam ga ostavio. Inače Manjaro i openSUSUe su "pamtili" za svaki program na kojem izlazu sam pustio, ne znam zašto Debian neće.
Hvala
Zadnja izmjena: redundant; 04 ožu 2017, 21:36; ukupno mijenjano 1 put/a.
Avatar
Postovi: 317
Postovi: 317
Pridružen/a: 02 svi 2011, 23:24
Lokacija: Ri
Podijelio/la zahvalu: 11 puta
Primio/la zahvalu: 1 puta
Spol: M
OS: Debian LXQt
pa probaj u svakoj aplikaciji. u VLCu i svakj multimedijalnoj app. možeš definirati kako da se zvuk ponaša, tj. koji izlaz i što sve da koristi.
Es gibt keinen Gott, kein Universum, keine menschliche Rasse, kein irdisches Leben, keinen Himmel, keine Hölle. Es ist alles ein Traum - ein grotesker und dummer Traum. Nichts existiert außer dir. Und du bist nur ein Gedanke - ein vagabundierender Gedanke, ein nutzloser Gedanke, ein heimatloser Gedanke, der verloren in der leeren Ewigkeit wandelt!
Avatar
Moderator
Postovi: 9916
Moderator
Postovi: 9916
Pridružen/a: 07 pro 2007, 18:07
Podijelio/la zahvalu: 158 puta
Primio/la zahvalu: 270 puta
Spol: Y
OS: utuntu 17.04
Probao sam reproducirati tvoj problem i uspio tako da sam zakomentirao liniju load-module module-stream-restore u /etc/pulse/default.pa

Probaj ovako, kao prvo, ako imaš slučajno custom datoteku default.pa u svome $HOME/.config/pulseaudio makni je ili obriši, pa otvori /etc/pulse/default.pa kao root
Kod: Označi sve
gksu gedit /etc/pulse/default.pa

i pogledaj da nije slučajno zakomentirana koja od linija:
Kod: Označi sve
load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore


Ako jesu, otkomentiraj ih (makni # sa početka linije), snimi i ponovo pokreni pulseaudio s:
Kod: Označi sve
pulseaudio -k

pa provjeri sada pamti li promjene izlaza s pavucontrol po aplikacijama.

Edit: provjeri i je li ti Analog izlaz postavljen kao prvi u pavucontrol->configuration tabu. Internet kaže da kao ima neki bug ako nije - ne znam točno o čemu je riječ ali provjeri indeks analogne kartice ako ono gore ne proradi. https://bbs.archlinux.org/viewtopic.php?id=164868
Avatar
Postovi: 1896
Postovi: 1896
Pridružen/a: 16 tra 2011, 08:34
Lokacija: i grupa Film
Podijelio/la zahvalu: 45 puta
Primio/la zahvalu: 338 puta
Spol: M
OS: Mint 10 LXDE itd...
jurastublic je napisao/la:Probao sam reproducirati tvoj problem i uspio tako da sam zakomentirao liniju load-module module-stream-restore u /etc/pulse/default.pa

Probaj ovako, kao prvo, ako imaš slučajno custom datoteku default.pa u svome $HOME/.config/pulseaudio makni je ili obriši, pa otvori /etc/pulse/default.pa kao root
Kod: Označi sve
gksu gedit /etc/pulse/default.pa

i pogledaj da nije slučajno zakomentirana koja od linija:
Kod: Označi sve
load-module module-device-restore
load-module module-stream-restore
...
load-module module-card-restore


Ako jesu, otkomentiraj ih (makni # sa početka linije), snimi i ponovo pokreni pulseaudio s:
Kod: Označi sve
pulseaudio -k

pa provjeri sada pamti li promjene izlaza s pavucontrol po aplikacijama.

Edit: provjeri i je li ti Analog izlaz postavljen kao prvi u pavucontrol->configuration tabu. Internet kaže da kao ima neki bug ako nije - ne znam točno o čemu je riječ ali provjeri indeks analogne kartice ako ono gore ne proradi. https://bbs.archlinux.org/viewtopic.php?id=164868


Hvala,
ove tri linije su odkomenetirane i taj file mi izgleda ok...
pogledao sam šta ovi arčeri pišu (iz linka) uglavnom meni naredba pacmd list izbaci dva active profila
Kod: Označi sve
active profile: <output:hdmi-stereo>

Kod: Označi sve
active profile: <output:analog-stereo>


to je isto što mi se pokazuje u Configuration tabu u PAVU controll. Tamo su dva profila za:
- Cedar HDMI Audio [Radeon HD ...] - znači moj grafička iz koje izlazi HDMI kabel, i
- Build-in Audio ( Tu eventualno mogu pod Build-In Audio nešto drugo izabrati, ali sumnjam da će to pomoći)

...svaki ima svoj drop - down i selektirano je isto što i pacmd list izbaci za active profile.
e sad ne znam koji od ta dva bi trebao dodati u /etc/pulse/default.pa
Avatar
Postovi: 317
Postovi: 317
Pridružen/a: 02 svi 2011, 23:24
Lokacija: Ri
Podijelio/la zahvalu: 11 puta
Primio/la zahvalu: 1 puta
Spol: M
OS: Debian LXQt
shrike je napisao/la:pa probaj u svakoj aplikaciji. u VLCu i svakj multimedijalnoj app. možeš definirati kako da se zvuk ponaša, tj. koji izlaz i što sve da koristi.


Hm nije mi palo na pamet... našao sam setting u VLC-u, još kad bi ga iskopao Chromiumu..:)
Avatar
Postovi: 317
Postovi: 317
Pridružen/a: 02 svi 2011, 23:24
Lokacija: Ri
Podijelio/la zahvalu: 11 puta
Primio/la zahvalu: 1 puta
Spol: M
OS: Debian LXQt
Da, malo mi je sumnjivo to što je HDMI prvi po redu. Možda tvoj debian ima stariju verziju pulseaudia koja nema ispravljen taj bug (tj. ako je hdmi prvi - ne pamti postavke). A pulseaudio opet, kako vidim, neće vjerojatno prepoznati HDMI ako ta kartica NIJE PRVA po redu (barem starije verzije).
Ali možeš probati postaviti analognu karticu kao prvu pa vidi. Lako se vrati ako ne bude valjalo.
Pogledaj prvo info o karticama:
Kod: Označi sve
lspci -knn |grep -iA 2 audio; aplay -l

Ako HDMI ima broj 0, zamijeni. Kako, to će ti ovisiti o tome koriste li kartice isti driver.
Ako ne koriste onda nadodaj u /etc/modprobe.d/alsa.conf (ili alsa-base.conf i sl. - ili napravi svoju .conf datoteku...) :
Kod: Označi sve
options snd slots=IME_DRIVERA_ANALOGNE,IME_DRIVERA_OD_HDMI

ko što rekoh, može se desiti da poslije HDMI uopće nema zvuka, pa obriši tu liniju u toj datoteci.
Restartaj alsu ili rebootaj nakon tih promjena:

Ako koriste isti driver onda može biti zafrknuto ako driver nema te opcije, pa možda ima neki drugi način, možda preko pulseaudia?
http://alsa.opensrc.org/MultipleCards#S ... s_going_on
Malo sam nadrobio, ali probaj, nema velike štete.
Avatar
Postovi: 1896
Postovi: 1896
Pridružen/a: 16 tra 2011, 08:34
Lokacija: i grupa Film
Podijelio/la zahvalu: 45 puta
Primio/la zahvalu: 338 puta
Spol: M
OS: Mint 10 LXDE itd...
Hvala, baš si si dao truda... sad imam materijala preko vikenda se malo zabavljati.
Bit će da je ovo na Debianu (stable #ironija :)) dosta starija verzija pulseaudia pa je bug još unutra. Ionako sam razmišljao prebaciti se na Testing, to bi možda riješilo i ovo... Zanimljivo, ni ovaj shriketov pristup ne funkcionira tj. aplikacije gube postavke zvuka poslije reboota (a ni one nemaju šta s tim zvukom nego preko pulseaudia s bugom, jel...)
u svakom slučaju hvala, javit ću rezultate.
Avatar
Postovi: 317
Postovi: 317
Pridružen/a: 02 svi 2011, 23:24
Lokacija: Ri
Podijelio/la zahvalu: 11 puta
Primio/la zahvalu: 1 puta
Spol: M
OS: Debian LXQt
Epilog...

prebacio se na Debian Testing i sad se postavke zvuka pamte. Naravno, to mi je donijelo sto novih problema, ali to je već za neku drugu temu.... hvala na pažnji!
Avatar
Postovi: 317
Postovi: 317
Pridružen/a: 02 svi 2011, 23:24
Lokacija: Ri
Podijelio/la zahvalu: 11 puta
Primio/la zahvalu: 1 puta
Spol: M
OS: Debian LXQt

Na mreži
Trenutno korisnika/ca: / i 2 gostiju.