Sada je: 15 lis 2019, 07:46.
Diskusije usko vezane uz Debian distribuciju.

Moderator/ica: Moderatori/ce

Ovako imam 2 hdd-a. Jedan na kojem imam win i drugi na kojem imam linux.
Prvi hdd mi se prilikom startanja linuxa normalno "mountira" dok na drugom hdd-u imam jednu logicku particiju na kojoj imam razne stvari. E sada svaki put kada zelim pristupit toj particiji na drugom hddu, moram ukucavat pass i moram je "mountat". Ono sto bih zelio napravit to je da mi se prilikom podizanja sistema ta druga particija na drugom hdd-u automatski mounta kao sto mi je to slucaj sa / particijom :).

POSTUPAK KOJI SAM JA POKUSAVAO:

Za pocetak koristim Debian zadnju verziju. Logiram se preko console kao root i u /etc/fstab file dodam slj.redak
UUID= "od drugog hdd-a" /media/windows/ ntfs users,rw,exec,umask=007 0 0
sejvam file i izadjem van. Kada odem u nautilus, pa na places i pokusam mountirat taj hdd koji sam dodao javlja mi gresku da nemam prava mountirat /dev/sda5 (particija na drugom hdd-u), da nemam neka prava na ntfs-3g binary i da provjerim prava na user id-u. E sada pretpostavljam da je sve dobro,ali mi neda mountirat disk jer to moze samo root, ali ne razumijem zasto mi ova opcija u 4-om polju "users" ne radi :twisted: (trebo bi imat bilo koji korisnik pravo da mountira i unmoutira hdd).
Na koju foru da dam obicnom korisniku prava da mountira hdd, tako da mi mount radi prilikom startupa.

Hvala na pomoci!
Postovi: 177
Postovi: 177
Pridružen/a: 26 pro 2010, 16:12
Podijelio/la zahvalu: 3 puta
Primio/la zahvalu: 0 puta
OS: Debian
UUID=A6F86572F8654223 /media/Win_ATA ntfs-3g defaults 0 0

a verujem da bi ti i dodavanje uid=1000 u opcije pomoglo.
...."Have you mooed today?"...
..It’s that time of the decade: I’m reinstalling Debian..
Avatar
Postovi: 5676
Postovi: 5676
Pridružen/a: 28 vel 2009, 16:36
Podijelio/la zahvalu: 1 puta
Primio/la zahvalu: 41 puta
hm... ovako sto se tice "mount pointa" naveo si /media/Win_ATA to mislim da ne igra ulogu, posto za mount point mogu npr zadat i Desktop :)). Probao sam stavit i ntfs-3g i sa default postavkama i opet nece :evil: sbatine. A sto se tice default postavki to sigurno nije ok,jer u tom slucaju samo root ima ovlasti da mountira hdd :P
Postovi: 177
Postovi: 177
Pridružen/a: 26 pro 2010, 16:12
Podijelio/la zahvalu: 3 puta
Primio/la zahvalu: 0 puta
OS: Debian
Kod: Označi sve
rw,nosuid,nodev,uid=1000,gid=100,dmask=0077,fmask=017
I'm a Paladin with 18 charisma and 97 hit points. I can use my helm of disintegration and do one D4 damage as my half-elf mage wields his plus-five holy avenger.
Avatar
Postovi: 1407
Postovi: 1407
Pridružen/a: 31 sij 2009, 23:37
Lokacija: rijeka
Podijelio/la zahvalu: 0 puta
Primio/la zahvalu: 0 puta
OS: arch | 7
evo kopirao sam ti cijelu liniju iz fstab fajla:

UUID=6C904D7C904D4E30 /media/ ntfs rw,nosuid,nodev,uid=1000,gid=1000,dmask=0077,fmask=017

nakon ovoga javim mi gresku "samo root moze mountirat drive", a ako dodam na pocetak "option fielda" users onda mi izbaci sve one greske koje sam spomenuo u prvom postu. Poludit cu :D
Postovi: 177
Postovi: 177
Pridružen/a: 26 pro 2010, 16:12
Podijelio/la zahvalu: 3 puta
Primio/la zahvalu: 0 puta
OS: Debian
tech_soul8 je napisao/la:evo kopirao sam ti cijelu liniju iz fstab fajla:

UUID=6C904D7C904D4E30 /media/ ntfs rw,nosuid,nodev,uid=1000,gid=1000,dmask=0077,fmask=017

nakon ovoga javim mi gresku "samo root moze mountirat drive", a ako dodam na pocetak "option fielda" users onda mi izbaci sve one greske koje sam spomenuo u prvom postu. Poludit cu :D

0 0 nakraju, folder nisi stvoio.

pa si restartao. trebao bi mu pristupiti bez problema nakon restarta

nije users nego user
I'm a Paladin with 18 charisma and 97 hit points. I can use my helm of disintegration and do one D4 damage as my half-elf mage wields his plus-five holy avenger.
Avatar
Postovi: 1407
Postovi: 1407
Pridružen/a: 31 sij 2009, 23:37
Lokacija: rijeka
Podijelio/la zahvalu: 0 puta
Primio/la zahvalu: 0 puta
OS: arch | 7
tech_soul8 je napisao/la: A sto se tice default postavki to sigurno nije ok,jer u tom slucaju samo root ima ovlasti da mountira hdd :P


By default, files and directories are owned by the effective user and group of the mounting process and everybody has full read, write, execution and directory browsing permissions
...."Have you mooed today?"...
..It’s that time of the decade: I’m reinstalling Debian..
Avatar
Postovi: 5676
Postovi: 5676
Pridružen/a: 28 vel 2009, 16:36
Podijelio/la zahvalu: 1 puta
Primio/la zahvalu: 41 puta
Istina :D nakon restarta evoga sve radi kako treba napokon :) zaboravio sam bio dodat na kraju tamo 0 0 nakon toga, restart i sve radi :)

Hvala puno na trudu i pomoci :)
Postovi: 177
Postovi: 177
Pridružen/a: 26 pro 2010, 16:12
Podijelio/la zahvalu: 3 puta
Primio/la zahvalu: 0 puta
OS: Debian
ave moa!
Avatar
Postovi: 1407
Postovi: 1407
Pridružen/a: 31 sij 2009, 23:37
Lokacija: rijeka
Podijelio/la zahvalu: 0 puta
Primio/la zahvalu: 0 puta
OS: arch | 7

Na mreži
Trenutno korisnika/ca: / i 2 gostiju.