Sada je: 17 srp 2019, 01:32.
Rasprave u vezi Linux aplikacija.

Moderator/ica: Moderatori/ce

Imam vrlo glup problem pa bih molio pomoć: instalirao sam Tisak/DM/Cewe fotoprogram ali ga ne mogu pokrenuti, pa me zanima u čemu je problem. Skine se verzija za linux, raspakira arhiva (skripta + eula), pokrene instalacijska skripta - yes, next, next i sve bude gotovo za minutu. Instalacijska mapa se nalazi u ~. Vidim izvršnu datoteku, ali je ne mogu pokrenuti. Wtf???

Link za preuzimanje (klik na desnoj strani):
http://foto.tisak.hr/default.aspx
Abzeenth je napisao/la:Dobro onda. Baš me briga. Krepajte od offtopica.

jurastublic je napisao/la:Ovaj thread me podsjeća na krepanu mačku. Treba to pokupit lopatom i zakopat. Onda dezinficirati lopatu. :-D
Avatar
Moderator
Postovi: 5818
Moderator
Postovi: 5818
Pridružen/a: 25 ožu 2012, 14:29
Lokacija: ~/kauč
Podijelio/la zahvalu: 155 puta
Primio/la zahvalu: 250 puta
Spol: M
OS: Mint 17.3 Cimet
Sa zanimanjem pratim temu (mogao si to i u zasebnu staviti) jer sam prije par godina bezuspješno pokušavao isto što i ti :place
[+ Prikaži] Klik
ThinkPad T440p
Intel Core i5-4300M
Intel HD Graphics 4600
16GB DDR3L
1xSanDisk X400 512 GB & 1x240GB Intel 2500 Pro
15.6" FHD IPS anti-glare
6 & 9 cell Li-Ion battery
OS: kako kada
Slika: dio kolekcije

***

ZEN
"Charlie. What are you thinking?"
"I'm thinking about what I want and what I need."
"What do you want?"
"I want a peaceful soul."
"And what do you need?"
"I need a bigger gun."
Avatar
Site Admin
Postovi: 10210
Site Admin
Postovi: 10210
Pridružen/a: 01 kol 2012, 12:39
Podijelio/la zahvalu: 573 puta
Primio/la zahvalu: 743 puta
Spol: M
OS: LinuxMint Cinnamon
Da stvar bude bolja, prije par godina sam instalirao DM-ovo izdanje foto programa (to je sve jedan program od firme Cewe koja printa slike, samo se rade odvojena izdanja programa za Tisak i DM) i stvarno je fenomenalno radio.
Desktop program ima neke dodatne stvari koje nema online verzija (koja je, usput rečeno, grozna), ali jednostavno se odbija pokrenuti. Instalirao na Mint 17.0, 17.3 i win7.

Evo video upute (prikaz programa):









PS: Ako se razvije rasprava onda premjestim u zasebnu temu
Abzeenth je napisao/la:Dobro onda. Baš me briga. Krepajte od offtopica.

jurastublic je napisao/la:Ovaj thread me podsjeća na krepanu mačku. Treba to pokupit lopatom i zakopat. Onda dezinficirati lopatu. :-D
Avatar
Moderator
Postovi: 5818
Moderator
Postovi: 5818
Pridružen/a: 25 ožu 2012, 14:29
Lokacija: ~/kauč
Podijelio/la zahvalu: 155 puta
Primio/la zahvalu: 250 puta
Spol: M
OS: Mint 17.3 Cimet
Na openSUSE Leap 42.3 se normalno pokreće nakon instalacije libgstreamer-0_10....
Avatar
Postovi: 1795
Postovi: 1795
Pridružen/a: 15 sij 2014, 09:37
Lokacija: Zaljev svetaca
Podijelio/la zahvalu: 68 puta
Primio/la zahvalu: 177 puta
Spol:
OS: Leap 15 / Linux Mint 19
kao što @vision reče, treba libgstreamer-0.10 da bi aplikacija krenula

na ubuntu 16.04 ne pomaže da se instalira libgstreamer-1.00 koji je trenutno 'default'
mora se ići okolo-naokolo

prvo skini dva paketa s neta:

Kod: Označi sve
wget http://ftp.ca.debian.org/debian/pool/main/g/gstreamer0.10/libgstreamer0.10-0_0.10.36-1.5_amd64.deb


Kod: Označi sve
wget http://ftp.ca.debian.org/debian/pool/main/g/gst-plugins-base0.10/libgstreamer-plugins-base0.10-0_0.10.36-2_amd64.deb


zatim odradi instalacije oba sa sudo dpkg -i ( jedan po jedan )
'81: ZX81 '83:ZX spectrum '85: Apple IIe '86:C-64 *** '87:PC-XT *** '88:PC-AT *** '90:386 *** 'itd.
Avatar
Postovi: 501
Postovi: 501
Pridružen/a: 26 svi 2012, 13:47
Lokacija: orahovica
Podijelio/la zahvalu: 59 puta
Primio/la zahvalu: 27 puta
Spol: M
OS: openSUSE-kde
@kepica - Kod mene je su istaliran paket libgstreamer1.0-0:i386 ver. 0.10.36-1.1
Paketi s neta se ne mogu instalirati:

1.) greška za libgstreamer0.10-0_0.10.36-1.5_amd64.deb
Kod: Označi sve
$ sudo dpkg -i libgstreamer0.10-0_0.10.36-1.5_amd64.deb
Selecting previously unselected package libgstreamer0.10-0:amd64.
(Reading database ... 204276 files and directories currently installed.)
Preparing to unpack libgstreamer0.10-0_0.10.36-1.5_amd64.deb ...
De-configuring libgstreamer0.10-0:i386 (0.10.36-1.2ubuntu3) ...
Unpacking libgstreamer0.10-0:amd64 (0.10.36-1.5) ...
dpkg: error processing package libgstreamer0.10-0:amd64 (--install):
 package libgstreamer0.10-0:amd64 0.10.36-1.5 cannot be configured because libgstreamer0.10-0:i386 is at a different version (0.10.36-1.2ubuntu3)
dpkg: error processing package libgstreamer0.10-0:i386 (--install):
 package libgstreamer0.10-0:i386 0.10.36-1.2ubuntu3 cannot be configured because libgstreamer0.10-0:amd64 is at a different version (0.10.36-1.5)
Errors were encountered while processing:
 libgstreamer0.10-0:amd64
 libgstreamer0.10-0:i386



2.) greška za libgstreamer-plugins-base0.10-0_0.10.36-2_amd64.deb
Kod: Označi sve
$ sudo dpkg -i libgstreamer-plugins-base0.10-0_0.10.36-2_amd64.deb
Selecting previously unselected package libgstreamer-plugins-base0.10-0:amd64.
(Reading database ... 204333 files and directories currently installed.)
Preparing to unpack libgstreamer-plugins-base0.10-0_0.10.36-2_amd64.deb ...
De-configuring libgstreamer-plugins-base0.10-0:i386 (0.10.36-1.1ubuntu2.1) ...
Unpacking libgstreamer-plugins-base0.10-0:amd64 (0.10.36-2) ...
dpkg: error processing package libgstreamer-plugins-base0.10-0:amd64 (--install):
 package libgstreamer-plugins-base0.10-0:amd64 0.10.36-2 cannot be configured because libgstreamer-plugins-base0.10-0:i386 is at a different version (0.10.36-1.1ubuntu2.1)
dpkg: error processing package libgstreamer-plugins-base0.10-0:i386 (--install):
 package libgstreamer-plugins-base0.10-0:i386 0.10.36-1.1ubuntu2.1 cannot be configured because libgstreamer-plugins-base0.10-0:amd64 is at a different version (0.10.36-2)
Errors were encountered while processing:
 libgstreamer-plugins-base0.10-0:amd64
 libgstreamer-plugins-base0.10-0:i386


:hmm
Abzeenth je napisao/la:Dobro onda. Baš me briga. Krepajte od offtopica.

jurastublic je napisao/la:Ovaj thread me podsjeća na krepanu mačku. Treba to pokupit lopatom i zakopat. Onda dezinficirati lopatu. :-D
Avatar
Moderator
Postovi: 5818
Moderator
Postovi: 5818
Pridružen/a: 25 ožu 2012, 14:29
Lokacija: ~/kauč
Podijelio/la zahvalu: 155 puta
Primio/la zahvalu: 250 puta
Spol: M
OS: Mint 17.3 Cimet
@calisto,
pitao sam čika gugla
nudi jedno objašnjenje za tvoju grešku, eto ga - probaj

Kod: Označi sve
sudo apt-get purge ".*:i386"
sudo dpkg --remove-architecture i386
sudo apt update
sudo apt install -f


DODATAK:
prije ' remove-architecture i386' treba odraditi ... purge ".*:i386" , promijenio sam u kodu iznad
očito ovo ima smisla samo ako je instalacija zaista 64-bitna
'81: ZX81 '83:ZX spectrum '85: Apple IIe '86:C-64 *** '87:PC-XT *** '88:PC-AT *** '90:386 *** 'itd.
Avatar
Postovi: 501
Postovi: 501
Pridružen/a: 26 svi 2012, 13:47
Lokacija: orahovica
Podijelio/la zahvalu: 59 puta
Primio/la zahvalu: 27 puta
Spol: M
OS: openSUSE-kde
Ne bi baš išlo... :pogled_dolje
Naredba purge uklonila je 240 MB libova (već me oblio znoj) :?
Naredba -remove-architecture nije vratila ništa. Na kraju sam ponovno pokušao instalirati prethodna dva paketa, ali bez uspjeha:

Kod: Označi sve
$ sudo dpkg -i libgstreamer0.10-0_0.10.36-1.5_amd64.deb
Preparing to unpack libgstreamer0.10-0_0.10.36-1.5_amd64.deb ...
Unpacking libgstreamer0.10-0:amd64 (0.10.36-1.5) over (0.10.36-1.5) ...
dpkg: dependency problems prevent configuration of libgstreamer0.10-0:amd64:
 libgstreamer0.10-0:amd64 depends on libglib2.0-0 (>= 2.41.1); however:
  Version of libglib2.0-0:amd64 on system is 2.40.2-0ubuntu1.

dpkg: error processing package libgstreamer0.10-0:amd64 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libgstreamer0.10-0:amd64


Kod: Označi sve
$ sudo dpkg -i libgstreamer-plugins-base0.10-0_0.10.36-2_amd64.deb
(Reading database ... 202640 files and directories currently installed.)
Preparing to unpack libgstreamer-plugins-base0.10-0_0.10.36-2_amd64.deb ...
Unpacking libgstreamer-plugins-base0.10-0:amd64 (0.10.36-2) over (0.10.36-2) ...
dpkg: dependency problems prevent configuration of libgstreamer-plugins-base0.10-0:amd64:
 libgstreamer-plugins-base0.10-0:amd64 depends on libgstreamer0.10-0 (>= 0.10.36); however:
  Package libgstreamer0.10-0:amd64 is not configured yet.
 libgstreamer-plugins-base0.10-0:amd64 depends on liborc-0.4-0 (>= 1:0.4.20); however:
  Version of liborc-0.4-0:amd64 on system is 1:0.4.18-1ubuntu1.

dpkg: error processing package libgstreamer-plugins-base0.10-0:amd64 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libgstreamer-plugins-base0.10-0:amd64




Da ne ispadne kako samo čekam gotova rješenja, ja se stvarno ne razumijem u dependency hell.. pface
Abzeenth je napisao/la:Dobro onda. Baš me briga. Krepajte od offtopica.

jurastublic je napisao/la:Ovaj thread me podsjeća na krepanu mačku. Treba to pokupit lopatom i zakopat. Onda dezinficirati lopatu. :-D
Avatar
Moderator
Postovi: 5818
Moderator
Postovi: 5818
Pridružen/a: 25 ožu 2012, 14:29
Lokacija: ~/kauč
Podijelio/la zahvalu: 155 puta
Primio/la zahvalu: 250 puta
Spol: M
OS: Mint 17.3 Cimet
Dependency hell, šta je to? :hihi

Šalu na stranu, @callisto053 ako imaš Synaptic pronađi i instaliraj libgstreamer-0.10.x i trebalo bi raditi.
Avatar
Postovi: 1795
Postovi: 1795
Pridružen/a: 15 sij 2014, 09:37
Lokacija: Zaljev svetaca
Podijelio/la zahvalu: 68 puta
Primio/la zahvalu: 177 puta
Spol:
OS: Leap 15 / Linux Mint 19
Ni mi vrag dao mira pa sam skinuo verziju za macOS sa linka koji si postao i nakon pokretanja:

slika

... iskočilo upozorenje da postoji nova verzija softvera i tu je ostalo stajati. Ok, klik na link za verziju 6.2.6, otpakiravanje zip-a, pokreni, os ponudi da napravim drag n drop softvera u mapu aplikacije (za sad sam odbio) i nakon toga se program normalno pokrene :-D

slika

... nemre jednostavnije :hihi

Ništa, sutra probam na LM 18.1 pa javim kako je prošlo ;)
[+ Prikaži] Klik
ThinkPad T440p
Intel Core i5-4300M
Intel HD Graphics 4600
16GB DDR3L
1xSanDisk X400 512 GB & 1x240GB Intel 2500 Pro
15.6" FHD IPS anti-glare
6 & 9 cell Li-Ion battery
OS: kako kada
Slika: dio kolekcije

***

ZEN
"Charlie. What are you thinking?"
"I'm thinking about what I want and what I need."
"What do you want?"
"I want a peaceful soul."
"And what do you need?"
"I need a bigger gun."
Avatar
Site Admin
Postovi: 10210
Site Admin
Postovi: 10210
Pridružen/a: 01 kol 2012, 12:39
Podijelio/la zahvalu: 573 puta
Primio/la zahvalu: 743 puta
Spol: M
OS: LinuxMint Cinnamon

Na mreži
Trenutno korisnika/ca: / i 1 gost.