Sada je: 03 tra 2020, 08:26.
C, C++, Java, PHP, Ruby...

Moderator/ica: Moderatori/ce

Pravila foruma
U naslovu teme unutar uglatih zagrada navesti o kojem jeziku je riječ. Primjer: [Java]
Imam Linux mint 19. Pokušavam složiti neku bazu na serveru i nekoliko .php programčića koji će nešto raditi s tom bazom. Da se ne mučim na serveru, htio sam sve najprije raditi lokalno. Instalirao sam već čudesa slušajući ove video tutorijale:

https://www.google.hr/search?q=lamp+for ... 00&bih=719

Manje više sve instaliram uspješno i kad probam u Firefoxu localhost/phpinfo.php on ne napravi ništa... Samo prazan bijeli Firefox. Molim pomoć i unaprijed zahvaljujem.
Postovi: 135
Postovi: 135
Pridružen/a: 18 stu 2010, 06:51
Lokacija: Sesvetski Kraljevec
Podijelio/la zahvalu: 2 puta
Primio/la zahvalu: 4 puta
Spol: M
OS: Windows 7
zato jer unutar /var/www/html dokumenta vjerojatno imaš samo index.html dokument koji ti javlja kako si instalirao apache2 server kada ukucaš localhost.

kreiraj novi file unutar tog direktorija i nazovi ga phpinfo.php pa da vidimo što će se desiti.. unutar file-a ubaci:

<?php

phpinfo();

?>
DebianResources
DebianHandbook
devil je napisao/la:nije neka tamo kanta pametnija od nas tu.
Postovi: 1465
Postovi: 1465
Pridružen/a: 12 kol 2008, 00:06
Podijelio/la zahvalu: 0 puta
Primio/la zahvalu: 0 puta
Spol: M
maliodpalube je napisao/la:Imam Linux mint 19. Pokušavam složiti neku bazu na serveru i nekoliko .php programčića koji će nešto raditi s tom bazom. Da se ne mučim na serveru, htio sam sve najprije raditi lokalno. Instalirao sam već čudesa slušajući ove video tutorijale:

https://www.google.hr/search?q=lamp+for ... 00&bih=719

Manje više sve instaliram uspješno i kad probam u Firefoxu localhost/phpinfo.php on ne napravi ništa... Samo prazan bijeli Firefox. Molim pomoć i unaprijed zahvaljujem.


Probao... vidi gornji post...
Postovi: 135
Postovi: 135
Pridružen/a: 18 stu 2010, 06:51
Lokacija: Sesvetski Kraljevec
Podijelio/la zahvalu: 2 puta
Primio/la zahvalu: 4 puta
Spol: M
OS: Windows 7
Dakako, taj isti phpinfo.php na serveru radi uredno...
Drugi .php fajlovi lokalno opet ne rade, a na serveru rade...
Postovi: 135
Postovi: 135
Pridružen/a: 18 stu 2010, 06:51
Lokacija: Sesvetski Kraljevec
Podijelio/la zahvalu: 2 puta
Primio/la zahvalu: 4 puta
Spol: M
OS: Windows 7
Prvi korak u debugiranju je navesti detaljno što imaš. Dakle, vrtiš li uopće webserver lokalno? Koji webserver imaš, koji PHP i kako instaliran (apache, nginx, fpm,...), koja baza? Da li si uključio logiranje u webserveru i PHP-u i stavio da logira sve?

Jer drugi korak je da pogledaš error.log od php i web servera i tamo će ti pisati.
Es gibt keinen Gott, kein Universum, keine menschliche Rasse, kein irdisches Leben, keinen Himmel, keine Hölle. Es ist alles ein Traum - ein grotesker und dummer Traum. Nichts existiert außer dir. Und du bist nur ein Gedanke - ein vagabundierender Gedanke, ein nutzloser Gedanke, ein heimatloser Gedanke, der verloren in der leeren Ewigkeit wandelt!
Avatar
Moderator
Postovi: 9972
Moderator
Postovi: 9972
Pridružen/a: 07 pro 2007, 18:07
Podijelio/la zahvalu: 163 puta
Primio/la zahvalu: 272 puta
Spol: Y
OS: utuntu 17.04
Moj prvi guess je da PHP modul za webserver nije instaliran
Avatar
Site Admin
Postovi: 4434
Site Admin
Postovi: 4434
Pridružen/a: 07 ožu 2009, 17:00
Podijelio/la zahvalu: 98 puta
Primio/la zahvalu: 179 puta
Spol: M
OS: w10, ubuntu, macos
Probaj ovaj tutorial:

https://www.itzgeek.com/how-tos/linux/l ... nt-12.html

Doduše kod mene je Debian host a CentOS guest u Virtualboxu i na oboje sam uspješno instalirao LAMP i to tako da fajlove držim u /home/user/public_html i sve mi radi :)

Je da onda moram u browseru kucati http://192.168.1.200/~user/ ali stavim u bookmark i problem riješen.

Garant nešto nije dobro odrađeno. Deinstaliraj sve i ponovo instaliraj.
Avatar
Postovi: 125
Postovi: 125
Pridružen/a: 15 stu 2011, 09:00
Podijelio/la zahvalu: 2 puta
Primio/la zahvalu: 3 puta

Na mreži
Trenutno korisnika/ca: Google [Bot] i 13 gostiju.