Sada je: 10 kol 2020, 23:16.
Diskusije usko vezane uz Arch Linux i srodne distribucije.

Moderator/ica: Moderatori/ce

Pozdrav ekipa!

Otkako se instalacija Archa promijenila, naletio sam na neke poteškoće prilikom svježe instalacije sustava.
Pratim guide, sve ide bez problema dok ne dođem do kreiranja grub.cfg fajla.
Instalirao sam os-prober i automatski kreirao cfg file naredbom
Kod: Označi sve
grub-mkconfig -o /boot/grub/grub.cfg

Problem se nalazi u tome što mi ne detektira Arch nego samo Win 7 koji je već instaliran za dual boot.
Pobrinuo sam se da mi /boot i /root budu mountani kako bi pronašao sustav, ali ništa.

Ima tko kakvih iskustva?
Say hello @geekowski
Avatar
Postovi: 133
Postovi: 133
Pridružen/a: 06 vel 2010, 13:53
Lokacija: Osijek
Podijelio/la zahvalu: 0 puta
Primio/la zahvalu: 0 puta
Spol: m
OS: Arch Linux
Nisam stavio os-prober na nedavnoj instalaciji i grub uredno prikazuje (jedini OS) Arch sa comunity repo (dabljutief) kernelom.
Mora bit da si tu nešto zeznuo.
Arch Linux Install Script
Hash Checker
Vl@do je napisao/la:Arch imaš upravo zato da uštediš na vremenu. Nemaš nikakvih problema s instalacijama, kompajliranjem i ostalim. Imaš jednostavno funkcionalan i stabilan, uvijek najsvježiji OS, a osim toga je sexy i cool do neba.

I've seen some idiots back in my days but you man... you're special!
Avatar
Moderator
Postovi: 6363
Moderator
Postovi: 6363
Pridružen/a: 13 stu 2010, 21:12
Lokacija: /hrvatska/split/.../9/7
Podijelio/la zahvalu: 272 puta
Primio/la zahvalu: 345 puta
Spol: M
OS: Arch MATE/Xfce/LXDE
Joj, zašto su morali mjenjati stari sistem instalacije koji je bio sasvim ok??
E sad što sam zeznuo? Nije mi nikakad error izbacio prije toga i slično.
Say hello @geekowski
Avatar
Postovi: 133
Postovi: 133
Pridružen/a: 06 vel 2010, 13:53
Lokacija: Osijek
Podijelio/la zahvalu: 0 puta
Primio/la zahvalu: 0 puta
Spol: m
OS: Arch Linux
Meni je u virtualci prepoznao, ali nije htio bootati. :nee
Navodno da onaj instaler nije imao tko održavati.
Avatar
Site Admin
Postovi: 4498
Site Admin
Postovi: 4498
Pridružen/a: 07 ožu 2009, 17:00
Podijelio/la zahvalu: 98 puta
Primio/la zahvalu: 185 puta
Spol: M
OS: w10, ubuntu, macos
Preporučan korištenje syslinuxa mjesto gruba, s njime nikda nisam imao problema, a i možete jednostavno ručno dodavati stavke (drugi OS, novi kernel,...).

IllusionsPlay je napisao/la:Joj, zašto su morali mjenjati stari sistem instalacije koji je bio sasvim ok??
E sad što sam zeznuo? Nije mi nikakad error izbacio prije toga i slično.


AIF nitko više ne održava, zastario je, ali zato imaš scripta koje pojednostavljuju instalaciju: https://bbs.archlinux.org/viewtopic.php?id=130515
Ken Thompson je napisao/la:One of my most productive days was throwing away 1000 lines of code.



Pikacode - Arch configs
Pikacode - dwm config
Avatar
Postovi: 2254
Postovi: 2254
Pridružen/a: 11 svi 2009, 16:26
Lokacija: /dev/pts/0
Podijelio/la zahvalu: 11 puta
Primio/la zahvalu: 94 puta
Spol: M
OS: Arch Linux x86-64 subtle
Ja sam ovo imao sa syslinuxom.
Avatar
Site Admin
Postovi: 4498
Site Admin
Postovi: 4498
Pridružen/a: 07 ožu 2009, 17:00
Podijelio/la zahvalu: 98 puta
Primio/la zahvalu: 185 puta
Spol: M
OS: w10, ubuntu, macos
Netrebas mountat /root dir, nego / dir, /boot, i eventualno jos koji ako si ih razdvojio, koji ce ti trebat da bis obavio radnje na tom sistemu(u ovom slucaju instalirao bootloader). Jesi chrootao unutar sistema?
EDIT:
Sve lijepo pise:
https://wiki.archlinux.org/index.php/Installation_Guide
Postovi: 290
Postovi: 290
Pridružen/a: 13 ožu 2012, 20:14
Podijelio/la zahvalu: 0 puta
Primio/la zahvalu: 0 puta
Pri početku vodiča kaže da se mounta /root i /home, ali ne i /boot. Tek kasnije kaže da se izađe iz instalacije, mounta još i /boot te se vrati na korak instalacije bootloadera. Kada sam pokušao sve iz početka, odmah sam mountao i /boot tamo gdje nije spomenuto te je sve prošlo bez problema.
Trebalo bi to napomenuti u početničkom vodiću koji sam pratio. Tamo ne piše.
Say hello @geekowski
Avatar
Postovi: 133
Postovi: 133
Pridružen/a: 06 vel 2010, 13:53
Lokacija: Osijek
Podijelio/la zahvalu: 0 puta
Primio/la zahvalu: 0 puta
Spol: m
OS: Arch Linux
Cista logika, grub treba smjestit na /boot particiju...
Mada kolko vidim pise i na https://wiki.archlinux.org/index.php/Be ... bootloader
Znaci rijeseno?
Postovi: 290
Postovi: 290
Pridružen/a: 13 ožu 2012, 20:14
Podijelio/la zahvalu: 0 puta
Primio/la zahvalu: 0 puta
Evo ovako imam slican problem
Imam instaliran windows 7 na particiji koju sam pomaknuo na "zadnje mjesto" sa gpartedom.
prilikom instalacije sam napravio 3 logicke particije
sda5 boot
sda6 root
sda7 home

sve sam uredno formatiro i mountao te instalirao.

upalim laptop on boota u windows 7 tu sam zapeo sta dalje
mislim da nisam dobro izvrsio ove naredbe
Kod: Označi sve
pacman -S grub-bios
# grub-install --target=i386-pc --recheck /[size=150][b]dev/sda[/b][/size]
# cp /usr/share/locale/en\@quot/LC_MESSAGES/grub.mo /boot/grub/locale/en.mo

jer sam umjesto dev/sda ubacio dev/sda5
i ova mi se komanda nije izvrsila
Kod: Označi sve
# grub-mkconfig -o /boot/grub/grub.cfg

Sta dalje, di sam pogrijesio pomagajte. Moguce da je banalna greska. :? I da instaliram 64 bitnu verziju archa.
Hvala

EDIT: Problem je bio sto sam mijenjao Dev/sda sa /dev/sda5
Postovi: 1
Postovi: 1
Pridružen/a: 23 ruj 2012, 16:32
Podijelio/la zahvalu: 0 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Windows 7

Na mreži
Trenutno korisnika/ca: / i 1 gost.