Stranica: 1/1.

Encoding

PostPostano: 29 pro 2012, 11:27
Postao/la domepro
Enivej, nisam imao ideje u koji podforum ovo da posaljem, tako da ce neki mod valjda premjestit ako ovome tu nije mjesto :)

keywords: arch, urxvt, java, font

koristim eng keyboard i ne pisem hrvatska slova uglavnom, pa u onom /etc/locale.gen obicno imam enableano samo en_us UTF-8 ili kako vec to ide. (iskreno, nemam pojma jel to ima veze s icim, ali je jedina stvar koje sam se sjetio a da ima veze sa zemljom a da sam radio prilikom instalacije)

na zalost, imam za nekako obraditi neki fajl koji je pun hrvatskih dijakritika. i lijepo ja to ucitam u javi i nekakav testni ispis napravim i umjesto ch/zh/sh/bla imam samo "??".

odkomentirao sam hr UTF-8 encoding u tom locale.gen jer mi je to prvo palo na pamet, ali je i dalje ostalo isto :).

testiranja radi, napravio sam bash skriptu koja echoa neku rijec sa hrvatskim dijakritikom i opet mi prikaze krivo, ali ne sa "??" nego sa nekakvim svedskim/finskim/kojimgod A sa onim kruzicem gore.

font koji koristim u terminalu je DejaVuSansMono trenutno (probao neki drugi nakon Inconsolate, ali je ista prica).

sad, problem je sto ne znam je li mi problem u javi (tipa moram ucitavat stringove sa utf-8 nekako eksplicitno) ili je samo u fontu/terminalu/mojem neznanju o archu/encodingu

so, ako itko ima kakav savjet bio bih zahvalan ;)

Re: Encoding

PostPostano: 29 pro 2012, 11:36
Postao/la Abzeenth
Premješteno iz "Savjeti i trikovi".

Re: Encoding

PostPostano: 29 pro 2012, 12:13
Postao/la retsam
Jesi li napravio local-gen update? Moj ti je prijedlog da omogućiš hrvatski locale u /etc/locale.gen, zatim napraviš update s:

Kod: Označi sve
sudo locale-gen


nkon toga u /etc/local.conf podesiš na hrvatski, ta bi linija trebala izgledati otprilike ovako:

Kod: Označi sve
LANG="hr_HR.UTF-8"


i onda po potrebi mijenjaš jezik u hrvatski/engleski u /etc/X11/xorg.conf.d/10-keyboard.conf, n. p. odijeljak s postavkama jezika tipkovnice:

Kod: Označi sve
Section "InputClass"
    Identifier             "Keyboard Defaults"
    MatchIsKeyboard      "yes"
    Option              "XkbLayout" "hr, us"
    Option                 "XkbVariant" "colemak"
EndSection

Re: Encoding

PostPostano: 29 pro 2012, 12:47
Postao/la stefan
Otvori fajl sa Kate, pa Tools -> Encoding i probaj cp2015 ili tako nesto. To je Windows central European. Ako je fajl napravljen na windowsima to ce rjesiti prikaz nasih znakova. Onda konvertiraj u UTF8 (ne znam napamet kako).

Re: Encoding

PostPostano: 29 pro 2012, 18:09
Postao/la drone
CP1250 je ta Windows CE kodna stranica. Inače tko god koristi subtitlove, zna da naši budu u tom encodingu.

@domepro
Zanima me je li u pitanju samo jedan fajl ili recimo u terminalu inače ne možeš dobiti naše znakove, recimo kad tipkaš. Ako je fajl, možeš ga konvertirati u utf8 na razne načine, a jedan ti je spomenuo stefan s tim da pri snimanju iz Kate-a (a i još nekih editora) postoji opcija izbora encodinga.

Re: Encoding

PostPostano: 01 sij 2013, 12:42
Postao/la eloop
Ili preko komandne linije:
Kod: Označi sve
iconv -f CP1250 -t UTF-8  windows_titlovo.sub > utf_titlovi.sub


Ako se desi da nije CP1250 odnosno WINDOWS-1250 mozes detektovat encoding sa:
Kod: Označi sve
enca -L hr <ime fajla>