Sada je: 18 stu 2019, 23:34.
Diskusije o hardveru i driverima pod Linuxom.

Moderator/ica: Moderatori/ce

alis_005 je napisao/la:Pozdrav, da, i mene zanima, što sa Linuxom se ne može koristiti ta eOI?

Radi bez problema. Forumaš JH-IM i ja smo opisali postupak instalacije par postova iznad.

EDIT:
Evo, još jednom:
1.) Drajver za smar card čitač je opensc i opensc-pkcs11 u Synapticu. Lista podržanog hardvera (čitača) je ovdje, trenutno ne mogu pronaći bolju. Čitač radi na principu upali-i-vozi.
2.) Instaliraš paket eMiddelware sa linka koji je JH-IM postavio kako bi po prvi put aktivirala osobnu sa čipom. Inače ti taj program ne treba.
3.) Instaliraš certifikate u web preglednik (samo pazi na podržane preglednike). I to je to!
Abzeenth je napisao/la:Dobro onda. Baš me briga. Krepajte od offtopica.

jurastublic je napisao/la:Ovaj thread me podsjeća na krepanu mačku. Treba to pokupit lopatom i zakopat. Onda dezinficirati lopatu. :-D
Avatar
Moderator
Postovi: 5818
Moderator
Postovi: 5818
Pridružen/a: 25 ožu 2012, 14:29
Lokacija: ~/kauč
Podijelio/la zahvalu: 155 puta
Primio/la zahvalu: 250 puta
Spol: M
OS: Mint 17.3 Cimet
Je li netko od vas imao problema s potpisivanjem PDF dokumenta, odnosno potpisivanjem zahtjeva?

Naime, pokušavam poslati online zahtjev za izradu nove vozačke (što se može napraviti samo s valjanim certifikatom i instaliranim i podešenim čitačem kartice); međutim u zadnjem koraku (nakon što sam već upisao sve potrebne podatke, priložio screenshotove o uplati i sl.), u kojem je potrebno potpisati zahtjev, dobijem sljedeću pogrešku:
Kod: Označi sve
Greška [014] Za uspješno provođenje postupka kreiranja elektroničkog postupka eSigner servis mora biti dostupan. Ukoliko eSigner nije automatski pokrenut molimo Vas da ga pokrene ručno kroz Start Programs izbornik. Ukoliko se greška i dalje javlja, molimo Vas kontaktirajte korisničku službu izdavatelja certifikata


Dostupna dokumentacija mi je apsolutno beskorisna.

Je li netko od vas naletio na ovaj problem i znate li kako ga riješiti?

Koristim Firefox 57.0.2


EDIT: Ok, izgleda da je stvar u tome da je za Linux dostupan Middleware verziji 2.0.1, dok je, prema dokumentaciji potreban minimalno Middleware verzije 2.0.3. pface
KAJ
Avatar
Postovi: 53
Postovi: 53
Pridružen/a: 06 lip 2012, 14:46
Lokacija: Zagreb
Podijelio/la zahvalu: 14 puta
Primio/la zahvalu: 4 puta
Spol: M
OS: Manjaro KDE
Sorry na double postu, ali činilo mi se besmisleno editirati sinoćnji post.

Uglavnom, ako ikoga uopće zanima, definitivno je stvar u verziji Middlewarea dostupnog za Linux.
Naime, čak sam i sinoć dobio odgovor s eOI-Helpdeska gdje su potvrdili kako je minimalna verzija potrebna za mogućnost potpisivanja dokumenta 2.0.3.
Sad čekam da mi odgovore kad će konačno updateati i verziju za Linux.

Uglavnom, eto, na kraju sam bio prisiljen potpisati dokument na računalu s Windowsima (nisam nikako uspio natjerati čitač kartica da mi proradi u virtualki na kojoj imam Windows 7 za ovakve nezgodne slučajeve). :(
KAJ
Avatar
Postovi: 53
Postovi: 53
Pridružen/a: 06 lip 2012, 14:46
Lokacija: Zagreb
Podijelio/la zahvalu: 14 puta
Primio/la zahvalu: 4 puta
Spol: M
OS: Manjaro KDE
Pozdrav svima, novi na forumu :)

Trazim rjesenje problema za pristup portalu e-gradjani tj. pretincu...
Imam osobnu s cipom, imam citac, download-ao sam middleware app, aktivirao osobnu ali dobivam gresku svaki put na popup-u kod prijave.
Pokusao sam iz njihovih upustava za linux medjutim nista od toga. Ovdje vidim linkane certove, medjutim njihova komanda radi s ovim lokalnima u /usr/lib/eoimiddl.../pkcs11/libEidPkcs11.so
izlistam nakon toga certove, i nema taj njihov sa slike... Sad sam pak smuljao pa dobivam SEC_ERROR_BAD_DATABASE pa rjesavam to..

Koristim Debian 9 stretch, kako rijesiti te certove? ako ima neko objasnjenje vec, please linkajte jer sam ja samo ovu temu nasao.

Hvala puno
Postovi: 2
Postovi: 2
Pridružen/a: 12 tra 2018, 15:47
Podijelio/la zahvalu: 0 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Debian - Xfce
DevMaster je napisao/la:Koristim Debian 9 stretch, kako rijesiti te certove? ako ima neko objasnjenje vec, please linkajte jer sam ja samo ovu temu nasao.

U ovoj temi ima baš to što ti treba! Evo, na primjer, ja na vrhu ove (4.) ali i na prošloj (3.) stranici ukratko opisivao što i kako radi. Certifikati se instaliraju u web preglednik.
Abzeenth je napisao/la:Dobro onda. Baš me briga. Krepajte od offtopica.

jurastublic je napisao/la:Ovaj thread me podsjeća na krepanu mačku. Treba to pokupit lopatom i zakopat. Onda dezinficirati lopatu. :-D
Avatar
Moderator
Postovi: 5818
Moderator
Postovi: 5818
Pridružen/a: 25 ožu 2012, 14:29
Lokacija: ~/kauč
Podijelio/la zahvalu: 155 puta
Primio/la zahvalu: 250 puta
Spol: M
OS: Mint 17.3 Cimet
calisto053 je napisao/la:
DevMaster je napisao/la:Koristim Debian 9 stretch, kako rijesiti te certove? ako ima neko objasnjenje vec, please linkajte jer sam ja samo ovu temu nasao.

U ovoj temi ima baš to što ti treba! Evo, na primjer, ja na vrhu ove (4.) ali i na prošloj (3.) stranici ukratko opisivao što i kako radi. Certifikati se instaliraju u web preglednik.


Hvala na javljanju :)
Da, to sam spomenio. Ok, koje od tih certa s tog linka skinuti i ako instalacija znaci import onda mi chrome to odbija. Pokusat cu ponovno cisto da error tocan dobijem, ali nesto prigovara oko potpisa certa valjda.
I s tim certovima s linka i s onima iz ID clienta sam probao.
Postovi: 2
Postovi: 2
Pridružen/a: 12 tra 2018, 15:47
Podijelio/la zahvalu: 0 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Debian - Xfce

Na mreži
Trenutno korisnika/ca: / i 2 gostiju.