Sada je: 10 kol 2020, 23:47.
Diskusije o hardveru i driverima pod Linuxom.

Moderator/ica: Moderatori/ce

E ovako.Prelistao sam neke teme vezane za slične probleme i identične wlan kartice i znam da nema nekog univerzalnog rješenja pa da pitam ovdje konkretno.Radi se o wlan adapteru iz naslova,dakle to je bcm 4312.
Instalirao sam firmware-b43-installer i instalacija je automatski povukla i b43-cutter.Sa vlasničkim STA wireless driverom su bili isti problemi.Odradio sam i sudo modprobe b43,dodao b43 u /etc/modules i restart nakon toga.
Radi jedno vrijeme do trenutka kad treba obaviti dhcp renew i tad se odspoji sa wlan-a i jedino kad ručno nakon par puta isključim pa uključim ponovo adapter,proradi na neko vrijeme.Drugi laptop na istoj mreži radi bez problema.Kubuntu 14.04.3 32bit je u pitanju.
lspci -vnn -d 14e4: kaže ovako
Kod: Označi sve
Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
        Subsystem: Dell Wireless 1397 WLAN Mini-Card [1028:000c]
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at c8000000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [40] Power Management version 3
        Capabilities: [58] Vendor Specific Information: Len=78 <?>
        Capabilities: [e8] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [d0] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [13c] Virtual Channel
        Capabilities: [160] Device Serial Number c6-1b-9d-ff-ff-51-1c-65
        Capabilities: [16c] Power Budgeting <?>
        Kernel driver in use: b43-pci-bridge


Pomagajte please pface
Postovi: 7
Postovi: 7
Pridružen/a: 07 sij 2016, 13:52
Podijelio/la zahvalu: 6 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Kubuntu_14.04_x64
Netko?Itko da pomogne?Ne znam jel treba još kakav info?Borim se sa ovim već par dana i ne znam šta bi još mogao napravit.Ne želim eksperimentirat sa blacklistanjem ili instaliranjem,deinstaliranjem ako ne znam šta radim pa zato se i obraćam ovdje da mi netko stručniji pojasni.
Postovi: 7
Postovi: 7
Pridružen/a: 07 sij 2016, 13:52
Podijelio/la zahvalu: 6 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Kubuntu_14.04_x64
Imao sam istu WiFi karticu u Lenovu U350, no nakon instalacije vlasničkog drivera nisam imao nikakvih problema s njom tako da nemam pojma što tebe muči.
Ipak, kako mi u tom laptopu nije bilo prihvatljivo korištenje bilo kakvog vlasničkog softvera (članak imaš ovdje), jednom zauvijek sam problem s Broadcomom riješio zamjenom WiFi kartice za drugu sa Atheros AR9285 čipom... trošak 60 kn.

Što se tiče toga što ti još nitko nije odgovorio, samo opušteno... članovi odgovore i pomognu kad stignu ili kad znaju/saznaju odgovor.

:zen
[+ Prikaži] Klik
ThinkPad T440p
Intel Core i5-4300M
Intel HD Graphics 4600
16GB DDR3L
1xSanDisk X400 512 GB & 1x240GB Intel 2500 Pro
15.6" FHD IPS anti-glare
6 & 9 cell Li-Ion battery
OS: kako kada
Slika: dio kolekcije

***

ZEN
"Charlie. What are you thinking?"
"I'm thinking about what I want and what I need."
"What do you want?"
"I want a peaceful soul."
"And what do you need?"
"I need a bigger gun."
Avatar
Site Admin
Postovi: 10576
Site Admin
Postovi: 10576
Pridružen/a: 01 kol 2012, 12:39
Podijelio/la zahvalu: 576 puta
Primio/la zahvalu: 797 puta
Spol: M
OS: LinuxMint Cinnamon
Prvi put kad sam instalirao Kubuntu i ja sam instalirao vlasnički driver i počelo je štekat od početka pa sam naišao na članak negdje da sa tim driverom kartica ne radi kad se ruter prebaci na 12-ti kanal i onda sam u postavkama rutera fiksno postavio kanal i frekvenciju na kojoj je proradilo bez problema i radilo je neko vrijeme bez štekanja ali samo par dana.Mislio sam da je problem u ruteru ali tad ne bi radio ni drugi laptop sa Kubuntu 14.04 i istim mrežnim postavkama.Nakon tog sam se odlučio na b43 driver što očito nije rješilo problem.Nije mi bitno jel vlasnički ili open source driver nego samo da radi.
Mogu pričekat na odgovor,nije problem.Hvala Bertone :thmb-up
Postovi: 7
Postovi: 7
Pridružen/a: 07 sij 2016, 13:52
Podijelio/la zahvalu: 6 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Kubuntu_14.04_x64
Nemam istu karticu kao ti, ali imala sam ogromnih problema s drugim Broadcomovim "proizvodima", od toga da je veza pucala čim bi signal pao ispod 55% do toga da se pretvara da je spojen na wireless ali se apsolutno ništa ne može učitati ni pingati, i još svašta... Na kraju su logovi pokazali da se driver ruši tj. izaziva kernel panic.

Prijavila sam se na sve bug reportove na launchpadu koji su imali veze s mojim modelom kartice, odnosno sve koji su imali sličan problem. Za neke bugove su izdali zakrpe za paket bcmwl-kernel-source, pa sam ih probala instalirati; neke su pomogle, s nekima je bilo samo još gore. Na kraju mi je pomogla instalacija novijeg kernela. Ne znam znaš li kako se to radi, nije pretjerano teško, ali možda da pričekaš da se javi netko s još savjeta, pa novi kernel možeš ostaviti za kraj, ako ništa drugo ne pomogne.

Možeš i ti probati pročešljati postojeće bug reportove na launchpadu, naći probleme najsličnije tvojem i vidjeti jesu li izdane neke zakrpe za njih, pa probati njih instalirati. Ako ne pomogne, samo se vratiš tj. downgradeaš paket na prethodnu verziju. Ovdje možeš vidjeti bugove za bcmwl paket:
https://bugs.launchpad.net/ubuntu/+source/bcmwl

Sretno :thmb-up
Avatar
Site Admin
Postovi: 6511
Site Admin
Postovi: 6511
Pridružen/a: 06 lip 2009, 23:16
Lokacija: Online
Podijelio/la zahvalu: 621 puta
Primio/la zahvalu: 630 puta
OS: Kubuntu & Manjaro
Abzeenth je napisao/la:

Prijavila sam se na sve bug reportove na launchpadu koji su imali veze s mojim modelom kartice, odnosno sve koji su imali sličan problem. Za neke bugove su izdali zakrpe za paket bcmwl-kernel-source, pa sam ih probala instalirati; neke su pomogle, s nekima je bilo samo još gore. Na kraju mi je pomogla instalacija novijeg kernela. Ne znam znaš li kako se to radi, nije pretjerano teško, ali možda da pričekaš da se javi netko s još savjeta, pa novi kernel možeš ostaviti za kraj, ako ništa drugo ne pomogne.


Ili to, što bi bilo nekakvo konvencionalno rješenje, ukoliko ti se da testirati sustav sa raznim kernelima. Ili nabavka novog komadića hardvera kako ti predlaže Bertone, što bi recimo bilo nekakvo nekonvencionalno rješenje. A kad smo kod nekonvencionalnog možeš ako ti se da probati i ovo:
( i ako ti u susjedstvu ne žive neki potencijalni hakeri), Naime, malo je poznata činjenica među linux korisnicima da određeni drajveri rade bolje sa jednim protokolima, a drugi bolje rade opet sa drugim. Mislim na one wep, wpa, wpa2 protokole. Ja sam jedanput, jednom kolegi, riješio problem tako da sam promijenio njegov wifi protokol i sve je radilo bez pucanja veze. Naravno upozorio sam ga na pitanje sigurnosti veze. Ako se odlučiš za to rješenje, promijeni u ruteru protokol, obriši svoju wifi konekciju na laptopu i napravi novu sa tim drugim protokolom. Ponavljam, nije najsretnije rješenje, ali sam prilično siguran da će ti raditi, barem meni je.
Postovi: 252
Postovi: 252
Pridružen/a: 09 pro 2013, 17:28
Podijelio/la zahvalu: 12 puta
Primio/la zahvalu: 24 puta
Spol: M
OS: ubuntu mate/linux mint
teorijavelikogpraska je napisao/la:probati i ovo:
( i ako ti u susjedstvu ne žive neki potencijalni hakeri), Naime, malo je poznata činjenica među linux korisnicima da određeni drajveri rade bolje sa jednim protokolima, a drugi bolje rade opet sa drugim. Mislim na one wep, wpa, wpa2 protokole.

Ovo je živa istina. Meni je stalno pucala veza na više uređaja dok nisam sa WPA2 TKIP prebacio na WPA2 AES. Od tada nikakve brige. Mislim da je to bug u ruteru.
"Hodor bre foobar"
Avatar
Postovi: 1907
Postovi: 1907
Pridružen/a: 16 tra 2011, 08:34
Lokacija: i grupa Film
Podijelio/la zahvalu: 45 puta
Primio/la zahvalu: 341 puta
Spol: M
OS: Mint 10 LXDE itd...
Eo ga sad opet radi sa vlasničkim driverom :lulz Izbrisao sam profil postavki wlan-a na laptopu,ponovo kreirao profil,pokušao se spojit i nije bilo promjena ali nakon što sam deinstalirao firmware-b43-installer b43-cutter pa stavio vlasnički driver,proradilo je bez štucanja.U postavkama rutera nisam mjenjao ništa konkretno.Hvala svima koji su htjeli pomoći i nadam se da vas po ovom pitanju neću trebat ponovo :hihi
Postovi: 7
Postovi: 7
Pridružen/a: 07 sij 2016, 13:52
Podijelio/la zahvalu: 6 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Kubuntu_14.04_x64
Ne želim biti zloguki prorok, ali kod takvih promjena korisnik nikad nije posve siguran :pogled_dolje

Meni je bežična Broadcom 43142 na Deb Testing uredno prestajala s radom prilikom svake nadogradnje kernela. O toj muci pisalo se ovdje viewtopic.php?f=7&t=11339&start=10

Na kraju je zapečaćen već davno zastarjeli kernel 3.13, koji i dan danas guram uz Deb Testing, bez novih nadogradnji. Svi ostali paketi uredno se nadograđuju. Što se same bežične tiče, prije koji dan stigla mi je ova poruka:
Kod: Označi sve
Setting up broadcom-sta-dkms (6.30.223.271-2) ...
Loading new broadcom-sta-6.30.223.271 DKMS files...
Building only for 3.13-1-amd64
Building initial module for 3.13-1-amd64
Done.

wl:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.13-1-amd64/updates/dkms/

depmod....

Backing up initrd.img-3.13-1-amd64 to /boot/initrd.img-3.13-1-amd64.old-dkms
Making new initrd.img-3.13-1-amd64
(If next boot fails, revert to initrd.img-3.13-1-amd64.old-dkms image)
update-initramfs....

DKMS: install completed.


I tako ostaje. Radi besprijekorno, ali pitam se zašto :hmm
Avatar
Postovi: 893
Postovi: 893
Pridružen/a: 27 ruj 2012, 12:39
Podijelio/la zahvalu: 62 puta
Primio/la zahvalu: 100 puta
Spol: M
OS: Debian Mate

Na mreži
Trenutno korisnika/ca: / i 1 gost.