Sada je: 25 kol 2019, 09:13.
Novi ste u svijetu Linuxa? Imate hrpu početničkih pitanja?

Moderator/ica: Moderatori/ce

Pravila foruma
PRAVILA ZA NOVE KORISNIKE LINUXA!
Prije otvaranja bilo kakve diskusije svaki novi korisnik u svijetu Linuxa obavezan je učiniti sljedeće korake:
Pročitati ove tekstove iz naše Wikipedije:
- Sve uvodne tekstove Linuxa za početnike (njih 5)
- Sve što trebate znati o radu s diskovima
- Pročitati ovu temu za početnike
- Pokušati pronaći riješenje problema u Enciklopediji znanja

Nakon toga korisnik smije otvoriti temu s naslovom svog problema uz obaveznu naznaku Linux distribucije koju koristi u formi:
[Linux distribucija, broj verzije, grafičko okruženje]: Naslov problema
U prvom postu korisnik obavezno mora odgovoriti na ova pitanja:
- Da li ima instalirane Windowse?
- Što ga je motiviralo na instaliranje i korištenje Linux distribucije?
- Obavezno je potrebno navesti specifikacije hardvera (Ime Laptopa, tip procesora, grafičke i mrežne kartice, količina RAM-a i diska)

Bez učinjenih ovih prvih koraka, na teme se neće odgovarati i one će biti izbrisane s foruma!
Dobra večer/dan/jutro zavisi kad budete čitali.

Imam jedan 'problem' sa Terminalom, neće da sluša il' ja ne znam koristit dovoljno dobro.

Eh sad, Python sam skinio preko Terminala i on radi. A kad sam došao do dodatka neće da ih skine. Tipa:Spyder,Kate...
Dobijem poruku:

Kod: Označi sve
sudo easy_install pipsudo: easy_install: command not found


Kod: Označi sve
No passwd entry for user 'easy_install'

I slične poruke.

I da, scriptu za učit sam skinio ovdje: https://bitbucket.org/simriteh/python-school U skripti sam stao na 1.2 Dodatni Paketi.

OFF TOPIC:
Nadam se da sam dobro opisao svoj problem, nisam nešto maher za pisat duge poruke. :oops

(nedavno sam bio pisao u ovoj temi 'Linux početnici i puno ste mi pomogli da se odlučim, šta da izaber, šta je najbolje i zabavnije za mene) :thmb-up
Avatar
Postovi: 20
Postovi: 20
Pridružen/a: 19 kol 2016, 10:19
Podijelio/la zahvalu: 3 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Linux mint 18
Prvo instaliraj:
Kod: Označi sve
sudo apt-get install python-setuptools

pa onda kreni sa easy_install.
http://askubuntu.com/questions/27519/ca ... sy-install
Avatar
Postovi: 1795
Postovi: 1795
Pridružen/a: 15 sij 2014, 09:37
Lokacija: Zaljev svetaca
Podijelio/la zahvalu: 68 puta
Primio/la zahvalu: 177 puta
Spol:
OS: Leap 15 / Linux Mint 19
Hvala.

E sad, kad sam pokušao Spyder istalirati ovo sam dobio.
Kod: Označi sve
sudo easy_install Spyder
Searching for Spyder
Reading https://pypi.python.org/simple/Spyder/
Best match: spyder 3.0.0
Downloading https://pypi.python.org/packages/64/5f/2755899e05cfff86611c972570c20a6ccf56a6c1ffa633358740809331a4/spyder-3.0.0.tar.gz#md5=7f5ef3f62d4c6f2d6a0ee9ec305b8c6a
Processing spyder-3.0.0.tar.gz
Writing /tmp/easy_install-R0Ltao/spyder-3.0.0/setup.cfg
Running spyder-3.0.0/setup.py -q bdist_egg --dist-dir /tmp/easy_install-R0Ltao/spyder-3.0.0/egg-dist-tmp-txVuxK
WARNING: unable to build documentation because Sphinx is not installed
warning: no files found matching '*.svg' under directory 'spyder_breakpoints'
warning: no files found matching '*.png' under directory 'spyder_breakpoints'
warning: no files found matching '*.svg' under directory 'spyder_profiler'
warning: no files found matching '*.svg' under directory 'spyder_pylint'
warning: no files found matching '*.' under directory 'doc'
warning: no files found matching 'CHANGELOG'
zip_safe flag not set; analyzing archive contents...
spyder.interpreter: module references __file__
spyder.__init__: module references __file__
spyder.requirements: module references __file__
spyder.app.restart: module references __file__
spyder.app.mainwindow: module references __file__
spyder.app.mainwindow: module references __path__
spyder.config.base: module references __file__
spyder.utils.codeanalysis: module references __file__
spyder.utils.debug: module MAY be using inspect.stack
spyder.utils.dochelpers: module MAY be using inspect.getsource
spyder.utils.dochelpers: module MAY be using inspect.getcomments
spyder.utils.programs: module MAY be using inspect.getsource
spyder.utils.icon_manager: module references __file__
spyder.utils.vcs: module references __file__
spyder.utils.ipython.start_kernel: module references __file__
spyder.utils.introspection.jedi_plugin: module references __file__
spyder.utils.introspection.rope_plugin: module references __file__
spyder.utils.introspection.fallback_plugin: module references __file__
spyder.utils.introspection.module_completion: module references __file__
spyder.utils.introspection.module_completion: module references __path__
spyder.utils.introspection.plugin_client: module references __file__
spyder.utils.site.sitecustomize: module references __file__
spyder.utils.site.osx_app_site: module references __file__
spyder.widgets.explorer: module references __file__
spyder.widgets.sourcecode.codeeditor: module references __file__
spyder.widgets.externalshell.pythonshell: module references __file__
spyder.widgets.externalshell.systemshell: module references __file__
spyder.widgets.projects.explorer: module references __file__
spyder_profiler.widgets.profilergui: module MAY be using inspect.getsource
spyder_pylint.widgets.pylintgui: module references __file__
creating /usr/local/lib/python2.7/dist-packages/spyder-3.0.0-py2.7.egg
Extracting spyder-3.0.0-py2.7.egg to /usr/local/lib/python2.7/dist-packages
Adding spyder 3.0.0 to easy-install.pth file
Installing spyder script to /usr/local/bin

Installed /usr/local/lib/python2.7/dist-packages/spyder-3.0.0-py2.7.egg
Processing dependencies for Spyder
Searching for pyzmq
Reading https://pypi.python.org/simple/pyzmq/
Best match: pyzmq 15.4.0
Downloading https://pypi.python.org/packages/ab/3a/5826efd93ebbbdc33203f70c6ceebab1b58ac6cb1e1ab131cc6b990b4cfa/pyzmq-15.4.0.tar.gz#md5=d92fa329c20c72f4831a6aaca8057b2a
Processing pyzmq-15.4.0.tar.gz
Writing /tmp/easy_install-Ouytn1/pyzmq-15.4.0/setup.cfg
Running pyzmq-15.4.0/setup.py -q bdist_egg --dist-dir /tmp/easy_install-Ouytn1/pyzmq-15.4.0/egg-dist-tmp-ShNLuK
warning: no files found matching 'tox.ini'
no previously-included directories found matching 'docs/build'
no previously-included directories found matching 'docs/gh-pages'
warning: no previously-included files found matching 'bundled/zeromq/src/Makefile*'
warning: no previously-included files found matching 'bundled/zeromq/src/platform.hpp'
warning: no previously-included files found matching 'zmq/libzmq*'
warning: no previously-included files matching '__pycache__/*' found anywhere in distribution
warning: no previously-included files matching '.deps/*' found anywhere in distribution
warning: no previously-included files matching '*.so' found anywhere in distribution
warning: no previously-included files matching '*.pyd' found anywhere in distribution
warning: no previously-included files matching '.git*' found anywhere in distribution
warning: no previously-included files matching '.DS_Store' found anywhere in distribution
warning: no previously-included files matching '.mailmap' found anywhere in distribution
warning: no previously-included files matching 'Makefile.am' found anywhere in distribution
warning: no previously-included files matching 'Makefile.in' found anywhere in distribution
Did not find libzmq via pkg-config.
{'libraries': ['zmq'], 'extra_link_args': [], 'runtime_library_dirs': [], 'library_dirs': [], 'include_dirs': []}
build/temp.linux-x86_64-2.7/scratch/check_sys_un.c:1:19: fatal error: stdio.h: No such file or directory
compilation terminated.
Warning: No sys/un.h, IPC_PATH_MAX_LEN will be undefined: command 'x86_64-linux-gnu-gcc' failed with exit status 1
************************************************
Configure: Autodetecting ZMQ settings...
    Custom ZMQ dir:       
/tmp/easy_install-Ouytn1/pyzmq-15.4.0/temp/timer_createabroGq.c:1:1: warning: return type defaults to ‘int’ [-Wimplicit-int]
 main (int argc, char **argv) {
 ^
/tmp/easy_install-Ouytn1/pyzmq-15.4.0/temp/timer_createabroGq.c: In function ‘main’:
/tmp/easy_install-Ouytn1/pyzmq-15.4.0/temp/timer_createabroGq.c:2:5: warning: implicit declaration of function ‘timer_create’ [-Wimplicit-function-declaration]
     timer_create();
     ^
/usr/bin/ld: cannot find crt1.o: No such file or directory
/usr/bin/ld: cannot find crti.o: No such file or directory
/usr/bin/ld: cannot find -lc
/usr/bin/ld: cannot find crtn.o: No such file or directory
collect2: error: ld returned 1 exit status
build/temp.linux-x86_64-2.7/scratch/vers.c:3:19: fatal error: stdio.h: No such file or directory
compilation terminated.

error: command 'x86_64-linux-gnu-gcc' failed with exit status 1

Failed with default libzmq, trying again with /usr/local
{'libraries': ['zmq'], 'extra_link_args': [], 'runtime_library_dirs': [], 'library_dirs': ['/usr/local/lib'], 'include_dirs': ['/usr/local/include']}
************************************************
Configure: Autodetecting ZMQ settings...
    Custom ZMQ dir:       /usr/local
/tmp/easy_install-Ouytn1/pyzmq-15.4.0/temp/timer_createewAnBY.c:1:1: warning: return type defaults to ‘int’ [-Wimplicit-int]
 main (int argc, char **argv) {
 ^
/tmp/easy_install-Ouytn1/pyzmq-15.4.0/temp/timer_createewAnBY.c: In function ‘main’:
/tmp/easy_install-Ouytn1/pyzmq-15.4.0/temp/timer_createewAnBY.c:2:5: warning: implicit declaration of function ‘timer_create’ [-Wimplicit-function-declaration]
     timer_create();
     ^
Assembler messages:
Fatal error: can't create build/temp.linux-x86_64-2.7/scratch/tmp/easy_install-Ouytn1/pyzmq-15.4.0/temp/timer_createewAnBY.o: No such file or directory
build/temp.linux-x86_64-2.7/scratch/vers.c:3:19: fatal error: stdio.h: No such file or directory
compilation terminated.

error: command 'x86_64-linux-gnu-gcc' failed with exit status 1

************************************************
Warning: Couldn't find an acceptable libzmq on the system.

If you expected pyzmq to link against an installed libzmq, please check to make sure:

    * You have a C compiler installed
    * A development version of Python is installed (including headers)
    * A development version of ZMQ >= 3.2 is installed (including headers)
    * If ZMQ is not in a default location, supply the argument --zmq=<path>
    * If you did recently install ZMQ to a default location,
      try rebuilding the ld cache with `sudo ldconfig`
      or specify zmq's location with `--zmq=/usr/local`

You can skip all this detection/waiting nonsense if you know
you want pyzmq to bundle libzmq as an extension by passing:

    `--zmq=bundled`

I will now try to build libzmq as a Python extension
unless you interrupt me (^C) in the next 10 seconds...

 1...
************************************************
Using bundled libzmq
already have bundled/zeromq
attempting ./configure to generate platform.hpp
Warning: failed to configure libzmq:
/bin/sh: 1: ./configure: not found

staging platform.hpp from: /tmp/easy_install-Ouytn1/pyzmq-15.4.0/buildutils/include_linux
************************************************
checking for timer_create
/tmp/easy_install-Ouytn1/pyzmq-15.4.0/temp/timer_creater61UMZ.c:1:1: warning: return type defaults to ‘int’ [-Wimplicit-int]
 main (int argc, char **argv) {
 ^
/tmp/easy_install-Ouytn1/pyzmq-15.4.0/temp/timer_creater61UMZ.c: In function ‘main’:
/tmp/easy_install-Ouytn1/pyzmq-15.4.0/temp/timer_creater61UMZ.c:2:5: warning: implicit declaration of function ‘timer_create’ [-Wimplicit-function-declaration]
     timer_create();
     ^
/usr/bin/ld: cannot find crt1.o: No such file or directory
/usr/bin/ld: cannot find crti.o: No such file or directory
/usr/bin/ld: cannot find -lc
/usr/bin/ld: cannot find crtn.o: No such file or directory
collect2: error: ld returned 1 exit status
no timer_create, linking librt
************************************************
buildutils/initlibzmq.c:10:20: fatal error: Python.h: No such file or directory
compilation terminated.
error: Setup script exited with error: command 'x86_64-linux-gnu-gcc' failed with exit status 1


A pyapp: na Linku naišao što si zaljepio, činilo se uredu.
Kod: Označi sve
sudo pip install py2app
The directory '/home/c0bra01/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
The directory '/home/c0bra01/.cache/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
Collecting py2app
  Downloading py2app-0.10.tar.gz (1.7MB)
    100% |████████████████████████████████| 1.7MB 294kB/s
Collecting altgraph>=0.12 (from py2app)
  Downloading altgraph-0.12.tar.gz (492kB)
    100% |████████████████████████████████| 501kB 756kB/s
Collecting modulegraph>=0.12 (from py2app)
  Downloading modulegraph-0.12.1.tar.gz (677kB)
    100% |████████████████████████████████| 686kB 642kB/s
Collecting macholib>=1.5 (from py2app)
  Downloading macholib-1.7.tar.gz (475kB)
    100% |████████████████████████████████| 481kB 773kB/s
Installing collected packages: altgraph, modulegraph, macholib, py2app
  Running setup.py install for altgraph ... done
  Running setup.py install for modulegraph ... done
  Running setup.py install for macholib ... done
  Running setup.py install for py2app ... error
    Complete output from command /usr/bin/python -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-UcOUh0/py2app/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-Iu8yvE-record/install-record.txt --single-version-externally-managed --compile:
    usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
       or: -c --help [cmd1 cmd2 ...]
       or: -c --help-commands
       or: -c cmd --help
   
    error: option --single-version-externally-managed not recognized
   
    ----------------------------------------
Command "/usr/bin/python -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-UcOUh0/py2app/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-Iu8yvE-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-build-UcOUh0/py2app/

Kate
sudo easy_install Kate
Searching for Kate
Reading https://pypi.python.org/simple/Kate/
Couldn't find index page for 'Kate' (maybe misspelled?)
Scanning index of all packages (this may take a while)
Reading https://pypi.python.org/simple/

Mislio sam da se razumijem u kompjutere dok nisam naišao na Linux :sokiran Ma samo da imam sve instalirano za Python ja zadovoljan, taman nađem nešto korisino i vidi šta mi se događa. Nikad na zelenu granu.
Avatar
Postovi: 20
Postovi: 20
Pridružen/a: 19 kol 2016, 10:19
Podijelio/la zahvalu: 3 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Linux mint 18
Mint, kao i većina linuxa dolazi s predinstaliranim python interpreterom, samo ovisi je li 2.7 ili 3. Ako ti fali neka verzija koja nije instalirana, instaliraj uobičajenim putem (zajedno sa kate i spyderom), najbolje ovako: sudo apt-get install python python3 kate spyder

Stvar je u tome da će se tako odmah riješiti zavisnosti (jesi li pogledao o koliko stvari ovisi spyder, a bogme i Kate ako nemaš KDE!?)

Edit: ako spyder neće ili ti verzija nije po volji, možeš onda probati i sa pip install spyder
http://pythonhosted.org/spyder/installa ... g-on-linux
Avatar
Postovi: 1891
Postovi: 1891
Pridružen/a: 16 tra 2011, 08:34
Lokacija: i grupa Film
Podijelio/la zahvalu: 45 puta
Primio/la zahvalu: 337 puta
Spol: M
OS: Mint 10 LXDE itd...
Hvala!!! Uspijelo je zajedno sve istalirati.

E sad mi Kate radi, otvori se program i mogu radi a to što si rekao za spyder neće drugčije da istalira nego sa codom

Kod: Označi sve
sudo apt-get install spyder


Ali kad sam istalirao i hoću da se otvori, on izlista:

Kod: Označi sve
 spyder
Traceback (most recent call last):
  File "/usr/local/bin/spyder", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2985, in <module>
    @_call_aside
  File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2971, in _call_aside
    f(*args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 2998, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 660, in _build_master
    ws.require(__requires__)
  File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 968, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 854, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'qtpy>=1.1.0' distribution was not found and is required by spyder

i neće da se otvori, no radi Kate. :drool

jurastublic je napisao/la:Stvar je u tome da će se tako odmah riješiti zavisnosti (jesi li pogledao o koliko stvari ovisi spyder, a bogme i Kate ako nemaš KDE!?)

Nisam gledao. :hmm Na što naletim ja čitam, još na to očito nisam naišao. btw tnx :bravo :thmbs-up
Avatar
Postovi: 20
Postovi: 20
Pridružen/a: 19 kol 2016, 10:19
Podijelio/la zahvalu: 3 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Linux mint 18
probaj:
Kod: Označi sve
sudo pip install qtpy

(eh, khm, ovisi o nečemu čega nema u službenom repou; vidiš po ovome što nedostaje:
pkg_resources.DistributionNotFound: The 'qtpy>=1.1.0' distribution was not found and is required by spyder)
Avatar
Postovi: 1891
Postovi: 1891
Pridružen/a: 16 tra 2011, 08:34
Lokacija: i grupa Film
Podijelio/la zahvalu: 45 puta
Primio/la zahvalu: 337 puta
Spol: M
OS: Mint 10 LXDE itd...
Hvala, nije samo to pface i : qtawesome, psutil nakon psutil problem opet nastaje...
Kod: Označi sve
    compilation terminated.
    error: command 'x86_64-linux-gnu-gcc' failed with exit status 1
   
    ----------------------------------------
Command "/usr/bin/python -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-GCbJZK/psutil/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-pAlacC-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-build-GCbJZK/psutil/


Ovo command je pod crveno... Što nije dobro. :hmm
Avatar
Postovi: 20
Postovi: 20
Pridružen/a: 19 kol 2016, 10:19
Podijelio/la zahvalu: 3 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Linux mint 18
Ne znam, kod mene na 17.3 radi. Ne znam je li problem u mint18 ili nešto sa verzijama pythona kod tebe. Uglavnom, taj paket "psutil" imaš u synapticu (u službenom repou) kao "python-psutil" pa probaj. Ili možda da probaš instalirati pyqt, možda povuče takve stvari.
Avatar
Postovi: 1891
Postovi: 1891
Pridružen/a: 16 tra 2011, 08:34
Lokacija: i grupa Film
Podijelio/la zahvalu: 45 puta
Primio/la zahvalu: 337 puta
Spol: M
OS: Mint 10 LXDE itd...
Fale paketi za buildanje kao i python-dev? :hmm
Avatar
Postovi: 1795
Postovi: 1795
Pridružen/a: 15 sij 2014, 09:37
Lokacija: Zaljev svetaca
Podijelio/la zahvalu: 68 puta
Primio/la zahvalu: 177 puta
Spol:
OS: Leap 15 / Linux Mint 19
jurastublic je napisao/la:Ne znam, kod mene na 17.3 radi. Ne znam je li problem u mint18 ili nešto sa verzijama pythona kod tebe. Uglavnom, taj paket "psutil" imaš u synapticu (u službenom repou) kao "python-psutil" pa probaj. Ili možda da probaš instalirati pyqt, možda povuče takve stvari.

Jesam! Ne radi pod "pip", već sam morao 'get-apt' upisivati i pokušao ponovo 'psutil' da skinem i opet isto. Da mjenjam Mint 18 za neki drugi?

vision je napisao/la:Fale paketi za buildanje kao i python-dev? :hmm


Nezz. Moreš napisat naredbe da probam? :)
Avatar
Postovi: 20
Postovi: 20
Pridružen/a: 19 kol 2016, 10:19
Podijelio/la zahvalu: 3 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Linux mint 18

Na mreži
Trenutno korisnika/ca: / i 1 gost.