Sada je: 17 stu 2019, 16:56.
Novi ste u svijetu Linuxa? Imate hrpu početničkih pitanja?

Moderator/ica: Moderatori/ce

Pravila foruma
PRAVILA ZA NOVE KORISNIKE LINUXA!
Prije otvaranja bilo kakve diskusije svaki novi korisnik u svijetu Linuxa obavezan je učiniti sljedeće korake:
Pročitati ove tekstove iz naše Wikipedije:
- Sve uvodne tekstove Linuxa za početnike (njih 5)
- Sve što trebate znati o radu s diskovima
- Pročitati ovu temu za početnike
- Pokušati pronaći riješenje problema u Enciklopediji znanja

Nakon toga korisnik smije otvoriti temu s naslovom svog problema uz obaveznu naznaku Linux distribucije koju koristi u formi:
[Linux distribucija, broj verzije, grafičko okruženje]: Naslov problema
U prvom postu korisnik obavezno mora odgovoriti na ova pitanja:
- Da li ima instalirane Windowse?
- Što ga je motiviralo na instaliranje i korištenje Linux distribucije?
- Obavezno je potrebno navesti specifikacije hardvera (Ime Laptopa, tip procesora, grafičke i mrežne kartice, količina RAM-a i diska)

Bez učinjenih ovih prvih koraka, na teme se neće odgovarati i one će biti izbrisane s foruma!
rudar je napisao/la:Ako si preuzeo odgovarajući driver s linka koji sam prije spomenuo, moraš ga pokrenuti posebnom naredbom u terminalu kako tamo stoji, ovom:
Kod: Označi sve
tar -xJvf amdgpu-pro_*.tar.xz


Zatim slijedi
Kod: Označi sve
cd amdgpu-pro-XX.XX-XXXXXX
, pri čemu umjesto xxx upisuješ podatke koji stoje na tom driveru koji si preuzeo. Mislim da su tamo navedene upute dovoljno jasne.

Na kraju, ti dobijaš ovlasti (permissions) kao root, kad ti to treba. Znači, terminal, pa
Kod: Označi sve
sudo
i onda unesi svoju root lozinku, koju si postavio prilikom instalacije.

Nece da prva komanda.
dell@Dell-Linux:~/Downloads$ tar -xJvf amdgpu-pro_*.tar.xz
tar (child): amdgpu-pro_*.tar.xz: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now
Niti imam to amdgpu-pro u tim fajlovima sto skinem a ni kad raspakujem. Imam samo
control.tar.gz i data.tar.gz i debian-binary
A kad promenim ime na komandi, ukucam ovako umestu gpu-pro stavim ovaj control

tar -xJvf control.tar.gz
xz: (stdin): File format not recognized
tar: Child returned status 1
tar: Error is not recoverable: exiting now
Dravjer kad skinem zove se:
fglrx_15.201-0ubuntu1_amd64_UB_14.01.deb
Postovi: 12
Postovi: 12
Pridružen/a: 27 pro 2018, 21:34
Podijelio/la zahvalu: 0 puta
Primio/la zahvalu: 1 puta
Spol: M
OS: Ubuntu 18.04
Ovako,mislim da na ubuntu verzijama 16.04 i 18.04 ti vlasnički drajveri nisu više podržani,dakle ubuntu koristi one otvorenog koda,koji su već u ubuntu,zato na amd stranici i piše za taj drajver ubuntu 14.04.Možeš probati ovo:
1.instalacija naravno nije uspjela jer se kod tebe drugačije zove drajver,dakle opet idi u Downloads,desni klik,ovdje otvori terminal,ova naredba:
Kod: Označi sve
sudo dpkg -i fglrx_15.201-0ubuntu1_amd64_UB_14.01.deb

možda ti ovo ne uspije do kraja jer kažem na 18.04 više to nije podržano,(drukčiji xorg itd.)
2.u ubuntu tražilici upiši drivers,pokreni alat additional drivers(ili kod tebe piše upravitelj upravljačkih programa)pa vidi hoće li ti ponuditi amd drajver za instalaciju,ako da instaliraj.To su drajveri otvorenog koda.
3.instaliraj umjesto ubuntu 18.04, 14.04 ako ti se da reinstalirati naravno.
Postovi: 118
Postovi: 118
Pridružen/a: 21 lip 2016, 18:37
Podijelio/la zahvalu: 1 puta
Primio/la zahvalu: 11 puta
Spol: M
OS: mint 13 64bit xfce
barbaivo je napisao/la:Ovako,mislim da na ubuntu verzijama 16.04 i 18.04 ti vlasnički drajveri nisu više podržani,dakle ubuntu koristi one otvorenog koda,koji su već u ubuntu,zato na amd stranici i piše za taj drajver ubuntu 14.04.Možeš probati ovo:
1.instalacija naravno nije uspjela jer se kod tebe drugačije zove drajver,dakle opet idi u Downloads,desni klik,ovdje otvori terminal,ova naredba:
Kod: Označi sve
sudo dpkg -i fglrx_15.201-0ubuntu1_amd64_UB_14.01.deb

možda ti ovo ne uspije do kraja jer kažem na 18.04 više to nije podržano,(drukčiji xorg itd.)
2.u ubuntu tražilici upiši drivers,pokreni alat additional drivers(ili kod tebe piše upravitelj upravljačkih programa)pa vidi hoće li ti ponuditi amd drajver za instalaciju,ako da instaliraj.To su drajveri otvorenog koda.
3.instaliraj umjesto ubuntu 18.04, 14.04 ako ti se da reinstalirati naravno.

Instaliro sam 14.04. Nema razlike u drajverima. Otiso sam tu u additional drivers. Priakze mi da se koriste kao testirani drajveri X.Org server i ispod mi ponudi jos 2 ali ne mogu njih da odaberem, kad kliknem na bilo koji pa onda apply vrati na ovaj defaultni x.org..
A samo da odgovorim ovom sto kaze da ubuntu funkcionise kao windows sa drajverima i da sam instalira. Pa znam ja da sam instalira, inace ne bi bila fullHD rezolucija. I na windowsu sam instalira ALI ONE OBICNE drajvere, ne instalira full drajvere originalne sa AMD stranice i onda ti je graficka slabija 5 puta. Malo losije radi sam windows, ali najvise se osjeti u igricama. Evo primjer cs 1.6. Sa obicnim drajverima na nekoj losijoj grafickoj, imas 20-30-50fps , a kad isntaliras originalne drajvere imas 150-200fps. I onda lagano igras na 100fps zakucano. Tako je i ovde. Ne moze u cjelom sistemu da budu svi drajveri od svake graficke i da to spakuju u 1gb fajla. To samo obicne drajvere koji se zovu pomocni drajveri spakuju da bi mogao uopste koristiti windows, zato se i zovu pomocni da bi bacalo sliku na monitor neku, da bi ti mogao da skines prave koje na windowsu za moju graficku skoro 200mb zauzimaju. Sad kad bi oni stavljali od svake graficke po 200mb, windows ne bi zauzimao 3-4gb nego 300TB i vise. Tako je slucaj i ovde, sigurno. Instalriani su mi pomocni drajveri, i zato losije radi linux, nije smooth kao win 7 animacije i tako kad skrolam web stranice itd. A zasto onda ljudi svagdje pisu ako imate stari racunar koji lose radi, da mu se uradi linux i onda ce da radi kako treba kad ja vidim da je kontra situacija.. Imao sam i stariji komp, nvidia graf pa tad je bio aktuelan 16.04 ubuntu, tad takodje je lose radilo, losije nego sad ovaj jer i bio je dual core, graf 512 9600gt 2gb ram. Ja na windowsu znam sve, ja napravim podesim sve ne radim windows po 4-5 godina, jer radi kao i prvog dana. A ovde jhe sve zapetljano i nelogicno, od prosti stvari napravljeno komplikovano. osjecam se kao da ucim ispocetka windows sto ne bi trebalo, jer neke osnovne stvari bi trebale da budu klik i cao, a ne da moram kucati po terminalu. Mislim nisam skinuo linux cisti pa da to se radi, ovo je distribucija kojoj je glavni cilj da pojednostavi stvari ali vidim opet nije ni blizu windowsu a moze jer linux ima vise mogucnosti nego windows
Eto kad nema da podesis skrol na misu. Moram hiljadu puta vrtiti krug da preskrolam stranicu. Tamo lepo ima koliko da se racuna jedan potez povlacenja skrola i koliko da prelista stranice. a ovde samo brzina misa. Mozda ima ali da se skida neki program sto je bezveze. To su osnovne opcije. Bar da su povecali na normalan broj skorlova pa ostavili da skines program ako hoces da mjenjas. Ne, nego sad svako normalan mora skidati da bi podesio normalan defaultni broj koji bi trebao da bude.
Zadnja izmjena: mist1; 28 pro 2018, 20:46; ukupno mijenjano 1 put/a.
Postovi: 12
Postovi: 12
Pridružen/a: 27 pro 2018, 21:34
Podijelio/la zahvalu: 0 puta
Primio/la zahvalu: 1 puta
Spol: M
OS: Ubuntu 18.04
Jes ti probao ono pod 1.,zanima me zaista kako je prošlo?Sad kad imaš ubuntu 14.04 možeš opet skinit onaj fglrx pa instaliraj kako ti je opisano ako do sad nisi.
Postovi: 118
Postovi: 118
Pridružen/a: 21 lip 2016, 18:37
Podijelio/la zahvalu: 1 puta
Primio/la zahvalu: 11 puta
Spol: M
OS: mint 13 64bit xfce
barbaivo je napisao/la:Jes ti probao ono pod 1.,zanima me zaista kako je prošlo?Sad kad imaš ubuntu 14.04 možeš opet skinit onaj fglrx pa instaliraj kako ti je opisano ako do sad nisi.

Probo sam dupli klik i krene instalacija ali pise da kao nisu preporuceni ti drajveri i moze se nastaviti, sad bi ja to nastavio ali nzm da li cu moci vratiti na ove ako oni budu jos gori ali ne bi trebalo da budu jer onda je linux nesto pojeban a ne drajveri jer sa tim drajverima bi trebao da leti komp ka osto je slucaj na windowsu kad ih skinem pa instaliram, onda leti
EDIT: ma nece sad ni oni, pise breaks existing package 'xserver-xorg-core-lts-xenial" conflict fglrx ()
Postovi: 12
Postovi: 12
Pridružen/a: 27 pro 2018, 21:34
Podijelio/la zahvalu: 0 puta
Primio/la zahvalu: 1 puta
Spol: M
OS: Ubuntu 18.04
To što ti piše xenial to ti je xenial xerus dakle ubuntu 18.04,dakle ti nisi instalirao sustav ubuntu 14.04 .Znači moraš skinuti i instalirati drugu distribuciju a ne ovu koju ti imaš.(Nadam se da nisi sredio sustav,ako jesi instaliraj ponovo).
Postovi: 118
Postovi: 118
Pridružen/a: 21 lip 2016, 18:37
Podijelio/la zahvalu: 1 puta
Primio/la zahvalu: 11 puta
Spol: M
OS: mint 13 64bit xfce
barbaivo je napisao/la:To što ti piše xenial to ti je xenial xerus dakle ubuntu 18.04,dakle ti nisi instalirao sustav ubuntu 14.04 .Znači moraš skinuti i instalirati drugu distribuciju a ne ovu koju ti imaš.(Nadam se da nisi sredio sustav,ako jesi instaliraj ponovo).

Jesam skino 14.04 1GB iso zauzimo, preko Rufusa ga na USB i instaliro. I drugacije je sad sam destop i applikacije. Malopre je moglo dupli klik i pokrene, sad to izbacuje sto sam napiso. I amlopre sam bio na 14.04 i iste drajvere pokreto i moglo ali nisam nastavljao jer je pisalo kao da ne preporucuju te nesto tako, oprez itd
Inace napravio sam ovo dugme scroll lock da radi i ubrzo sam skrol na misu.
Evo dole slika pa vidi da je 14.04 stari
https://i.imgur.com/axB7M0N.jpg
Zadnja izmjena: mist1; 28 pro 2018, 21:22; ukupno mijenjano 1 put/a.
Postovi: 12
Postovi: 12
Pridružen/a: 27 pro 2018, 21:34
Podijelio/la zahvalu: 0 puta
Primio/la zahvalu: 1 puta
Spol: M
OS: Ubuntu 18.04
@mist1, tražeći rješenje za tvoj problem pogledao sam ovaj tutorijal https://www.youtube.com/watch?v=lebB_CMzu0w

Pojednostavljeno rečeno, mislim da s linka https://www.amd.com/en/support/kb/relea ... -lin-18-10 trebaš preuzeti driver pod oznakom Radeon Software for Linux version 18.10 for Ubuntu 16.04.4. To je velik file, koji ima 545 MB. Kad ga preuzmeš, unesi redom tri naredbe u terminal:

Kod: Označi sve
tar -xJvf amdgpu-pro_*.tar.xz


zatim

Kod: Označi sve
cd amdgpu-pro X.x


i na kraju

Kod: Označi sve
./amdgpu-pro-install -y


Tako je problem riješen u tutorijalu. Treba malo vremena dok se sve složi, jer je razmjerno veliki file i treba ga prvo raspakirati i onda složiti na mjesto i pokrenuti.

Šteta je što ovu raspravu ne prati kolega @JH-IM s foruma, jer je on ovdje najviše pisao o Ubuntuu, koji meni osobno baš i nije draga distra. Nadam se da ćeš uspjeti riješiti problem i nemoj se obeshrabriti misleći da je Windows bolji. Linux je jednostavno drukčiji i traži veći angažman korisnika. Sretno!
Zadnja izmjena: rudar; 28 pro 2018, 21:23; ukupno mijenjano 1 put/a.
Avatar
Postovi: 879
Postovi: 879
Pridružen/a: 27 ruj 2012, 12:39
Podijelio/la zahvalu: 62 puta
Primio/la zahvalu: 99 puta
Spol: M
OS: Debian Mate
rudar je napisao/la:@mist1, tražeći rješenje za tvoj problem pogledao sam ovaj tutorijal https://www.youtube.com/watch?v=lebB_CMzu0w

Pojednostavljeno rečeno, mislim da s linka https://www.amd.com/en/support/kb/relea ... -lin-18-10 trebaš preuzeti driver pod oznakom Radeon Software for Linux version 18.10 for Ubuntu 16.04.4. To je velik file, koji ima 545 MB. Kad ga preuzmeš, unesi redom tri naredbe u terminal:

Kod: Označi sve
tar -xJvf amdgpu-pro_*.tar.xz


zatim

Kod: Označi sve
cd amdgpu-pro X.x


i na kraju

Kod: Označi sve
./amdgpu-pro-install -y


Tako je problem riješen u tutorijalu. Treba malo vremena dok se sve složi, jer je razmjerno veliki file i treba ga prvo raspakirati i onda složiti na mjesto i pokrenuti.

Šteta je što ovu raspravu ne prati kolega @HJ-IM s foruma, jer je on ovdje najviše pisao o Ubuntuu, koji meni osobno baš i nije draga distra. Nadam se da ćeš uspjeti riješiti problem i nemoj se obeshrabriti misleći da je Windows bolji. Linux je jednostavno drukčiji i traži veći angažman korisnika. Sretno!

Hoce li odgovarati sad ovo posto sam instaliro 14.04 verziju?
Postovi: 12
Postovi: 12
Pridružen/a: 27 pro 2018, 21:34
Podijelio/la zahvalu: 0 puta
Primio/la zahvalu: 1 puta
Spol: M
OS: Ubuntu 18.04
Ako ti radi i ako si zadovoljan, onda ne diraj... ne mogu govoriti u tvoje ime.

Isprika, nisam shvatio: ti si instalirao novu verziju Ubuntua, 14.04 umjesto 18.04? Ako si instalirao Ubuntu 14.04, onda VRLO VJEROJATNO gornji driver neće raditi.
Avatar
Postovi: 879
Postovi: 879
Pridružen/a: 27 ruj 2012, 12:39
Podijelio/la zahvalu: 62 puta
Primio/la zahvalu: 99 puta
Spol: M
OS: Debian Mate

Na mreži
Trenutno korisnika/ca: / i 3 gostiju.