Sada je: 18 kol 2019, 20:14.
Diskusije usko vezane uz Fedora i srodne distribucije (RHEL, CentOS...)

Moderator/ica: Moderatori/ce

Ne mogu nikako instalirati Gimp na novoj Fedori. Mislio sam da će se stvari s vremenom srediti, i da će se dependency-ji posložiti, ali ipak ništa od toga.

Uglavnom, kad pokušam instalirati Gimp, niti 2.6.11 verzija iz službenog repozitorija, a niti 2.7.3 verzija s fedorapeople repozitorija ne prolazi instalalaciju. Greška je:

Kod: Označi sve
Error: Package: 2:gimp-2.7.3-1.fc16.i686 (fedora-gimp)
           Requires: libpoppler.so.14


Koliko sam skužio taj libpoppler.so se nalazi u poppler paketu, kojeg imam instaliranog:

Kod: Označi sve
[root@fedora ~]# yum info poppler
Loaded plugins: langpacks, presto, refresh-packagekit
Installed Packages
Name        : poppler
Arch        : i686
Version     : 0.18.0
Release     : 1.fc16
Size        : 1.8 M
Repo        : installed
From repo   : updates-testing
Summary     : PDF rendering library
URL         : http://poppler.freedesktop.org/
License     : GPLv2
Description : Poppler, a PDF rendering library, is a fork of the xpdf PDF
            : viewer developed by Derek Noonburg of Glyph and Cog, LLC.


pa sam mislio da će proći poppler sa Fedore 14, čija je verzija 0.14 jer sam mislio da ima nekakve veze s brojem 14 u libpoppler.so.14, ali niti instalacija tog paketa nije pomogla.

Ispitivao sam i ispitivao Google, ali mi ni on nije mogao dati odgovor.. Pa se nadam da će se javiti netko tko zna bolje od Google-a.. :D
Zadnja izmjena: Hugo; 11 lis 2011, 20:18; ukupno mijenjano 1 put/a.
One definition of the word mean is "small." Mean people live small, think small, and feel small—the smaller, the meaner.
Avatar
Postovi: 2478
Postovi: 2478
Pridružen/a: 28 vel 2010, 18:13
Lokacija: Đubrovnik
Podijelio/la zahvalu: 11 puta
Primio/la zahvalu: 7 puta
Spol: M
OS: Linux
Hugo je napisao/la:Ne mogu nikako instalirati Gimp na novoj Fedori. Mislio sam da će se stvari s vremenom srediti, i da će se dependency-ji posložiti, ali ipak ništa od toga.

Uglavnom, kad pokušam instalirati Gimp, niti 2.6.11 verzija iz službenog repozitorija, a niti 2.7.3 verzija s fedorapeople repozitorija ne prolazi instalalaciju. Greška je:

Kod: Označi sve
Error: Package: 2:gimp-2.7.3-1.fc16.i686 (fedora-gimp)
           Requires: libpoppler.so.14


Koliko sam skužio taj libpoppler.so se nalazi u poppler paketu, kojeg imam instaliranog:

Kod: Označi sve
[root@fedora ~]# yum info poppler
Loaded plugins: langpacks, presto, refresh-packagekit
Installed Packages
Name        : poppler
Arch        : i686
Version     : 0.18.0
Release     : 1.fc16
Size        : 1.8 M
Repo        : installed
From repo   : updates-testing
Summary     : PDF rendering library
URL         : http://poppler.freedesktop.org/
License     : GPLv2
Description : Poppler, a PDF rendering library, is a fork of the xpdf PDF
            : viewer developed by Derek Noonburg of Glyph and Cog, LLC.


pa sam mislio da će proći poppler sa Fedore 14, čija je verzija 0.14 jer sam mislio da ima nekakve veze s brojem 14 u libpoppler.so.14, ali niti instalacija tog paketa nije pomogla.

Ispitivao sam i ispitivao Google, ali mi ni on nije mogao dati odgovor.. Pa se nadam da će se javiti netko tko zna bolje od Google-a.. :D


Pozdrav,

Pokusaj napraviti symlink imena libpoppler.so.14 od libpoppler liba koji imas na stroju (izvorno ime liba (libpoppler.so vjerojatno))
Kod: Označi sve
ln -s /put/do/libpoppler.so /put/do/libpoppler.so.14


Ukoliko ovo gore ne udovolji dep potrebi, force-aj instalaciju
Kod: Označi sve
yum install package.rpm --nodeps -y

pa pokusaj pokrenuti GIMP.
When you're a kid and you wanna go "Weee !", but you ain't got drugs yet ... You hold out for your life, hold on to your little GONADS ... and STRIFE.
Avatar
Postovi: 910
Postovi: 910
Pridružen/a: 12 svi 2010, 07:57
Podijelio/la zahvalu: 0 puta
Primio/la zahvalu: 13 puta
OS: linux
Neće:

Kod: Označi sve
[root@fedora ~]# ln -s /usr/lib/libpoppler.so.18 /usr/lib/libpoppler.so.14
[root@fedora ~]#


Kod: Označi sve
[root@fedora ~]# locate libpoppler.so
/usr/lib/libpoppler.so
/usr/lib/libpoppler.so.18
/usr/lib/libpoppler.so.18.0.0
/usr/lib/libpoppler.so.7
/usr/lib/libpoppler.so.7.0.0


Kod: Označi sve
[root@fedora ~]# yum install gimp --nodeps -y
Loaded plugins: langpacks, presto, refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package gimp.i686 2:2.7.3-1.fc16 will be installed
--> Processing Dependency: gimp-libs(x86-32) = 2:2.7.3-1.fc16 for package: 2:gimp-2.7.3-1.fc16.i686
--> Processing Dependency: libpoppler.so.14 for package: 2:gimp-2.7.3-1.fc16.i686
--> Processing Dependency: libgimpwidgets-2.0.so.0 for package: 2:gimp-2.7.3-1.fc16.i686
--> Processing Dependency: libgimpui-2.0.so.0 for package: 2:gimp-2.7.3-1.fc16.i686
--> Processing Dependency: libgimpthumb-2.0.so.0 for package: 2:gimp-2.7.3-1.fc16.i686
--> Processing Dependency: libgimpmodule-2.0.so.0 for package: 2:gimp-2.7.3-1.fc16.i686
--> Processing Dependency: libgimpmath-2.0.so.0 for package: 2:gimp-2.7.3-1.fc16.i686
--> Processing Dependency: libgimpconfig-2.0.so.0 for package: 2:gimp-2.7.3-1.fc16.i686
--> Processing Dependency: libgimpcolor-2.0.so.0 for package: 2:gimp-2.7.3-1.fc16.i686
--> Processing Dependency: libgimpbase-2.0.so.0 for package: 2:gimp-2.7.3-1.fc16.i686
--> Processing Dependency: libgimp-2.0.so.0 for package: 2:gimp-2.7.3-1.fc16.i686
--> Processing Dependency: libgegl-0.1.so.0 for package: 2:gimp-2.7.3-1.fc16.i686
--> Processing Dependency: libbabl-0.1.so.0 for package: 2:gimp-2.7.3-1.fc16.i686
--> Running transaction check
---> Package babl.i686 0:0.1.4-1.fc16 will be installed
---> Package gegl.i686 0:0.1.6-2.fc16 will be installed
--> Processing Dependency: libumfpack.so.5 for package: gegl-0.1.6-2.fc16.i686
--> Processing Dependency: libspiro.so.0 for package: gegl-0.1.6-2.fc16.i686
--> Processing Dependency: libopenraw.so.1 for package: gegl-0.1.6-2.fc16.i686
---> Package gimp.i686 2:2.7.3-1.fc16 will be installed
--> Processing Dependency: libpoppler.so.14 for package: 2:gimp-2.7.3-1.fc16.i686
---> Package gimp-libs.i686 2:2.7.3-1.fc16 will be installed
--> Running transaction check
---> Package gimp.i686 2:2.7.3-1.fc16 will be installed
--> Processing Dependency: libpoppler.so.14 for package: 2:gimp-2.7.3-1.fc16.i686
---> Package libopenraw.i686 0:0.0.8-5.fc15 will be installed
---> Package libspiro.i686 0:20071029-5.fc15 will be installed
---> Package suitesparse.i686 0:3.6.1-1.fc16 will be installed
--> Finished Dependency Resolution
Error: Package: 2:gimp-2.7.3-1.fc16.i686 (fedora-gimp)
           Requires: libpoppler.so.14
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
One definition of the word mean is "small." Mean people live small, think small, and feel small—the smaller, the meaner.
Avatar
Postovi: 2478
Postovi: 2478
Pridružen/a: 28 vel 2010, 18:13
Lokacija: Đubrovnik
Podijelio/la zahvalu: 11 puta
Primio/la zahvalu: 7 puta
Spol: M
OS: Linux
Napravi ovo:
Kod: Označi sve
unlink /usr/lib/libpoppler.so.14
ln -s /usr/lib/libpoppler.so /usr/lib/libpoppler.so.14

Provjeri da li je symlink uistinu napravljen
Kod: Označi sve
test -h /usr/lib/libpoppler.so.14 && echo "Ima" || echo "Nema"


Izmjena druge komande:
Kod: Označi sve
yum install gimp --nodeps --skip-broken -y

Mozda mozes probati dodati i --force argument.

Ima jos jedan nacin kako instalirati manju verziju libpopplera (alternativno mozes skinuti src.rpm, izmjeniti spec datoteku i napraviti rpm paket):
Kod: Označi sve
yum downgrade libpoppler


EDIT:
Koristenje --nodeps --force nije bas preporucljivo (moze ti se gadno polomiti nekaj na sustavu).
When you're a kid and you wanna go "Weee !", but you ain't got drugs yet ... You hold out for your life, hold on to your little GONADS ... and STRIFE.
Avatar
Postovi: 910
Postovi: 910
Pridružen/a: 12 svi 2010, 07:57
Podijelio/la zahvalu: 0 puta
Primio/la zahvalu: 13 puta
OS: linux
*ebiga, neće:

Kod: Označi sve
[root@fedora ~]# ln -s /usr/lib/libpoppler.so /usr/lib/libpoppler.so.14
[root@fedora ~]# test -h /usr/lib/libpoppler.so.14 && echo "Ima" || echo "Nema"
Ima



Kod: Označi sve
[root@fedora ~]# yum install gimp --nodeps --skip-broken -y
Loaded plugins: langpacks, presto, refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package gimp.i686 2:2.7.3-1.fc16 will be installed
--> Processing Dependency: gimp-libs(x86-32) = 2:2.7.3-1.fc16 for package: 2:gimp-2.7.3-1.fc16.i686
--> Processing Dependency: libpoppler.so.14 for package: 2:gimp-2.7.3-1.fc16.i686
--> Processing Dependency: libgimpwidgets-2.0.so.0 for package: 2:gimp-2.7.3-1.fc16.i686
--> Processing Dependency: libgimpui-2.0.so.0 for package: 2:gimp-2.7.3-1.fc16.i686
--> Processing Dependency: libgimpthumb-2.0.so.0 for package: 2:gimp-2.7.3-1.fc16.i686
--> Processing Dependency: libgimpmodule-2.0.so.0 for package: 2:gimp-2.7.3-1.fc16.i686
--> Processing Dependency: libgimpmath-2.0.so.0 for package: 2:gimp-2.7.3-1.fc16.i686
--> Processing Dependency: libgimpconfig-2.0.so.0 for package: 2:gimp-2.7.3-1.fc16.i686
--> Processing Dependency: libgimpcolor-2.0.so.0 for package: 2:gimp-2.7.3-1.fc16.i686
--> Processing Dependency: libgimpbase-2.0.so.0 for package: 2:gimp-2.7.3-1.fc16.i686
--> Processing Dependency: libgimp-2.0.so.0 for package: 2:gimp-2.7.3-1.fc16.i686
--> Processing Dependency: libgegl-0.1.so.0 for package: 2:gimp-2.7.3-1.fc16.i686
--> Processing Dependency: libbabl-0.1.so.0 for package: 2:gimp-2.7.3-1.fc16.i686
--> Running transaction check
---> Package babl.i686 0:0.1.4-1.fc16 will be installed
---> Package gegl.i686 0:0.1.6-2.fc16 will be installed
--> Processing Dependency: libumfpack.so.5 for package: gegl-0.1.6-2.fc16.i686
--> Processing Dependency: libspiro.so.0 for package: gegl-0.1.6-2.fc16.i686
--> Processing Dependency: libopenraw.so.1 for package: gegl-0.1.6-2.fc16.i686
---> Package gimp.i686 2:2.7.3-1.fc16 will be installed
--> Processing Dependency: libpoppler.so.14 for package: 2:gimp-2.7.3-1.fc16.i686
---> Package gimp-libs.i686 2:2.7.3-1.fc16 will be installed
--> Running transaction check
---> Package gimp.i686 2:2.7.3-1.fc16 will be installed
--> Processing Dependency: libpoppler.so.14 for package: 2:gimp-2.7.3-1.fc16.i686
---> Package libopenraw.i686 0:0.0.8-5.fc15 will be installed
---> Package libspiro.i686 0:20071029-5.fc15 will be installed
---> Package suitesparse.i686 0:3.6.1-1.fc16 will be installed
fedora/filelists_db                                                                                                           |  19 MB     00:42     

Packages skipped because of dependency problems:
    babl-0.1.4-1.fc16.i686 from fedora
    gegl-0.1.6-2.fc16.i686 from fedora
    2:gimp-2.7.3-1.fc16.i686 from fedora-gimp
    2:gimp-libs-2.7.3-1.fc16.i686 from fedora-gimp
    libopenraw-0.0.8-5.fc15.i686 from fedora
    libspiro-20071029-5.fc15.i686 from fedora
    suitesparse-3.6.1-1.fc16.i686 from updates-testing



Kod: Označi sve
[root@fedora ~]# yum downgrade libpoppler
Loaded plugins: langpacks, presto, refresh-packagekit
Setting up Downgrade Process
No package libpoppler available.
Nothing to do


Kod: Označi sve
[root@fedora ~]# yum downgrade poppler
Loaded plugins: langpacks, presto, refresh-packagekit
Setting up Downgrade Process
Only Upgrade available on package: poppler-0.18.0-1.fc16.i686
Nothing to do


Što se tiče --force argumenta, yum ga ne prepoznaje..

Paket libpoppler ne postoji za Fedoru, tražio sam i na rpmfind, pkgs i drugim stranicama, i nema ga. Postoji samo za Ubuntu, Suse, Mandrivu, Debiana i dr. :

http://rpmfind.net/linux/rpm2html/searc ... =Search+...

http://pkgs.org/search/?keyword=libpopp ... it&exact=0
One definition of the word mean is "small." Mean people live small, think small, and feel small—the smaller, the meaner.
Avatar
Postovi: 2478
Postovi: 2478
Pridružen/a: 28 vel 2010, 18:13
Lokacija: Đubrovnik
Podijelio/la zahvalu: 11 puta
Primio/la zahvalu: 7 puta
Spol: M
OS: Linux
Postoji poppler paket.

Ajde pokusaj ovo:
Kod: Označi sve
rpm -Uvh http://repos.fedorapeople.org/repos/nphilipp/gimp-unstable/fedora-16/i386/gimp-2.7.3-1.fc16.i686.rpm


Javi output.
When you're a kid and you wanna go "Weee !", but you ain't got drugs yet ... You hold out for your life, hold on to your little GONADS ... and STRIFE.
Avatar
Postovi: 910
Postovi: 910
Pridružen/a: 12 svi 2010, 07:57
Podijelio/la zahvalu: 0 puta
Primio/la zahvalu: 13 puta
OS: linux
Evo:

Kod: Označi sve
[root@fedora ~]# rpm -Uvh http://repos.fedorapeople.org/repos/nphilipp/gimp-unstable/fedora-16/i386/gimp-2.7.3-1.fc16.i686.rpm
Retrieving http://repos.fedorapeople.org/repos/nphilipp/gimp-unstable/fedora-16/i386/gimp-2.7.3-1.fc16.i686.rpm
warning: /var/tmp/rpm-tmp.Vo4QXS: Header V4 DSA/SHA1 Signature, key ID 69513011: NOKEY
error: Failed dependencies:
   gimp-libs(x86-32) = 2:2.7.3-1.fc16 is needed by gimp-2:2.7.3-1.fc16.i686
   libbabl-0.1.so.0 is needed by gimp-2:2.7.3-1.fc16.i686
   libgegl-0.1.so.0 is needed by gimp-2:2.7.3-1.fc16.i686
   libgimp-2.0.so.0 is needed by gimp-2:2.7.3-1.fc16.i686
   libgimpbase-2.0.so.0 is needed by gimp-2:2.7.3-1.fc16.i686
   libgimpcolor-2.0.so.0 is needed by gimp-2:2.7.3-1.fc16.i686
   libgimpconfig-2.0.so.0 is needed by gimp-2:2.7.3-1.fc16.i686
   libgimpmath-2.0.so.0 is needed by gimp-2:2.7.3-1.fc16.i686
   libgimpmodule-2.0.so.0 is needed by gimp-2:2.7.3-1.fc16.i686
   libgimpthumb-2.0.so.0 is needed by gimp-2:2.7.3-1.fc16.i686
   libgimpui-2.0.so.0 is needed by gimp-2:2.7.3-1.fc16.i686
   libgimpwidgets-2.0.so.0 is needed by gimp-2:2.7.3-1.fc16.i686


Što se tiče poppler paketa, napisao sam gore da sam ga bio downgrade-ao na 0.14 verziju iz Fedore 14, ali nije pomoglo.
One definition of the word mean is "small." Mean people live small, think small, and feel small—the smaller, the meaner.
Avatar
Postovi: 2478
Postovi: 2478
Pridružen/a: 28 vel 2010, 18:13
Lokacija: Đubrovnik
Podijelio/la zahvalu: 11 puta
Primio/la zahvalu: 7 puta
Spol: M
OS: Linux
Kod: Označi sve
rpm -Uvh --nogpgcheck http://repos.fedorapeople.org/repos/nphilipp/gimp-unstable/fedora-16/i386/gimp-libs-2.7.3-1.fc16.i686.rpm
rpm -Uvh --nogpgcheck http://repos.fedorapeople.org/repos/nphilipp/gimp-unstable/fedora-16/i386/gimp-2.7.3-1.fc16.i686.rpm
When you're a kid and you wanna go "Weee !", but you ain't got drugs yet ... You hold out for your life, hold on to your little GONADS ... and STRIFE.
Avatar
Postovi: 910
Postovi: 910
Pridružen/a: 12 svi 2010, 07:57
Podijelio/la zahvalu: 0 puta
Primio/la zahvalu: 13 puta
OS: linux
Kod: Označi sve
[root@fedora ~]# rpm -Uvh --nosignature http://repos.fedorapeople.org/repos/nphilipp/gimp-unstable/fedora-16/i386/gimp-libs-2.7.3-1.fc16.i686.rpm
Retrieving http://repos.fedorapeople.org/repos/nphilipp/gimp-unstable/fedora-16/i386/gimp-libs-2.7.3-1.fc16.i686.rpm
Preparing...                ########################################### [100%]
   1:gimp-libs              ########################################### [100%]

[root@fedora ~]# rpm -Uvh --nosignature http://repos.fedorapeople.org/repos/nphilipp/gimp-unstable/fedora-16/i386/gimp-2.7.3-1.fc16.i686.rpm
Retrieving http://repos.fedorapeople.org/repos/nphilipp/gimp-unstable/fedora-16/i386/gimp-2.7.3-1.fc16.i686.rpm
error: Failed dependencies:
   libbabl-0.1.so.0 is needed by gimp-2:2.7.3-1.fc16.i686
   libgegl-0.1.so.0 is needed by gimp-2:2.7.3-1.fc16.i686
One definition of the word mean is "small." Mean people live small, think small, and feel small—the smaller, the meaner.
Avatar
Postovi: 2478
Postovi: 2478
Pridružen/a: 28 vel 2010, 18:13
Lokacija: Đubrovnik
Podijelio/la zahvalu: 11 puta
Primio/la zahvalu: 7 puta
Spol: M
OS: Linux
Kod: Označi sve
yum install babl gegl

Pa ponovi instalaciju samo gimp paketa (gimp-libs se instalirao).
When you're a kid and you wanna go "Weee !", but you ain't got drugs yet ... You hold out for your life, hold on to your little GONADS ... and STRIFE.
Avatar
Postovi: 910
Postovi: 910
Pridružen/a: 12 svi 2010, 07:57
Podijelio/la zahvalu: 0 puta
Primio/la zahvalu: 13 puta
OS: linux

Na mreži
Trenutno korisnika/ca: / i 1 gost.