Sada je: 16 srp 2019, 01:41.
Diskusije usko vezane uz Fedora i srodne distribucije (RHEL, CentOS...)

Moderator/ica: Moderatori/ce

Pozdrav svima. Nisam tako iskusan linuxaš , pa nemojte zamjerit ako je što loše objašnjeno.

Ovako, na internet se moram spajati preko mobilnog interneta (Huawei E173 ). Na svježoj instalaciji fedore 17 on je radio bez problema, na samom početku sam ga konfigurirao (prvider, apn...), i spajao sam se na internet bez problema. Nakon update-a sustava (sa 3.6.11-5 na 3.7.3-101) sa njim se više ne mogu spojiti. Fedora ga prepozna kao internet modem, ali nikako ostvariti vezu. Prilikom pokušaja spajanja pojavi se poruka “Connection failed Activation of network connection failed”.
Pokušao sam ga konfigurirati ponovo ali se greška ponavlja. “Guglao” sam problem, većinom se oni odnose na prepoznavanje sticka kao vanjske memorije, pa se to rješava sa modeswitch-om ali mislim da to nije slučaj kod mene jer je sve radilo bez problema na svježoj instalaciji fedore(prije update-a). Stari stick radi bez problema, ali ne "hvata" HSPA signal, pa je internet veoma spor.
Zadnja izmjena: Matha; 21 vel 2013, 13:01; ukupno mijenjano 1 put/a.
Postovi: 19
Postovi: 19
Pridružen/a: 14 stu 2012, 23:10
Podijelio/la zahvalu: 2 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Fedora 17, Windows 7
probaj izvaditi stick, obriši konekciju, napravi novu, uštekaj stick nazad, čekaj da se automatski spoji, ako neće klikni connect i više ništa ne diraj, frend ima isti stick, samo na LMDE-u problem, isti problem i riješen je tako, ako slučajno klikneš na konekciju dok je spojen moraš sve ispočetka (to je privremeno rješenje dok netko ne skonta kako rješiti bez svega toga)
I don't want to be a human. I want to see gamma rays, I want to hear x-rays and I want to smell dark matter. I want to reach out with something other than this prehensile paws and feel the solar wind of a super nova flowing over me.
Avatar
Postovi: 1975
Postovi: 1975
Pridružen/a: 19 srp 2011, 22:39
Lokacija: wonderland
Podijelio/la zahvalu: 8 puta
Primio/la zahvalu: 38 puta
Spol: M
OS: Debian 7 Wheezy
Na zalost ne radi. :x Zbrisao sam konekciju, izvukao stick, i napravio profil na dok je stick bio vani, stavio sam da se automatski spaja. i kad sam stavio stick ponovno poruka “Connection failed...". Postoji li još možda koji workaround?
Postovi: 19
Postovi: 19
Pridružen/a: 14 stu 2012, 23:10
Podijelio/la zahvalu: 2 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Fedora 17, Windows 7
Matha je napisao/la:Na zalost ne radi. :x Zbrisao sam konekciju, izvukao stick, i napravio profil na dok je stick bio vani, stavio sam da se automatski spaja. i kad sam stavio stick ponovno poruka “Connection failed...". Postoji li još možda koji workaround?


Vraćanje na stari kernel? Ako ti je radilo na starom, vrati se na stari i zaključak update kernela dok se situacija na popravi... Ako je to do kernela. Mislim da je to prije do neke promjene u NetworkManageru.

Možda ti /var/log/messages otkrije gdje je greška jer tamo NM ispisuje svoj log...
A neutron walks into a bar; he asks the bartender, 'How much for a beer?' The bartender looks at him, and says 'For you, no charge.'
Avatar
Moderator
Postovi: 4059
Moderator
Postovi: 4059
Pridružen/a: 15 svi 2008, 18:05
Lokacija: Hamburg, DE
Podijelio/la zahvalu: 111 puta
Primio/la zahvalu: 183 puta
Spol: M
OS: Fedora/KDE
Probao sam u grub-u otic na stari kernel, sada ni na starom ne radi. Otvorio sam /var/log/messages, ali ne mogu/ ne znam iščitati di je greška. Pokušati ću si nabaviti drugi modem, ovaj vjerojatno nije na zelenoj grani sa linuxom.
Probao sam prema ovim uputama instalirati program, koji bi ga trebao pokretati, ali isto nikako ostvariti vezu.
Vidio sam da su neko to rješavali uz pomoć wvdial-a ali ne znam to namjestiti. :oops
Postovi: 19
Postovi: 19
Pridružen/a: 14 stu 2012, 23:10
Podijelio/la zahvalu: 2 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Fedora 17, Windows 7
Matha je napisao/la:Probao sam u grub-u otic na stari kernel, sada ni na starom ne radi. Otvorio sam /var/log/messages, ali ne mogu/ ne znam iščitati di je greška. Pokušati ću si nabaviti drugi modem, ovaj vjerojatno nije na zelenoj grani sa linuxom.
Probao sam prema ovim uputama instalirati program, koji bi ga trebao pokretati, ali isto nikako ostvariti vezu.
Vidio sam da su neko to rješavali uz pomoć wvdial-a ali ne znam to namjestiti. :oops


Možda nije problem u novom kernelu (to nema ni onako smisla), već u novijoj verziji NetworkManagera? Da njega downgradeaš?

Log NM-a možeš dobiti i s ovom naredbom:
Kod: Označi sve
grep NetworkManager /var/log/messages
A neutron walks into a bar; he asks the bartender, 'How much for a beer?' The bartender looks at him, and says 'For you, no charge.'
Avatar
Moderator
Postovi: 4059
Moderator
Postovi: 4059
Pridružen/a: 15 svi 2008, 18:05
Lokacija: Hamburg, DE
Podijelio/la zahvalu: 111 puta
Primio/la zahvalu: 183 puta
Spol: M
OS: Fedora/KDE
Znači probao sam downgrade-ati
Kod: Označi sve
yum downgrade NetworkManager NetworkManager-gnome NetworkManager-glib

Na kraju izvršavanja dobio sam jedan poruku:
Error: Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a problem. Eg.:

1. You have an upgrade for NetworkManager-gtk which is missing some
dependency that another package requires. Yum is trying to
solve this by installing an older version of NetworkManager-gtk of the
different architecture. If you exclude the bad architecture
yum will tell you what the root cause is (which package
requires what). You can try redoing the upgrade with
--exclude NetworkManager-gtk.otherarch ... this should give you an error
message showing the root cause of the problem.

2. You have multiple architectures of NetworkManager-gtk installed, but
yum can only see an upgrade for one of those arcitectures.
If you don't want/need both architectures anymore then you
can remove the one with the missing update and everything
will work.

3. You have duplicate versions of NetworkManager-gtk installed already.
You can use "yum check" to get yum show these errors.

...you can also use --setopt=protected_multilib=false to remove
this checking, however this is almost never the correct thing to
do as something else is very likely to go wrong (often causing
much more problems).

Protected multilib versions: 1:NetworkManager-gtk-0.9.4.0-7.git20120403.fc17.i686 != 1:NetworkManager-gtk-0.9.6.4-3.fc17.x86_64
Error: Protected multilib versions: 1:NetworkManager-glib-0.9.6.4-3.fc17.i686 != 1:NetworkManager-glib-0.9.4.0-7.git20120403.fc17.x86_64


Poslije toga pokusao sam se spojiti, ali problem se ponavlja, tj ne uspostavi se veza.

Pogledao sam /var/log/messages on kaze ovako:

Feb 18 09:38:47 localhost NetworkManager[766]: <info> Activation (ttyUSB2) starting connection 'T-Mobile Default 1'
Feb 18 09:38:47 localhost NetworkManager[766]: <info> (ttyUSB2): device state change: disconnected -> prepare (reason 'none') [30 40 0]
Feb 18 09:38:47 localhost NetworkManager[766]: <info> Activation (ttyUSB2) Stage 1 of 5 (Device Prepare) scheduled...
Feb 18 09:38:47 localhost NetworkManager[766]: <info> Activation (ttyUSB2) Stage 1 of 5 (Device Prepare) started...
Feb 18 09:38:47 localhost NetworkManager[766]: <info> Activation (ttyUSB2) Stage 1 of 5 (Device Prepare) complete.
Feb 18 09:38:53 localhost NetworkManager[766]: <warn> GSM connection failed: (32) Sending command failed: 'Resource temporarily unavailable'
Feb 18 09:38:53 localhost NetworkManager[766]: <info> (ttyUSB2): device state change: prepare -> failed (reason 'unknown') [40 120 1]
Feb 18 09:38:53 localhost NetworkManager[766]: <info> Marking connection 'T-Mobile Default 1' invalid.
Feb 18 09:38:53 localhost NetworkManager[766]: <warn> Activation (ttyUSB2) failed for connection 'T-Mobile Default 1'
Feb 18 09:38:53 localhost NetworkManager[766]: <info> (ttyUSB2): device state change: failed -> disconnected (reason 'none') [120 30 0]
Feb 18 09:38:53 localhost NetworkManager[766]: <info> (ttyUSB2): deactivating device (reason 'none') [0]
Feb 18 09:38:59 localhost NetworkManager[766]: <info> WWAN now disabled by management service
Feb 18 09:39:16 localhost NetworkManager[766]: <warn> failed to enable/disable modem: (32) Sending command failed: 'Resource temporarily unavailable'


Na netu sam nasao kao su se neki uspjeli spojiti sa wvdial-om ali kad otvorim /etc/wvdial.conf on je potpuno prazan.

Oprostite na malo podužem postu.
Postovi: 19
Postovi: 19
Pridružen/a: 14 stu 2012, 23:10
Podijelio/la zahvalu: 2 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Fedora 17, Windows 7
Ajd ako možeš probati na Live Fedori radi li ti stick kroz NM. Time bi eliminirali definitivno krivnju sticka i znali bi da se radi o nadogradnji NM-a ili sličnog podsustava.

Nakon toga bi ostale sljedeće solucije:
a) vraćanje na staru verziju NM-a (ručno čak ako ne ide yumom)
b) odbacivanje NM-a i konfiguriranje wvdial-a
c) pretraživanje bugzilla za već prijavljenim bugom ili prijavljivanje novog buga kako bi se riješio taj problem
A neutron walks into a bar; he asks the bartender, 'How much for a beer?' The bartender looks at him, and says 'For you, no charge.'
Avatar
Moderator
Postovi: 4059
Moderator
Postovi: 4059
Pridružen/a: 15 svi 2008, 18:05
Lokacija: Hamburg, DE
Podijelio/la zahvalu: 111 puta
Primio/la zahvalu: 183 puta
Spol: M
OS: Fedora/KDE
Na live fedori stick radi bey problema (ovaj tekst pisem spojen preko njega sa live fedore). Dali znas mozda kako bi rucno downgradeao network manager? I da dali sam moram pisati sav tekst u /etc/wvdial.conf ili bi tamo vec trebala postojati neka konfiguracija?
Postovi: 19
Postovi: 19
Pridružen/a: 14 stu 2012, 23:10
Podijelio/la zahvalu: 2 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Fedora 17, Windows 7
Matha je napisao/la:Na live fedori stick radi bey problema (ovaj tekst pisem spojen preko njega sa live fedore). Dali znas mozda kako bi rucno downgradeao network manager? I da dali sam moram pisati sav tekst u /etc/wvdial.conf ili bi tamo vec trebala postojati neka konfiguracija?


I meni je wvdial.conf prazan, a možeš ga popuniti nakon što uštekaš stick i pokreneš:
Kod: Označi sve
wvdialconf /etc/wvdial.conf

I onda ćeš još ručno morati staviti podatke za spajanje i sl.

Za više informacija pogledaj Archev wiki o wvdialu jer osobno nemam iskustva s njime. NM mi je uvijek radio.

Malo sam proguglao - puno ljudi ima problema s novijom verzijom NM-a pa bi bilo zbilja dobro da jednostavno instaliraš originalni NM i u yum.conf dodaš liniju da ne nadograđuje NM s novijim verzijama, pa dok se tvoj problem ne popravi. Ručno možeš vratiti na originalni ovako nekako:
1. poskidaj prvo NM pakete za Fedoru 17 odavde (ako imaš 64-bitnu verziju)
2. ukloni aktualni NM:
Kod: Označi sve
yum remove NetworkManager

3. instaliraj skinute RPM pakete iz foldera gdje si ih skinuo:
Kod: Označi sve
yum localinstall NetworkManager*rpm

(samo pazi na redosljed, prvo samo NM, a onda ove dodatne pakete)
4. makni NM iz updatea tako da u /etc/yum.conf dodaš liniju:
Kod: Označi sve
exclude=NetworkManager*
A neutron walks into a bar; he asks the bartender, 'How much for a beer?' The bartender looks at him, and says 'For you, no charge.'
Avatar
Moderator
Postovi: 4059
Moderator
Postovi: 4059
Pridružen/a: 15 svi 2008, 18:05
Lokacija: Hamburg, DE
Podijelio/la zahvalu: 111 puta
Primio/la zahvalu: 183 puta
Spol: M
OS: Fedora/KDE

Na mreži
Trenutno korisnika/ca: / i 1 gost.