Sada je: 19 kol 2019, 23:25.
Diskusije o hardveru i driverima pod Linuxom.

Moderator/ica: Moderatori/ce

Nedavno sam na drugo računalo instalirao novu ISO sliku LMDE. Ne mogu pokrenuti stari printer HP DeskJet 1125c koji je povezan s računalom paralelnim portom. U početku ga LMDE uopće nije prepoznavao, pa sam utipkao u terminal

sudo apt-get purge cups && sudo apt-get autoremove
sudo apt-get update && sudo apt-get install cup

sudo dpkg-reconfigure cups

Sada LMDE vidi printer, ali još uvijek ne mogu printati. Kad sam pokušao s probnom stranicom, primio sam poruku

Option 'printer-resolution' has value '(unknown IPP tag)' and cannot be edited

odnosno

Idle - no profiles specified in PPD

Imate li neku ideju kako dalje szbunjen ?
Zadnja izmjena: rudar; 19 srp 2013, 10:41; ukupno mijenjano 1 put/a.
Avatar
Postovi: 873
Postovi: 873
Pridružen/a: 27 ruj 2012, 12:39
Podijelio/la zahvalu: 62 puta
Primio/la zahvalu: 99 puta
Spol: M
OS: Debian Mate
U Synapticu instaliraj hplip, hplip-gui i hp-ppd (možda je poblm baš u ovom zdnjem). Dobit ćeš grafičko sučelje za kompletno upravljanje HP printerima
Abzeenth je napisao/la:Dobro onda. Baš me briga. Krepajte od offtopica.

jurastublic je napisao/la:Ovaj thread me podsjeća na krepanu mačku. Treba to pokupit lopatom i zakopat. Onda dezinficirati lopatu. :-D
Avatar
Moderator
Postovi: 5818
Moderator
Postovi: 5818
Pridružen/a: 25 ožu 2012, 14:29
Lokacija: ~/kauč
Podijelio/la zahvalu: 155 puta
Primio/la zahvalu: 250 puta
Spol: M
OS: Mint 17.3 Cimet
Napravio sam i to, Calisto, ali nije bilo rezultata. Ista stvar, ista greška, ne može printati. Negdje je zapelo s driverima, jer dok nisam našao na stranicama Minta onaj trik sa zamjenom cupsa i unio u terminal, uopće mi nije 'vidio' printer. Nema rješenja i dalje.
Usput, pokušao sam s Live Debianom 6.0.3. i nisam imao problema s printerom. Stari kernel (2.6.32) za stari printer vrijedi! Međutim, LMDE (kernel 3.2.0-4) ovdje malo zapinje i nadam se rješenju.
Kad u LO Writer pokušam printati tekst, on mi javlja samo: Generic printer. Naravno da printanje onda ne reagira. Nažalost, sudeći po stranicama Minta, nešto je zapelo općenito s drajverima za printere ovaj put, ima više nezadovoljnih. szbunjen
Avatar
Postovi: 873
Postovi: 873
Pridružen/a: 27 ruj 2012, 12:39
Podijelio/la zahvalu: 62 puta
Primio/la zahvalu: 99 puta
Spol: M
OS: Debian Mate
Čini se da problem nije u Mintu, već u Debianu. Našao sam bug report iz siječnja protekle godine (Klik) gdje kažu kako je bug popravljen u verziji x.x.62 python-cupsa. Probaj skinuti tu verziju i instaliraj ju.

P.S.: Prvo ukloni python-cups paket koji trenutno imaš instaliran (verziju iz debian repozitorija) ;)
Emotion 98.3 je napisao/la:Some people call the radio station and say "Fernando, are you bilingual?" I said I try anything once.
Avatar
Postovi: 310
Postovi: 310
Pridružen/a: 12 lip 2011, 21:52
Lokacija: Slavonski Brod
Podijelio/la zahvalu: 16 puta
Primio/la zahvalu: 16 puta
Spol: M
OS: Debian Xfce
Hvala, dinosb! Ovo ću svakako probati, ali prije nego što počnem, zamolio bih još jedan detalj: link na koji me upućuješ odnosi se na 32-bitnu verziju (I386), a kod mene je 64-bitna (amd64). Gdje mogu naći verziju koja mi odgovara?
Avatar
Postovi: 873
Postovi: 873
Pridružen/a: 27 ruj 2012, 12:39
Podijelio/la zahvalu: 62 puta
Primio/la zahvalu: 99 puta
Spol: M
OS: Debian Mate
rudar je napisao/la:Hvala, dinosb! Ovo ću svakako probati, ali prije nego što počnem, zamolio bih još jedan detalj: link na koji me upućuješ odnosi se na 32-bitnu verziju (I386), a kod mene je 64-bitna (amd64). Gdje mogu naći verziju koja mi odgovara?


Aha, pardon. Mislio sam da koristiš 32-bit ver. Evo 64-bitni paket, a sve verije možeš naći ovdje. Sretno ;)
Emotion 98.3 je napisao/la:Some people call the radio station and say "Fernando, are you bilingual?" I said I try anything once.
Avatar
Postovi: 310
Postovi: 310
Pridružen/a: 12 lip 2011, 21:52
Lokacija: Slavonski Brod
Podijelio/la zahvalu: 16 puta
Primio/la zahvalu: 16 puta
Spol: M
OS: Debian Xfce
Skinuo sam sadržaj s linka i kad sam pokušao instalaciju s GDebian package installer zatekla me poruka:
Error: Dependency is not satisfiable: libc6 (>= 2.14)

Pa...? szbunjen
Avatar
Postovi: 873
Postovi: 873
Pridružen/a: 27 ruj 2012, 12:39
Podijelio/la zahvalu: 62 puta
Primio/la zahvalu: 99 puta
Spol: M
OS: Debian Mate
rudar je napisao/la:Skinuo sam sadržaj s linka i kad sam pokušao instalaciju s GDebian package installer zatekla me poruka:
Error: Dependency is not satisfiable: libc6 (>= 2.14)

Pa...? szbunjen


Hmm... ne znam kako to funkcionira, ali ti imaš lmde koji kao bazu koristi debian, a ovaj paket koji pokušavaš instalirati je za ubuntu (znači "obični Mint"). Ali neki paketi se i mogu instalirati s jednog na drugi, ali ne svi. Jer Debian i Ubuntu se baš ne vole. Ako hoćeš probaj instalirati paket po paket.Evo ti link na libc6 >=2.14 odn. 2.15
http://pkgs.org/ubuntu-12.10/ubuntu-mai ... 6.deb.html
Pa probaj jedno po jedno. I svaki put ako te traži neki paket upiši u Search polje i potraži po distribucijama. Ma snaći ćeš se! :) :) Pardon, ti trebaš 64 bitni
http://pkgs.org/ubuntu-12.10/ubuntu-mai ... 4.deb.html
Ako želiš pobijediti, ne smiješ izgubiti.....
Avatar
Postovi: 90
Postovi: 90
Pridružen/a: 18 lip 2008, 16:59
Lokacija: Jaska okolica
Podijelio/la zahvalu: 1 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Linux Mint 18.2 KDE
Kad sam bez problema printao probnu stranicu s Debian Live 6.0.3, dobio sam poruku:

This test page was produced by CUPS 1.4.4.

To znači da mi treba stariji, a ne noviji CUPS. To treba skinuti. Osim toga, Debian ima Driver Version 5.2.6. (CUPS+Gutenprit v.5.2.6).
Avatar
Postovi: 873
Postovi: 873
Pridružen/a: 27 ruj 2012, 12:39
Podijelio/la zahvalu: 62 puta
Primio/la zahvalu: 99 puta
Spol: M
OS: Debian Mate
Kroz Google sam skinuo iz Debianovih repozitorija potrebni python-cups 1.9.62-1_amd64.deb i instalirao ga umjesto zadanog po defaultu, ali i dalje nema rezultata. Sad mi prijavljuje da je izvršio zadatak, a da se ništa nije dogodilo. Ni promjena PPD kroz Synaptic nije donijela ništa. Problem traje.
Avatar
Postovi: 873
Postovi: 873
Pridružen/a: 27 ruj 2012, 12:39
Podijelio/la zahvalu: 62 puta
Primio/la zahvalu: 99 puta
Spol: M
OS: Debian Mate

Na mreži
Trenutno korisnika/ca: / i 2 gostiju.