Sada je: 21 stu 2019, 18:20.
Diskusije o hardveru i driverima pod Linuxom.

Moderator/ica: Moderatori/ce

Kao što naslov kaže, imam problema sa ATI Radeon 5670 grafičkom karticom i molim vas za pomoć.
Nadogradio sam na Ubuntu 3.4.6 Linux kernel, i sada se čini da mi OpenGL podrška uopšte neradi jer ne mogu da pokrenem nijednu aplikaciju koja zahtijeva OpenGL, a i sa kernelom 3.2.0 sam imao problema sa time, ali u malo manjoj mjeri (OpenGL je djelomično radio i mogao sam koristiti mnogo aplikacija koje ga koriste, iako neke nisu radile).

EDIT: Čini se da problem sa Alien Arenom nije do grafičke kartice.

Instalirao sam najnovije ATI drajvere na slijedeći način:

- Moramo prvo ukloniti stare drajvere, tako da kucam u terminalu:

sudo sh /usr/share/ati/fglrx-uninstall.sh
I dobijam "odgovor":
sh: 0: Can't open /usr/share/ati/fglrx-uninstall.sh
Iz nepoznatog razloga. To ipak ignoriram.
Zatim kucam sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*
Naredba uspijeva da se izvrši, iako se prethodna nije mogla izvršiti szbunjen

- Moramo instalirati pakete koji su potrebni da bismo sagradili .deb pakete:

sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 dkms libqtgui4 wget execstack libelfg0 dh-modaliases
sudo apt-get install ia32-libs
Pošto koristim 64-bitnu verziju Ubuntua, instalirao sam i:
sudo apt-get install ia32-libs-multiarch
sudo apt-get install i386 lib32gcc1
sudo apt-get install libc6-i386

-Skinuo sam najnoviji 64-bitni ATI drajver sa ATI web sajta i ime fajla je:

amd-driver-installer-12-6-x86.x86_64.run

-Započinjem gradnju .deb paketa komandom:

sudo sh amd-driver-installer-12-6-x86.x86_64.run --buildpkg Ubuntu/precise
Gradnja .deb paketa se okončala uspješno.
Kreirana su 3 .deb paketa pod imenima:

fglrx-dev_8.980-0ubuntu1_amd64.deb
fglrx_8.980-0ubuntu1_amd64.deb
fglrx-amdcccle_8.980-0ubuntu1_amd64.deb

I fajl:

fglrx-installer_8.980-0ubuntu1_amd64.changes

-Koristim komandu:

sudo dpkg -i fglrx*.deb

Da bih instalirao ta 3 .deb paketa.
Instalacija se uspješno okončala.

- Kucam:

sudo aticonfig --initial

Naredba uspijeva da se izvrši.

- Nakon toga restartujem računar

- Kucam:

fglrxinfo

Da bih potvrdio da drajver radi.
I dobijam "odgovor":

X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 139 (ATIFGLEXTENSION)
Minor opcode of failed request: 66 ()
Serial number of failed request: 13
Current serial number in output stream: 13

szbunjen
Što je veoma neočekivano.

- Kucam:

sudo amdcccle

Da bih se uvjerio da Catalyst Control Center radi.
CCC se starta nakon oko 5-10 sekundi.
Na prvi pogled sve izgleda da je uredu i CCC detektuje grafičku karticu.
Idem na Display Manager
Rezolution: Preffered 4000x4000 szbunjen :lol:
Refresh rate: Preffered (160Hz) szbunjen
CCC ne mogu naći ni pod ijednom kategorijom na menu-u

Stvarno mi je potrebna pomoć jer ne znam šta više da probam da učinim.
Zadnja izmjena: qwxy; 21 kol 2012, 21:24; ukupno mijenjano 2 put/a.
Postovi: 121
Postovi: 121
Pridružen/a: 21 srp 2012, 00:36
Podijelio/la zahvalu: 6 puta
Primio/la zahvalu: 1 puta
Spol: M
OS: Arch Compiz|LXQt Debian
Zašto jednostavno nisi skinuo i instalirao drajvere putem programa "Additional Drivers"? Ja imam Radeonku 6650M i radi ko urica! Pokreneš program, on očita što ti fali i s jednim klikom to skineš i aktiviraš. Ne može jednostavnije - ne trebaju ti nikakvi dodatni paketi, ni pachanje kernela (pačanje u kernel)....
Pokušaj najprije na taj način. Ako bude problema, u Synapticu deinstaliraj to što si instalirao, pa probaj opet
Abzeenth je napisao/la:Dobro onda. Baš me briga. Krepajte od offtopica.

jurastublic je napisao/la:Ovaj thread me podsjeća na krepanu mačku. Treba to pokupit lopatom i zakopat. Onda dezinficirati lopatu. :-D
Avatar
Moderator
Postovi: 5818
Moderator
Postovi: 5818
Pridružen/a: 25 ožu 2012, 14:29
Lokacija: ~/kauč
Podijelio/la zahvalu: 155 puta
Primio/la zahvalu: 250 puta
Spol: M
OS: Mint 17.3 Cimet
calisto053 je napisao/la:Zašto jednostavno nisi skinuo i instalirao drajvere putem programa "Additional Drivers"?


Inače, trudim se da pokušam sve što mogu sam uraditi prije nego što napravim post na forumu. Zaboravio sam spomenuti da sam to pokušao.

Vidim 2 drajvera vezana za grafičku karticu:

ATI/AMD vlasnički FGLRX grafički drajver i
ATI/AMD vlasnički FGLRX grafički drajver (nadogradnje nakon izdanja)

Pokušao sam ta dva. Prvi radi djelomično, dok drugi (nadogradnje nakon izdanja) ne radi uopšte, barem pod 3.2.0 kernelom. Pod novim kernelom, doduše, nisam ni pokušao jer je drajver sagrađen na spomenuti način ustvari radio djelomično kao i vlasnički drajver pod 3.2.0 kernelom. Mislio sam da će, možda, nadogradnja na Ubuntu 3.4.6 kernel riješiti problem, ali nije. Uvijek mogu vratiti na stari 3.2.0 kernel ako je potrebno.
Postovi: 121
Postovi: 121
Pridružen/a: 21 srp 2012, 00:36
Podijelio/la zahvalu: 6 puta
Primio/la zahvalu: 1 puta
Spol: M
OS: Arch Compiz|LXQt Debian
calisto053 je napisao/la:ne trebaju ti nikakvi dodatni paketi, ni pachanje kernela (pačanje u kernel)....


Kernel sam instalirao putem .deb paketa sa web adrese:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4.6-quantal/

Skinuo sam 4 paketa i instalirao ih:

linux-image-extra-3.4.6-030406-generic_3.4.6-030406.201207191609_amd64.deb
linux-headers-3.4.6-030406-generic_3.4.6-030406.201207191609_amd64.deb
linux-image-3.4.6-030406-generic_3.4.6-030406.201207191609_amd64.deb
linux-headers-3.4.6-030406_3.4.6-030406.201207191609_all.deb

Zatim sam uninstalirao sve stare 3.2.0 kernele putem Synaptic-a. To također uklanja i sve stare 3.2.0 kernel module.
Postovi: 121
Postovi: 121
Pridružen/a: 21 srp 2012, 00:36
Podijelio/la zahvalu: 6 puta
Primio/la zahvalu: 1 puta
Spol: M
OS: Arch Compiz|LXQt Debian
https://bbs.archlinux.org/viewtopic.php ... 7#p1124147

12.6:
- supports Radeons HD >= 5xxx ONLY (hd 2 3 4k users please use catalyst-total-hd234k @AUR or [catalyst-hd234k] repo)
- supports 3.4 kernel (through patches);
- supports xorg-server 1.12
Listen, I gotta fight the lion. That's what that guy Scott's all about. I know. I've studied him already.
Avatar
Moderator
Postovi: 1779
Moderator
Postovi: 1779
Pridružen/a: 10 ruj 2010, 11:20
Podijelio/la zahvalu: 9 puta
Primio/la zahvalu: 92 puta
Spol: M
OS: openSUSE Factory KDE
sumski je napisao/la:https://bbs.archlinux.org/viewtopic.php?pid=1124147#p1124147

12.6:
- supports Radeons HD >= 5xxx ONLY (hd 2 3 4k users please use catalyst-total-hd234k @AUR or [catalyst-hd234k] repo)
- supports 3.4 kernel (through patches);
- supports xorg-server 1.12


:facepalm Hvala vam. Nisam za to znao. Sumnjao sam da bi to mogao biti uzrok, ali nisam bio siguran.
Postovi: 121
Postovi: 121
Pridružen/a: 21 srp 2012, 00:36
Podijelio/la zahvalu: 6 puta
Primio/la zahvalu: 1 puta
Spol: M
OS: Arch Compiz|LXQt Debian
Patch se, čini se, uspiješno izvršio, ali dobijam grešku kada pokušam da sagradim .deb pakete.

Kucam:

sudo ./ati-installer.sh 8.980 --buildpkg Ubuntu/quantal

Dobijam "odgovor":

Generating package: Ubuntu/quantal
Error: Distro Version entered incorrectly or not supported, use --listpkg to identify valid distro versions
Error: Distro Version entered incorrectly or not supported, use --listpkg to identify valid distro versions

EDIT: I ja ne čitam :D
Postovi: 121
Postovi: 121
Pridružen/a: 21 srp 2012, 00:36
Podijelio/la zahvalu: 6 puta
Primio/la zahvalu: 1 puta
Spol: M
OS: Arch Compiz|LXQt Debian
Hvala vam svima. OpenGL sada radi kao i prije.
Postovi: 121
Postovi: 121
Pridružen/a: 21 srp 2012, 00:36
Podijelio/la zahvalu: 6 puta
Primio/la zahvalu: 1 puta
Spol: M
OS: Arch Compiz|LXQt Debian
Pa dal koristiš 12.10?
Možeš povući već patcheni fglrx iz quantala:
Kod: Označi sve
wget https://launchpad.net/ubuntu/+archive/primary/+files/fglrx-installer_8.960.orig.tar.gz
wget https://launchpad.net/ubuntu/+archive/primary/+files/fglrx-installer_8.960-0ubuntu5.diff.gz
wget https://launchpad.net/ubuntu/+archive/primary/+files/fglrx-installer_8.960-0ubuntu5.dsc
dpkg-source -x fglrx-installer_8.960-0ubuntu5.dsc
cd fglrx-installer-8.960/
dpkg-buildpackage -rfakeroot -b
Listen, I gotta fight the lion. That's what that guy Scott's all about. I know. I've studied him already.
Avatar
Moderator
Postovi: 1779
Moderator
Postovi: 1779
Pridružen/a: 10 ruj 2010, 11:20
Podijelio/la zahvalu: 9 puta
Primio/la zahvalu: 92 puta
Spol: M
OS: openSUSE Factory KDE
Uspio sam patchati i sagraditi .deb pakete. Instalirao sam drajver i sada sve radi kao i prije.

Hvala vam svima.
Postovi: 121
Postovi: 121
Pridružen/a: 21 srp 2012, 00:36
Podijelio/la zahvalu: 6 puta
Primio/la zahvalu: 1 puta
Spol: M
OS: Arch Compiz|LXQt Debian

Na mreži
Trenutno korisnika/ca: / i 1 gost.