Sada je: 17 ruj 2019, 09:45.
Novi ste u svijetu Linuxa? Imate hrpu početničkih pitanja?

Moderator/ica: Moderatori/ce

Pravila foruma
PRAVILA ZA NOVE KORISNIKE LINUXA!
Prije otvaranja bilo kakve diskusije svaki novi korisnik u svijetu Linuxa obavezan je učiniti sljedeće korake:
Pročitati ove tekstove iz naše Wikipedije:
- Sve uvodne tekstove Linuxa za početnike (njih 5)
- Sve što trebate znati o radu s diskovima
- Pročitati ovu temu za početnike
- Pokušati pronaći riješenje problema u Enciklopediji znanja

Nakon toga korisnik smije otvoriti temu s naslovom svog problema uz obaveznu naznaku Linux distribucije koju koristi u formi:
[Linux distribucija, broj verzije, grafičko okruženje]: Naslov problema
U prvom postu korisnik obavezno mora odgovoriti na ova pitanja:
- Da li ima instalirane Windowse?
- Što ga je motiviralo na instaliranje i korištenje Linux distribucije?
- Obavezno je potrebno navesti specifikacije hardvera (Ime Laptopa, tip procesora, grafičke i mrežne kartice, količina RAM-a i diska)

Bez učinjenih ovih prvih koraka, na teme se neće odgovarati i one će biti izbrisane s foruma!
Moj sistem je dual-boot: Linux Mint 17. 1 Rebecca MATE 1. 8. 1. & Windows 7 Ultimate, hardware je HP Compaq 7800 Small Form Factor. Neka slova na tipkovnici odnedavno nisu na svom mjestu.
Svejedno da li uđem pod Menu/Preferences/Keyboard/ i tamo podesim postavke gumbiju ili to učinim preko Terminala ("sudo dpkg-reconfigure keyboard-configuration"), rezultat je uvijek isti:
Umjesto engleskih karaktera (q,w,x,y) prikazuje hrvatske (lj,nj,z,dž), a umjesto hrvatskih (š,đ,ž,č,ć) prikazuje one za interpunkciju ([]\;'). Ako sam pogodio komande, to izgleda ovako:
Kod: Označi sve
kresica@kresica-HP-Compaq-dc7800-Small-Form-Factor ~ $ sudo dpkg-reconfigure keyboard-configuration
[sudo] password for kresica:
Your console font configuration will be updated the next time your system
boots. If you want to update it now, run 'setupcon' from a virtual console.
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools (0.103ubuntu4.2) ...
update-initramfs: Generating /boot/initrd.img-3.13.0-37-generic
kresica@kresica-HP-Compaq-dc7800-Small-Form-Factor ~ $

Na jednom stranjskom forumu za Linux Mint našao sam thread sa istim problemom kao mojim, a gdje se savjetovalo rješavanje locale en_US.utf.8 fajla prema priloženim kodovima. Ubacio sam ih u Terminal:
Kod: Označi sve
kresica@kresica-HP-Compaq-dc7800-Small-Form-Factor ~ $ sudo dpkg-reconfigure locales
Generating locales...
  en_AG.UTF-8... up-to-date
  en_AU.UTF-8... up-to-date
  en_BW.UTF-8... up-to-date
  en_CA.UTF-8... up-to-date
  en_DK.UTF-8... up-to-date
  en_GB.UTF-8... up-to-date
  en_HK.UTF-8... up-to-date
  en_IE.UTF-8... up-to-date
  en_IN.UTF-8... up-to-date
  en_NG.UTF-8... up-to-date
  en_NZ.UTF-8... up-to-date
  en_PH.UTF-8... up-to-date
  en_SG.UTF-8... up-to-date
  en_US.UTF-8... up-to-date
  en_ZA.UTF-8... up-to-date
  en_ZM.UTF-8... up-to-date
  en_ZW.UTF-8... up-to-date
  hr_HR.UTF-8... up-to-date
Generation complete.
kresica@kresica-HP-Compaq-dc7800-Small-Form-Factor ~ $

Kod: Označi sve
kresica@kresica-HP-Compaq-dc7800-Small-Form-Factor ~ $ sudo update-locale LANG=en_US.UTF-8
kresica@kresica-HP-Compaq-dc7800-Small-Form-Factor ~ $

Kod: Označi sve
kresica@kresica-HP-Compaq-dc7800-Small-Form-Factor ~ $ sudo locale-gen --purge --no-archive
Generating locales...
  en_AG.UTF-8... done
  en_AU.UTF-8... done
  en_BW.UTF-8... done
  en_CA.UTF-8... done
  en_DK.UTF-8... done
  en_GB.UTF-8... done
  en_HK.UTF-8... done
  en_IE.UTF-8... done
  en_IN.UTF-8... done
  en_NG.UTF-8... done
  en_NZ.UTF-8... done
  en_PH.UTF-8... done
  en_SG.UTF-8... done
  en_US.UTF-8... done
  en_ZA.UTF-8... done
  en_ZM.UTF-8... done
  en_ZW.UTF-8... done
  hr_HR.UTF-8... done
Generation complete.
kresica@kresica-HP-Compaq-dc7800-Small-Form-Factor ~ $ sudo update-initramfs -u -k all
update-initramfs: Generating /boot/initrd.img-3.13.0-37-generic
kresica@kresica-HP-Compaq-dc7800-Small-Form-Factor ~ $

Nakon reboota, ponovno sam ušao pod Menu/Preferences/Keyboard/ i promjenio postavke tipkovnice. Bez promjene.
Nadalje je admin savjetovao otvaranje testnog računa pod Menu > Administration > User & Groups te podešavanje postavki tipkovnice od tamo. Opet mi je izgledalo prilično jednostavno pa sam napravio tako. Jedino bilo je uzalud, da li ja podesio gumbe tamo preko Terminala ili preko Menija. Ista 'rošada' u tipkama ostaje i dalje. Mislim da je čak na tom testnom računu bilo još i gore za 1-2 karaktera nego na glavnom računu.
Ulogiram se na Windows svako slovo je na svom mjestu. Jedino hoću više izbjeći taj OS pod svaku cijenu.
Pomoć?
Zadnja izmjena: kresica35; 26 ruj 2015, 06:48; ukupno mijenjano 1 put/a.
Postovi: 18
Postovi: 18
Pridružen/a: 06 srp 2015, 21:05
Lokacija: Zagreb
Podijelio/la zahvalu: 4 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Linux Mint 18.2
Tastatura, koji model? Na usb? Daj rezultat naredbe lsusb
Isto tako možeš postaviti sadržaj iz /etc/default/keyboard.
Avatar
Postovi: 1795
Postovi: 1795
Pridružen/a: 15 sij 2014, 09:37
Lokacija: Zaljev svetaca
Podijelio/la zahvalu: 68 puta
Primio/la zahvalu: 177 puta
Spol:
OS: Leap 15 / Linux Mint 19
Rezultat za "lsusb":
Kod: Označi sve
kresica@kresica-HP-Compaq-dc7800-Small-Form-Factor ~ $ lsusb
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 0bda:8172 Realtek Semiconductor Corp. RTL8191SU 802.11n WLAN Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 1a2c:0c21 China Resource Semico Co., Ltd
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 0458:012b KYE Systems Corp. (Mouse Systems)
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
kresica@kresica-HP-Compaq-dc7800-Small-Form-Factor ~ $


Sadržaj iz /etc/default/keyboard:
# Check /usr/share/doc/keyboard-configuration/README.Debian for
# documentation on what to do after having modified this file.

# The following variables describe your keyboard and can have the same
# values as the XkbModel, XkbLayout, XkbVariant and XkbOptions options
# in /etc/X11/xorg.conf.

XKBMODEL="pc105"
XKBLAYOUT="hr"
XKBVARIANT="unicodeus"
XKBOPTIONS=""

# If you don't want to use the XKB layout on the console, you can
# specify an alternative keymap. Make sure it will be accessible
# before /usr is mounted.
# KMAP=/etc/console-setup/defkeymap.kmap.gz

Koliko vidim u Preferencama, model tipkovnice je Generic 105-key (Intl) PC, nigdje ne piše brand.

Napomena: Neko vrijeme sam koristio Lubuntu 14.04. umjesto Minta (igrom slučaja). Tamo su karakteri bili na svom mjestu - svi.
Postovi: 18
Postovi: 18
Pridružen/a: 06 srp 2015, 21:05
Lokacija: Zagreb
Podijelio/la zahvalu: 4 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Linux Mint 18.2
Sa root dozvolom izmijeni malo taj fajl u /etc/defautl/keyboard:
nzm što ti više odgovara, kroz terminal sa nano, kroz GUI sa gksudo caja
neka ti ovako bude:
Kod: Označi sve
# Check /usr/share/doc/keyboard-configuration/README.Debian for
# documentation on what to do after having modified this file.

# The following variables describe your keyboard and can have the same
# values as the XkbModel, XkbLayout, XkbVariant and XkbOptions options
# in /etc/X11/xorg.conf.

XKBMODEL="pc105"
XKBLAYOUT="hr"
XKBVARIANT=""
XKBOPTIONS=""

# If you don't want to use the XKB layout on the console, you can
# specify an alternative keymap. Make sure it will be accessible
# before /usr is mounted.
# KMAP=/etc/console-setup/defkeymap.kmap.gz

Odnosno, izbriši unicodeus. Spremi, možda se ponovo logiraj ili napravi reboot pa probaj.
Avatar
Postovi: 1795
Postovi: 1795
Pridružen/a: 15 sij 2014, 09:37
Lokacija: Zaljev svetaca
Podijelio/la zahvalu: 68 puta
Primio/la zahvalu: 177 puta
Spol:
OS: Leap 15 / Linux Mint 19
Izrezao unicodeus van kao administrator, spremio i restartao.
U kućici za testiranje postavki tipkovnice pod Menu/Preferences/Keyboard/ dalje izbacuje ljnjzdž umjesto englekih slova a \]['; umjesto naških kvačica.
U LibreOffice isto tako.
Postovi: 18
Postovi: 18
Pridružen/a: 06 srp 2015, 21:05
Lokacija: Zagreb
Podijelio/la zahvalu: 4 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Linux Mint 18.2
A jesi li jednostavno probao:
Kod: Označi sve
setxkbmap hr

odnosno za englesku tipkovnicu:
Kod: Označi sve
setxkbmap us

:zbunj
Arch Linux Install Script
Hash Checker
Vl@do je napisao/la:Arch imaš upravo zato da uštediš na vremenu. Nemaš nikakvih problema s instalacijama, kompajliranjem i ostalim. Imaš jednostavno funkcionalan i stabilan, uvijek najsvježiji OS, a osim toga je sexy i cool do neba.

I've seen some idiots back in my days but you man... you're special!
Avatar
Moderator
Postovi: 6222
Moderator
Postovi: 6222
Pridružen/a: 13 stu 2010, 21:12
Lokacija: /hrvatska/split/.../9/7
Podijelio/la zahvalu: 266 puta
Primio/la zahvalu: 323 puta
Spol: M
OS: Arch MATE/Xfce
Prvi kod za hrvatsku tipkovnicu funkcionira sva slova su na svojim gumbima ali tako samo do rebooota. Kada se opet podigne, karakteri se vrate na staro stanje.
Drugi kod ne postiže ništa nikakvu promjenu u slovima, neovisno o rebootu.
Postovi: 18
Postovi: 18
Pridružen/a: 06 srp 2015, 21:05
Lokacija: Zagreb
Podijelio/la zahvalu: 4 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Linux Mint 18.2
Ovaj tvoj problem me sad podsjetio na ovo:

slika slika

pface

Nema veze s tvojim problemom ali je na kraju riješenje problema isto :place
[+ Prikaži] Klik
ThinkPad T440p
Intel Core i5-4300M
Intel HD Graphics 4600
16GB DDR3L
1xSanDisk X400 512 GB & 1x240GB Intel 2500 Pro
15.6" FHD IPS anti-glare
6 & 9 cell Li-Ion battery
OS: kako kada
Slika: dio kolekcije

***

ZEN
"Charlie. What are you thinking?"
"I'm thinking about what I want and what I need."
"What do you want?"
"I want a peaceful soul."
"And what do you need?"
"I need a bigger gun."
Avatar
Site Admin
Postovi: 10238
Site Admin
Postovi: 10238
Pridružen/a: 01 kol 2012, 12:39
Podijelio/la zahvalu: 573 puta
Primio/la zahvalu: 746 puta
Spol: M
OS: LinuxMint Cinnamon
Kod: Označi sve
kresica@kresica-HP-Compaq-dc7800-Small-Form-Factor ~ $ nano~/.bash_profile
bash: nano~/.bash_profile: No such file or directory
kresica@kresica-HP-Compaq-dc7800-Small-Form-Factor ~ $


U repozitoriju mi stoji kako su paketi 'bash' i 'bash-completition' već instalirani. Isto to stoji za paket 'nano'.
Postovi: 18
Postovi: 18
Pridružen/a: 06 srp 2015, 21:05
Lokacija: Zagreb
Podijelio/la zahvalu: 4 puta
Primio/la zahvalu: 0 puta
Spol: M
OS: Linux Mint 18.2
Kroz dconf-editor to namjesti.
Prvo ga instaliraj ako ga nemaš;
Otvori → org→gnome→desktop→input-sources
Meni stoji pod sources [('xkb', 'hr')]

@bertone
rofl2 ti si još dobro bio prošao :zvizdi
Avatar
Postovi: 1795
Postovi: 1795
Pridružen/a: 15 sij 2014, 09:37
Lokacija: Zaljev svetaca
Podijelio/la zahvalu: 68 puta
Primio/la zahvalu: 177 puta
Spol:
OS: Leap 15 / Linux Mint 19

Na mreži
Trenutno korisnika/ca: / i 1 gost.